Subject: RE: [Entmib] State, Status and URL info

From: Randy Presuhn <[email-masked]>
Date: Tue, 9 Jul 2002 14:21:09 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> From: "Sharon Chisholm" <[email-masked]>
> To: [email-masked]
> Cc: [email-masked], [email-masked], [email-masked], [email-masked]
> Subject: RE: [Entmib] State, Status and URL info
> Date: Thu, 4 Jul 2002 07:41:00 -0400 
...
>   ItuAlarmStatus  ::=  TEXTUAL-CONVENTION
>      STATUS         current
>      DESCRIPTION
>              " Represents the possible values of alarm status
>                (ITU-T X.731)."
>            SYNTAX         INTEGER
>                           {
>                            under-repair(1),
>                            critical(2),
>                            major(3),
>                            minor(4),
>                            alarm-outstanding(5)
>                           }

This one should probably be BITS rather than INTEGER in order to
match the semantics in X.731 (clause 8.1.2.1); note that the
corresponding syntax in X.721 is a set type.  This might be
problematic. CMIP allows specific members of a SET to be added
or removed, thus avoiding multi-manager race conditions that
can happen with read-write BITS.

(Consider the case where manager sets "under-repair" for a
minor alarm, and "critical" is asserted between the read and
the write.)

>   ItuProcStatus  ::=  TEXTUAL-CONVENTION
>      STATUS         current
>      DESCRIPTION
>              " Represents the possible values of procedural status
>                (ITU-T X.731)."
> 
>            SYNTAX         INTEGER
>                           {
>                            initialization-required(1),
>                            not-initialized(2),
>                            initializing(3),
>                            reporting(4),
>                            terminating(5)
>                           }

Same problem.  Should be BITS; semantics in X.731 clause 8.1.2.2;
note that the corresponding syntax in X.721 is a set type.

>   ItuAvailStatus  ::=  TEXTUAL-CONVENTION
>      STATUS         current
>      DESCRIPTION
>              " Represents the possible values of availability status
>                (ITU-T X.731)."
> 
>            SYNTAX         INTEGER
>                           {
>                            in-test(1),
>                            failed(2),
>                            power-off(3),
>                            off-line(4),
>                            off-duty(5),
>                            dependency(6),
>                            degraded(7),
>                            not-installed(8),
>                            log-full(9)
>                           }

Same problem.  Should be BITS; semantics in X.731 clause 8.1.2.3;
note that the corresponding syntax in X.721 is a set type.

>   ItuControlStatus  ::=  TEXTUAL-CONVENTION
>      STATUS         current
>      DESCRIPTION
>              " Represents the possible values of control status
>                (ITU-T X.731)."
> 
>            SYNTAX         INTEGER
>                           {
>                            subject-to-test(1),
>                            part-of-services-locked(2),
>                            reserved-for-test(3),
>                            suspended(4)
>                           }
...

Same problem.  Should be BITS; semantics in X.731 clause 8.1.2.4;
note that the corresponding syntax in X.721 is a set type.  This
might pose a problem; CMIP allows specific members of a SET to
be added or removed, thus avoiding multi-manager race conditions
that can happen with read-write BITS.

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 10 Jul 2002 18:36:33 +0200

I am ignorant of the details in the X.731 / X.721 documents. So from
the ignorant point of view, I am a bit puzzled...

>                            initialization-required(1),

Randy> Same problem.  Should be BITS; semantics in X.731 clause
Randy> 8.1.2.2; note that the corresponding syntax in X.721 is a set
Randy> type.

So I can be initializing(3) and terminating(5) at the same time? Or is
there some state machine that defines which bits may be set?

In short: It would be extremely helpful for people like me if someone
can provide a description of the model behind the proposal.

/js

-- 
Juergen Schoenwaelder    <http://www.informatik.uni-osnabrueck.de/schoenw/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 10 Jul 2002 18:36:33 +0200

/js