Subject: RE: [Entmib] State, Status and URL info

From: Randy Presuhn <[email-masked]>
Date: Tue, 9 Jul 2002 14:33:14 -0700 (PDT)

Hi -

> Message-Id: <[email-masked]>
> Date: Thu, 04 Jul 2002 10:33:28 -0700
> To: "Sharon Chisholm" <[email-masked]>
> From: Andy Bierman <[email-masked]>
> Subject: RE: [Entmib] State, Status and URL info
> Cc: [email-masked], [email-masked], [email-masked], [email-masked],
>         [email-masked]
> In-Reply-To: <[email-masked]
>  l.com>
...
>                         locked(1),
>                         shuttingDown(2),
>                         unlocked(3)
> (2) looks like an operState, not an adminState. I would also replace
> (1) and (3) with enabled and disabled.  Looking through the MIB,
...

No, these really are administrative controls.  Setting the
attribute to locked(1) kicks off any users of the service.
Setting the attributed to shuttingDown(2) prevents new users
from using the service, but does not kick off the current
users.  This way both graceful and abrupt shutdown are possible.
When the last user leaves, shuttingDown transitions automatically
to locked. Figure 6 in X.731 shows the relationship between the
administrative and usage states.  (Figure 4 gives a combined state
diagram that's really quite nice, if a bit harder to digest.)

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Andy Bierman <[email-masked]>
Date: Tue, 09 Jul 2002 15:47:21 -0700

> diagram that's really quite nice, if a bit harder to digest.)

Well the enum names are misleading.  You mention that these
are administrative states applied to services. In that case,
how does this object (maybe the whole MIB) apply to
physical entities?  It sounds like this should apply to
logical entities.

Andy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 09 Jul 2002 15:47:21 -0700

Andy