Subject: Re: [Entmib] State, Status and URL info

From: Randy Presuhn <[email-masked]>
Date: Tue, 9 Jul 2002 16:02:31 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
> Date: Tue, 09 Jul 2002 15:47:21 -0700
> From: Andy Bierman <[email-masked]>
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [Entmib] State, Status and URL info
> References: <[email-masked]>
...
> Well the enum names are misleading.  You mention that these
> are administrative states applied to services. In that case,
> how does this object (maybe the whole MIB) apply to
> physical entities?  It sounds like this should apply to
> logical entities.
...

I think X.731 clause 7.1 sums it up nicely:

| Three primary factors affect the management state of a managed
| object with regard to its corresponding rsources' availability.
| Some managed objects may not be affected by all three of these
| factors.  These are
|
|  - operability: whether or not the resource is physically
|    installed and working, if applicable;
|  - usage: whether or not the resource is actively in use at
|    a specific instant, and if so, whether or not it has spare
|    capacity for additional users at that instant.  A resource
|    is said to be "in use" when it has received one or more
|    requests for service that it has not yet completed or
|    otherwise discharged, or when some part of its capacity
|    has been allocated, and not yet recalimed, as a result of
|    a previous service request;
|  - administration: permission to use or prohibition against
|    using the resource, imposed through the management services.
|
| The state of a managed object does not affect its ability to
| respond to management operations.

As a practical matter, this means that these may be applicable
to both physical and logical entities, and there will be some
entities to which some of these may not apply.  I agree with
your earlier comment about the augmentation being sparse.

This is one of the reasons why X.731 clause 8.1.3 defines the
"state" attribute group.  This lets a CMIP manager ask an
object to return "whatever your state attribute(s) are".

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 09 Jul 2002 23:50:42 -0700

HI,

One of the biggest differences between the ITU model and the "IETF model"
is that in the IETF model the "oper state" follows the admin state,
where in the ITU model the oper state is independent of the admin state.

Resolving the differences (or at least documenting them) between the
ITU and the IETF models (including the physical models (as specified
in M.3100), I believe are the most important and would provide a
great benefit to the SNMP community. But I repeat myself. Sorry.

>object to return "whatever your state attribute(s) are".

Regards,
/david t. perkins

---

From: "David T. Perkins" <[email-masked]>
Date: Tue, 09 Jul 2002 23:50:42 -0700

HI,

Regards,
/david t. perkins