Subject: [Entmib] WG Last Call: Entity State MIB

From: Margaret Wasserman <[email-masked]>
Date: Tue, 08 Jul 2003 08:35:34 -0400

This is an Entity MIB working group last call for comments on advancing the 
following
document as a Proposed Standard:

	Title		: Entity State MIB
	Author(s)	: S. Chisholm, D. Perkins
	Filename	: draft-ietf-entmib-state-01.txt
	Pages		: 22
	Date		: June 2003

The document can be found at:
http://www.ietf.org/internet-drafts/draft-ietf-entmib-state-01.txt

Please send substantive comments to the entmib mailing list, and minor 
editorial
comments to the authors.  This last call period will end on 22-July-2003.

Margaret Wasserman
Entity MIB WG Chair

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 9 Jul 2003 19:49:14 +0300

Here are my comments. They are grouped in two categories, 'substantive' and 'editorial'.

Substantive Comments:

A1) If entStateAdmin is to be made a read-write object, there is a need for more clarity about what values are allowed to be set on write operations. I assume that 'notSupported' is not a writeable value. but how is a physical entity shut down? by setting the value of entStateAdmin to 'shuttingDown' or to 'locked'?
A2) I perceive a problem with the way 'usage state' is being defined and modeled. The distinction between 'active' and 'busy' is not clear. The difference between the two should be whether the entity has spare capacity to serve additional 'users'. A phrase in section 2 mentions that 'In the context of this MIB, the user is equivalent to an entity', and I do not really know how to interpret this. Can entStateUsage of an entity of type powerSupply have a value of 'active' if it does not provide all amperage it is capable of, or only 'busy' is acceptable, as 2.3.4.3 seems to indicate? Same question for a fan, that supports several speeds? 
A3) AlarmStatusTC - what does setting notSupported(0) bit mean? Is not this same as indeterminate(7)?
A4) StandbyStatus TC - I think that there is a need to define a new value for 'load-sharing', even if this is not defined in X.731
A5) Notifications - first the names are very confusing - they are called OperEnabled and OperDisabled, while they carry only entStateAdmin, and entStateAlarm objects. I think that at least entStateOper should be added. It also is not defined when these notifications are supposed to be sent. 
A6) The Security Considerations section should clearly articulate the operational risks of writing on entStateAdmin.
A7) Section 2.2.1 - A corrective action is not necessary in all cases to make an entity available for use. In some cases setting the admin state to unlock should be enough.

Editorial Comments
B1) Intellectual Property section is missing
B2) Entity MIB and entity MIB are capitalized in an un-consistent manner in the document. I suggest to use Entity MIB all over, starting with the Abstract section.
B3) What is the 'existing IETF model' mentioned in the first paragraph of Section 2?
B4) Also in the first paragraph in Section 2, replace 'leveraged' by 'leverage'.
B5) Section 2.1, first paragraph - replace 'addresses' by 'addressed'
B6) Section 2.2 'compares' instead of 'compare'
B7) I understand that 'state' and 'status' are interchangeable in this document, but from a style point of view, the same noun should be used in the same phrase. See second paragraph in 2.2
B8) All section 2.3 should be better organized. The way it is written, it is not clear why some values are being omitted. It would be useful to re-write it in a tabular manner, and be specific what values are relevant for each entPhysicalType and each object.
B9) replace 'chassis' by 'container'
B10) 2.3.5.2 is incomprehensible
B11) 2.3.9.1, 2.3.9.2 - replace 'system' by 'stack'. 
B12) 2.4. - key word not capitalized
B13) several DESCRIPTION clauses in the MIB would gain in readability if enumerated value significance is written in separated lines

I hope this helps.

Regards,

Dan

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]]
> Sent: 08 July, 2003 3:36 PM
> To: [email-masked]
> Subject: [Entmib] WG Last Call: Entity State MIB
> 
> 
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 9 Jul 2003 19:49:14 +0300

Substantive Comments:

Editorial Comments

I hope this helps.

Regards,

Dan