Subject: [Entmib] #322 - Textual Convention Names (Prefix)

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 29 Mar 2004 10:27:51 -0500

hi

<co-editor>
I'm not sure if consensus is fully formed yet, but I wanted to test a view
that it seems to be leaning  in the direction of creating a separate MIB
within this ID to house to textual conventions who's prefix we have not yet
determined? Is that were people are or is more discussion required?
</co-editor>

<Sharon>
I think the term 'Entity' is too limiting if we agree we are going for a
more generic set of TCs. It occurs to be that we use the term 'resource' in
the Alarm MIB when we introduced the concept of a 'ResourceId' as well as
within the description clauses of the TCs in this MIB. Would a prefix of
'ResourceState' work?
</Sharon>

Sharon Chisholm
Portfolio Integration
Nortel Networks
Ottawa, Canada

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 29 Mar 2004 13:49:33 -0800

Hi -

> From: "Sharon Chisholm" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, March 29, 2004 7:27 AM
> Subject: [Entmib] #322 - Textual Convention Names (Prefix)
...
> determined? Is that were people are or is more discussion required?

This seems reasonable to me.
I agree with Dave Perkins' message in this thread that attribute
re-use in the SNMP world is much more difficult than in GDMO-land.
However, it is still possible, and I think the TCs that've been
crafted here do have good potential for giving us some useful re-use
within the constraints of the SNMP SMI.

> within the description clauses of the TCs in this MIB. Would a prefix of

I'd strongly prefer "EntityState" as a prefix.  The word "entity"
is just the college and sci-fi equivalent of "thingie", so I don't see how it
would be limiting.

Randy

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 29 Mar 2004 13:49:33 -0800

Hi -

...

Randy