Subject: Fwd: Re: [Entmib] CLEI Code URN draft

From: Kaj Tesink <[email-masked]>
Date: Mon, 13 Dec 2004 17:27:46 -0500

>Date: Mon, 13 Dec 2004 13:55:57 -0500
>To: [email-masked]
>From: Kaj Tesink <[email-masked]>
>Subject: Re: [Entmib] CLEI Code URN draft
>Cc: [email-masked]
>
>At 06:47 PM 12/10/2004, Juergen Schoenwaelder wrote:
>>On Thu, Dec 02, 2004 at 06:44:15PM -0500, Kaj Tesink wrote:
>>
>> >    The following three examples are based on the examples provided in
>> >    [T1.213a], and correspond with three different sets of features by
>> >    three different manufacturers (Nortel Networks, Lear and Lucent
>> >    Technologies) producing "D4CE" (a particular D4 channel bank type)
>> >    equipment. The fourth example refers to a SONET power unit convertor
>> >    of Alcatel.
>> >
>> >
>> >       URN:CLEI:D4CE18B7AA
>> >       URN:CLEI:D4CE4248AA
>> >       URN:CLEI:D4CE363PAB
>> >       URN:CLEI:SNPWBBC7AA
>>
>>Are these URNs always uppercase? Does case matter here? Would some or
>>all of the following be illegal?
>>
>>         urn:CLEI:D4CE18B7AA
>>         urn:clei:D4CE18B7AA
>>         urn:clei:d4ce18b7aa
>>         urn:CLEI:D4CE18B7AA
>>         URN:CLEI:d4ce18b7aa
>>         URN:clei:d4ce18b7aa
>>         URN:clei:D4CE18B7AA
>>
>>According to RFC 2141, the leading "urn:" sequence is case-insensitive.
>>What about the rest?
>
>
>thanks, good catch; the rest is up to the particular name space.
>in the CLEI case i believe that CLEI codes are always
>uppercase.
>i'll fix that in the CLEI URN name space request
>together with the format issues that Bert found.

i verified with the CLEI gurus; it turns out that while CLEI codes
are usually represented in uppercase, the codes are actually case-insensitive.

as a result, i suggest that we clarify the lexical equivalence clause
as follows:

Rules for lexical equivalence:

Lexical equivalence of two CLEI URN namespace specific strings
is defined as an exact, case-insensitive string match.  CLEI codes
are assigned in a case-insensitive fashion, so that there will
not be two CLEI codes that differ only in case.
See [T1.213] and [T1.213a] for further information.

kaj

>kaj
>
>
>
>>/js
>>
>>--
>>Juergen Schoenwaelder               International University Bremen
>><http://www.eecs.iu-bremen.de/>     P.O. Box 750 561, 28725 Bremen, Germany
>>
>>_______________________________________________
>>Entmib mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/entmib
>
>
>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
>
>Kaj Tesink
>Telcordia Technologies. Inc.
>One Telcordia drive
>Piscataway, NJ 08854
>Email: [email-masked]
>Tel: (732) 699-6068
>Fax: (732) 336-2336
>
>_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies. Inc.
One Telcordia drive
Piscataway, NJ 08854
Email: [email-masked]
Tel: (732) 699-6068
Fax: (732) 336-2336

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 13 Dec 2004 18:32:22 -0800

Hi -

> From: "Kaj Tesink" <[email-masked]>
> To: <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, December 13, 2004 2:27 PM
> Subject: Fwd: Re: [Entmib] CLEI Code URN draft
...
> See [T1.213] and [T1.213a] for further information.
...

Wouldn't it be simpler to say that CLEI codes MUST be upper case?

Randy

---

From: Kaj Tesink <[email-masked]>
Date: Tue, 14 Dec 2004 15:10:46 -0500

>Wouldn't it be simpler to say that CLEI codes MUST be upper case?

maybe so, but as i understand it T1.213 is case-insensitive,
so restricting the URN name space to upper case seems inappropriate.

kaj

Kaj Tesink

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 14 Dec 2004 22:30:03 +0100

> so restricting the URN name space to upper case seems inappropriate.

So then this is fine. I just want to have clarity. Case conversions 
are really trivial since we do not have to deal with international 
character sets. No need to optimize for this I would say.

/js

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 14 Dec 2004 13:53:12 -0800

Hi -

> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Tuesday, December 14, 2004 12:10 PM
> Subject: Re: Re: [Entmib] CLEI Code URN draft
...
...

My concerns are mailnly with regard to the future if these things prove useful.
    1) consider what it would take to describe the behaviour of read-write
        objects that used these (after a write, would the value read be bit-for-bit
        identical, or merely fit the matching rules?)
    2) if they were used for indexing...

If their definition is already case insensitive, then I think we'd really be better
off deciding what their "canonical" representation should be for our purposes.
However, I freely admit this is a theoretical concern, and that if we don't imagine
these being used in other MIB object definitions, there's less need to worry
about it.

Randy

---

From: Kaj Tesink <[email-masked]>
Date: Thu, 16 Dec 2004 15:09:49 -0500

>these being used in other MIB object definitions, there's less need to worry

randy,

i agree that at this stage your point is theoretical but at the same
time we dont want to go in a direction that we may regret later on.
i checked a bit more with the CLEI folks, and the following transpired:
- T1.213 is case-insensitive
- the maintenance agent in practice only assigns codes using uppercase
    representation; the records are kept uppercase
- the maintenance agent can load records in
    lower case and their system will convert it to uppercase
- common representation is usually in uppercase

so in  practice we seem to have two choices for the URN space:
1.sticking with case-insensitive, i.e., be strictly compatible
     with T1.213, or
2.going for uppercase only, which would be compatible with practical use
     but narrow the application of T1.213

any further thoughts?

kaj

Kaj Tesink