Subject: [Entmib] CLEI Code URN draft

From: Kaj Tesink <[email-masked]>
Date: Thu, 02 Dec 2004 18:44:15 -0500

here is the draft for the CLEI URN name space request, which
i'll also forward following the 3406 process.

kaj

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

Kaj Tesink
Telcordia Technologies. Inc.
One Telcordia drive
Piscataway, NJ 08854
Email: [email-masked]
Tel: (732) 699-6068
Fax: (732) 336-2336

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: "David T. Perkins" <[email-masked]>
Date: Fri, 3 Dec 2004 10:46:48 -0800 (PST)

HI,

Draft looks good.

Regards,
/david t. perkins

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 11 Dec 2004 00:47:51 +0100

On Thu, Dec 02, 2004 at 06:44:15PM -0500, Kaj Tesink wrote:
 
>    The following three examples are based on the examples provided in
>    [T1.213a], and correspond with three different sets of features by
>    three different manufacturers (Nortel Networks, Lear and Lucent
>    Technologies) producing "D4CE" (a particular D4 channel bank type)
>    equipment. The fourth example refers to a SONET power unit convertor
>    of Alcatel.
> 
> 
>       URN:CLEI:D4CE18B7AA
>       URN:CLEI:D4CE4248AA
>       URN:CLEI:D4CE363PAB
>       URN:CLEI:SNPWBBC7AA

Are these URNs always uppercase? Does case matter here? Would some or
all of the following be illegal?

	urn:CLEI:D4CE18B7AA
	urn:clei:D4CE18B7AA
	urn:clei:d4ce18b7aa
	urn:CLEI:D4CE18B7AA
	URN:CLEI:d4ce18b7aa
	URN:clei:d4ce18b7aa
	URN:clei:D4CE18B7AA

According to RFC 2141, the leading "urn:" sequence is case-insensitive.
What about the rest?

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany

---

From: Kaj Tesink <[email-masked]>
Date: Mon, 13 Dec 2004 13:55:57 -0500

>According to RFC 2141, the leading "urn:" sequence is case-insensitive.

thanks, good catch; the rest is up to the particular name space.
in the CLEI case i believe that CLEI codes are always
uppercase.
i'll fix that in the CLEI URN name space request
together with the format issues that Bert found.

kaj

Kaj Tesink