Subject: [Entmib] entstate-648 Wordsmith - various (I, J, K, L, M, N )

From: "Sharon Chisholm" <[email-masked]>
Date: Wed, 15 Dec 2004 13:50:24 -0500

#648 Continued ...

<Juergen>
i) In the EntityOperState description, should it not be "therefore"
instead of "there fore"?
</Juergen>

Yes.

<Juergen>
j) The second paragraph in the description of the EntityAlarmStatus
object seems to be garbled.

When no bits of this attribute are set, then none
of the value of under repair is set, the resource is
currently being repaired, which depending on the
implementation, may make the other values in this bit
string unreliable.

Note sure how to repair the beginning. Also, the notion of an
unreliable bit might confuse readers. Perhaps you want to say that
the other bits are not meaningful or something like that.
</Juergen>

Recently introduced error. It is a garble of two separate points.

Propose replacing with

"When no bits of this attribute are set, then no active alarms are
known against this entity and it is not under repair. 

When the 'value of underRepair' is set, the resource is
currently being repaired, which depending on the
implementation, may make the other values in this bit
string meaningful."

<Juergen>
k) Missing final dot in the description of entStateLastChanged.
</Juergen>

Propose adding final dot

<Juergen>
l) I suggest to move the first sentence of the second paragraph in the
description of entStateAdmin to the beginning of the text of the
description clause. Furthermore, I think 'notSupported' must be
replaced by 'unknown'. So the first two paragraphs of the
description clause would read like this:

The administrative state for this entity. This object
refers to an entity's administrative permission to 
service both other entities within its containment 
hierarchy as well other users of its services defined 
by means outside the scope of this MIB.

Setting this object to 'unknown' will result
in an 'inconsistentValue' error. For entities that
do not support administrative state, all set
operations will result in an 'inconsistentValue' 
error.

Also note the addition of the final dot.
</Juergen>

Agree with moving the first sentence of the second paragraph up.

Just noticed that the bit of changing 'notSupported' has been discussed and
closed. No further changes for this closed issue.

Agree to add a final dot.

<Juergen>
m) You do not mention 'testing' in the description of the entStateOper
object.
</Juergen>

Propose adding text

"A value of 'testing' means that entity currently being tested
and cannot there fore report whether it is operational
or not."

<Juergen>
n) Description of entStateAlarm:

"The alarm status for this entity. It does not include
the alarms raised on child components within its
containment hierarchy.

Note that this differs from 'indeterminate' which
means that that alarm state is supported and there
are alarms against this entity, but the severity of
some of the alarms is not known.

I fail to see to what "this" in the beginning of the second
paragraph refers to.
</Juergen>

Recently introduced error. Proposed replacement

"A value of 'unknown' means that this entity is
unable to report alarm state. Note that this differs 
from 'indeterminate' which
means that that alarm state is supported and there
are alarms against this entity, but the severity of
some of the alarms is not known."

Sharon Chisholm
Nortel Networks
Ottawa, Ontario
Canada

_______________________________________________
Entmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/entmib

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 16 Dec 2004 12:22:02 +0100

> implementation, may make the other values in this bit

Something like "may make the other values in this bit string meaningful"
scares me a bit. Is there any way to find out whether the bits are
meaningful, other than knowing the object implementor and having a
beer with her?

What about this (although it does not change the general situation):

  When the 'value of underRepair' is set, the resource is
  currently being repaired. In this situation, it is 
  implementation specific whether the other values in this 
  bit string are meaningful.

(This just avoids the "make meaningful" phrase, which kind of 
 implies that before the transition into underRepair the bits 
 were not meaningful, which I think is not necessarily true.)

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany