Subject: [Extra] Request for feedback - OBJECTID

From: Bron Gondwana <[email-masked]>
Date: Fri, 20 Jul 2018 07:27:19 +1000

Hi All,

Thanks to Pete's very comprehensive GENART feedback, the OBJECTID spec
has changed significantly this week.  Basically all the SHOULDs have
become MUST.
This means that any server supporting OBJECTID will have to have
persistent storage for both EMAILID and MAILBOXID which survives rename
and copy/move.
I'm quite happy with that - my server handles it fine, but if this would
be a problem with your server, now is the time to speak up.  If there
are problems, we can consider multiple CAPABILITY strings, or something
else - but if everyone is fine with everything being MUST, we can go
ahead with something simple and much more robust/trustable for clients.
I'll ask Alexey to hold off on progressing the spec any further until
August 3rd (2 weeks) to allow time for feedback here.
Thanks heaps!

Cheers,

Bron.

--
  Bron Gondwana, CEO, FastMail Pty Ltd
  [email-masked]

---

From: Bron Gondwana <[email-masked]>
Date: Fri, 27 Jul 2018 02:54:44 -0400

Anybody?

If I don't get feedback to the contrary, I'll be asking Alexey to push ahead in a week with the all-new very-MUSTy objectid-06.

Cheers,

Bron.

On Fri, Jul 20, 2018, at 07:27, Bron Gondwana wrote:
> Hi All,
> 
> Thanks to Pete's very comprehensive GENART feedback, the OBJECTID spec has changed significantly this week.  Basically all the SHOULDs have become MUST.
> 
> This means that any server supporting OBJECTID will have to have persistent storage for both EMAILID and MAILBOXID which survives rename and copy/move.
> 
> I'm quite happy with that - my server handles it fine, but if this would be a problem with your server, now is the time to speak up.  If there are problems, we can consider multiple CAPABILITY strings, or something else - but if everyone is fine with everything being MUST, we can go ahead with something simple and much more robust/trustable for clients.
> 
> I'll ask Alexey to hold off on progressing the spec any further until August 3rd (2 weeks) to allow time for feedback here.
> 
> Thanks heaps!
> 
> Cheers,
> 
> Bron.
> 
> --
> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra
>

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 27 Jul 2018 11:36:34 -0500

Just confirming: I got the notice that I should do the re-review for 
GenART by Tuesday for the August 2 telechat. Shall I go ahead with that 
now on -06?

pr

On 27 Jul 2018, at 1:54, Bron Gondwana wrote:

> Anybody?
>
> If I don't get feedback to the contrary, I'll be asking Alexey to push 
> ahead in a week with the all-new very-MUSTy objectid-06.
>
> Cheers,
>
> Bron.
>
>> Thanks to Pete's very comprehensive GENART feedback, the OBJECTID 
>> spec has changed significantly this week.  Basically all the SHOULDs 
>> have become MUST.
>>
>> persistent storage for both EMAILID and MAILBOXID which survives 
>> rename and copy/move.
>>
>> I'm quite happy with that - my server handles it fine, but if this 
>> would be a problem with your server, now is the time to speak up.  
>> If there are problems, we can consider multiple CAPABILITY strings, 
>> or something else - but if everyone is fine with everything being 
>> MUST, we can go ahead with something simple and much more 
>> robust/trustable for clients.
>>

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 27 Jul 2018 17:43:55 +0100

On 27/07/2018 17:36, Pete Resnick wrote:

> GenART by Tuesday for the August 2 telechat. Shall I go ahead with 
> that now on -06?
>
Yes, please!
>     If I don't get feedback to the contrary, I'll be asking Alexey to
>     push ahead in a week with the all-new very-MUSTy objectid-06.
>
>     Cheers,
>
>     Bron.
>
>>     spec has changed significantly this week.  Basically all the
>>     SHOULDs have become MUST.
>>
>>     I'm quite happy with that - my server handles it fine, but if
>>     this would be a problem with your server, now is the time to
>>     speak up. If there are problems, we can consider multiple
>>     CAPABILITY strings, or something else - but if everyone is fine
>>     with everything being MUST, we can go ahead with something simple
>>     and much more robust/trustable for clients.
>>
>>     I'll ask Alexey to hold off on progressing the spec any further
>>     until August 3rd (2 weeks) to allow time for feedback here.
>>
>>     Thanks heaps!
>>
>>     Cheers,
>>
>>     Bron.
>>
>>     --