Subject: Re: [Extra] Benjamin Kaduk's No Objection on draft-ietf-extra-imap-savedate-01: (with COMMENT)

From: Stephan Bosch <[email-masked]>
Date: Fri, 5 Oct 2018 15:45:06 +0200

Hello Mr. Kaduk,

Op 25-9-2018 om 16:11 schreef Benjamin Kaduk:
> Benjamin Kaduk has entered the following ballot position for
> draft-ietf-extra-imap-savedate-01: No Objection
>
> When responding, please keep the subject line intact and reply to all
> email addresses included in the To and CC lines. (Feel free to cut this
> introductory paragraph, however.)
>
>
> Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
> for more information about IESG DISCUSS and COMMENT positions.
>
>
> The document, along with other ballot positions, can be found here:
> https://datatracker.ietf.org/doc/draft-ietf-extra-imap-savedate/
>
>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> Section 1
>
>     to permanently remove (expunge) all messages in that Trash mailbox
>     deleted before a certain time (e.g. a configurable expiration
>
> nit: comma after "e.g.".
OK.

>
> Section 4.2
>
> Should there be an example for the 'NIL response' case?

I don't think that is highly important, but I guess we can add a small 
example for that. The modified text will then be something like:

    Example for selected mailbox with SAVEDATE support:

          C: A101 FETCH 998 (SAVEDATE)
          S: * 998 FETCH (SAVEDATE "01-Jan-2015 18:50:53 +0100")
          S: A101 OK Fetch completed.

    Example for selected mailbox without SAVEDATE support:

          C: A101 FETCH 123 (SAVEDATE)
          S: * 123 FETCH (SAVEDATE NIL)
          S: A101 OK Fetch completed.

Kind regards,

-- 

Stephan Bosch
Senior Developer

Phone: +49 2761 75252 00  Fax: +49 2761 75252 30
Email: [email-masked]

-------------------------------------------------------------------------------------
Open-Xchange AG,  Rollnerstr. 14, 90408 Nuremberg, District Court Nuremberg HRB 24738
Managing Board: Rafael Laguna de la Vera, Carsten Dirks, Uwe Reumuth
Chairman of the Board: Richard Seibt

Dovecot Oy, Lars Sonckin Kaari 10, 02600 Espoo, Finland
Managing Director: Markku Kenttä
Chairman of the Board: Timo Sirainen
Board Member: Carsten Dirks

-------------------------------------------------------------------------------------

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 5 Oct 2018 12:49:28 -0500

Hi,

>           S: A101 OK Fetch completed.

This was just a question I had while reading, and I'm not sure what the
best path is.  I promise to not be offended if you leave this example out
-- do what you think is best.  I do appreciate seeing what the example
looks like, even here in mail, though -- thank you!

-Benjamin