Subject: [Extra] QUOTA: representing "no limit" while still giving counts

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 20 Nov 2019 19:06:12 +1100

An issue I've had with QUOTA in the past is that I've set a limit on storage but not on "number of messages". Internally, our server is storing all the counts, but it has "-1" (aka: unlimited) as the limit.

There's no way in the wire protocol to indicate this. I'm not sure if it's possible to do it in a backwards compatible way other than just say "use UINT32_MAX for unlimited", but it would be nice to define that in the spec and tell clients to treat UINT32_MAX in that field as "unlimited" for display purposes.

Cheers,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 20 Nov 2019 20:38:07 +1100

On Wed, Nov 20, 2019, at 20:36, Timo Sirainen wrote:
> On 20. Nov 2019, at 10.06, Bron Gondwana <[email-masked]> wrote:
>> 
> What's wrong with just not sending the MESSAGE reply when it's unlimited?

Sometimes it's nice to know how much of something you have even when you don't have a limited bucket.

Bron.

---

From: Timo Sirainen <[email-masked]>
Date: Wed, 20 Nov 2019 11:36:21 +0200