Subject: I-D ACTION:draft-ietf-fax-terminal-mode-goals-00.txt

From: [email-masked]
Date: Wed, 27 Jun 2001 07:02:48 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Fax Working Group of the IETF.

	Title		: Goals for Terminal Mode
	Author(s)	: T. Maeda
	Filename	: draft-ietf-fax-terminal-mode-goals-00.txt
	Pages		: 5
	Date		: 26-Jun-01
	
This draft describes goals of Terminal Mode which was proposed 
in ITU-T SG16 meeting on November 2000 at Geneva.  The Terminal 
Mode supports the transfer of image data, capabilities exchange and 
confirmation for Store and Forward internet fax terminals having 
limited memory and small CPU power.  Terminal Mode also supports all 
features of Group 3 facsimile on the Internet using T.30 signals in 
capability exchange.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-fax-terminal-mode-goals-00.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-fax-terminal-mode-goals-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-fax-terminal-mode-goals-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 27 Jun 2001 09:47:40 -0700

IPP is more suitable for these goals than SMTP.

-d

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of [email-masked]
> Sent: Wednesday, June 27, 2001 4:03 AM
> To: IETF-Announce:
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-fax-terminal-mode-goals-00.txt
>
>

---

From: "MAEDA Toru" <[email-masked]>
Date: Thu, 28 Jun 2001 19:11:32 +0200

Hi, Wing-san

Thank you for your comments.

Since Terminal Mode should fall back to Full Mode or Simple Mode,
ESMTP is more preferable than IPP.

Regards.

Toru Maeda

-- 
***********************************
MAEDA TORU
Canon Research Centre France S.A.
***********************************

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 28 Jun 2001 10:39:33 -0700

I'm unclear on why the ability to fallback requires the original attempt be in
SMTP.

The goals document also says that "Use of Existing Infrastructure" is a goal.
You do know that the existing infrastructure doesn't permit connecting
directly from Internet hosts to internal SMTP servers?

-d

> From: MAEDA Toru [mailto:[email-masked]]
> Sent: Thursday, June 28, 2001 10:12 AM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-fax-terminal-mode-goals-00.txt
>
>
> Hi, Wing-san
>

---

From: Dave Crocker <[email-masked]>
Date: Sat, 30 Jun 2001 10:54:44 -0400

>I'm unclear on why the ability to fallback requires the original attempt be in

The more the modes have in common, the more code they share.  That means 
that the different modes have less to implement.

There also might be operational impact, such as retaining an SMTP connection.

Retaining interworking with email continues to be a nice ability, too.

It also makes it easier to evaluate the efficacy of each, different 
mode.  The fewer modes the better/simpler.

d/

----------
Dave Crocker  <mailto:[email-masked]>
Brandenburg InternetWorking  <http://www.brandenburg.com>
tel +1.408.246.8253;  fax +1.408.273.6464

---

From: "Dan Wing" <[email-masked]>
Date: Sat, 30 Jun 2001 17:42:39 -0700

Yes, shared code is good.

"Fax terminal mode" is an end-to-end service which has much more in common
with PSTN fax and T.38 fax than the SMTP model of multiple hops, storing mail,
mailing lists, etc.

IPP has more in common with transmitting documents than SMTP, and I still say
that IPP can provide something more closer approaching the goals of "fax
terminal mode" than SMTP.

For universal messaging, T.37/RFC2305 is the way to go.  For duplication of
exact fax functionality on an IP network, T.38 is the way to go.  While T.38
is more difficult than an IETF text-based protocol, forcing SMTP to
essentially do 'SAML' (everyone by Dave, see RFC821 for a description of SAML)
across multiple hops is hard.

If you want something easier than T.38, IPP exists.  IPP can be enhanced as
needed to support the features necessary to replicate fax.

-d

> From: Dave Crocker [mailto:[email-masked]]
> Sent: Saturday, June 30, 2001 7:55 AM
> To: Dan Wing
> Cc: MAEDA Toru; [email-masked]
> Subject: RE: I-D ACTION:draft-ietf-fax-terminal-mode-goals-00.txt
>
>