Subject: Re: I-D ACTION:draft-ietf-fax-faxprocessing-status-00.txt

From: "MAEDA Toru" <[email-masked]>
Date: Mon, 02 Jul 2001 19:28:49 +0200

Hi, Wing-san

We need further discussion about the valid "codes".
Do you have any idea about it?

Regards.

Toru Maeda

Dan Wing wrote:
> 
> Hi.
> 
> This I-D shows the following:
> 
>   2.   MDN extension
>   To send fax prosessing status from the receiver, MDN extension field
>   is used for results, received page number and error page number.
> 
>   MDN extension field:
>   Fax-Report: Fax-Results = code
>              ; Fax-Pages = received page number
>              ; Fax-Errorpage = error page number
> 
> What are the valid "codes"?
> 
> -d
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On
> > Behalf Of [email-masked]
> > Sent: Wednesday, June 27, 2001 4:03 AM
> > To: IETF-Announce:
> > Cc: [email-masked]
> > Subject: I-D ACTION:draft-ietf-fax-faxprocessing-status-00.txt
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > This draft is a work item of the Internet Fax Working Group of the IETF.
> >
> >       Title           : Fax Processing Status
> >       Author(s)       : T. Maeda
> >       Filename        : draft-ietf-fax-faxprocessing-status-00.txt
> >       Pages           : 4
> >       Date            : 26-Jun-01
> >
> > This proposal describes a fax processing status which was requested
> > in ITU-T SG16 meeting on November 2000 at Geneva, for Full Mode.
> > The notification of success/failure of document processing and page
> > by page status from the receiver is very important feature for the
> > internet fax.
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-fax-faxprocessing-sta
> > tus-00.txt
> >
> > Internet-Drafts are also available by anonymous FTP. Login with the username
> > "anonymous" and a password of your e-mail address. After logging in,
> > type "cd internet-drafts" and then
> >       "get draft-ietf-fax-faxprocessing-status-00.txt".
> >
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> >
> >
> > Internet-Drafts can also be obtained by e-mail.
> >
> > Send a message to:
> >       [email-masked].
> > In the body type:
> >       "FILE /internet-drafts/draft-ietf-fax-faxprocessing-status-00.txt".
> >
> > NOTE: The mail server at ietf.org can return the document in
> >       MIME-encoded form by using the "mpack" utility.  To use this
> >       feature, insert the command "ENCODING mime" before the "FILE"
> >       command.  To decode the response(s), you will need "munpack" or
> >       a MIME-compliant mail reader.  Different MIME-compliant mail readers
> >       exhibit different behavior, especially when dealing with
> >       "multipart" MIME messages (i.e. documents which have been split
> >       up into multiple messages), so check your local documentation on
> >       how to manipulate these messages.
> >
> >
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> >

-- 
***********************************
MAEDA TORU
Canon Research Centre France S.A.
***********************************

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 2 Jul 2001 11:02:51 -0700

Enumerate the T.30 error codes, I guess, as this is very T.30 specific.  Text
needs to be added that transmission should be ceased when an error page is
encountered (again, very T.30 specific).  There should be codes added for
'unable to process TIFF file' or 'invalid TIFF file' -- for example, if the
email is marked clearly as 'image/tiff', but the attachment is really a PDF
file or a Microsoft Word document, or a JPG, etc., it isn't a valid TIFF and
this can't be assigned a T.30 error code.

So, I would say some ABNF like this:

  code = attachment_code | t30_code
  t30_code = "T30" ... all of the T30 codes ....
  attachment_code = "Attachment" att_code
  att_code = "unable to process attachment as TIFF" |
             "invalid pointer in TIFF"

Where "... all of the T30 codes ...." enumerates all of the error codes from
T.30 into a textual or numeric ASCII format -- not binary.

Comments from anyone on this?

-d

> From: MAEDA Toru [mailto:[email-masked]]
> Sent: Monday, July 02, 2001 10:29 AM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-fax-faxprocessing-status-00.txt
>
>
> Hi, Wing-san
>
> > >       "FILE
> /internet-drafts/draft-ietf-fax-faxprocessing-status-00.txt".
> > >

---

From: "MAEDA Toru" <[email-masked]>
Date: Sat, 07 Jul 2001 01:16:24 +0900

Hi, Wing-san

Thank you very much for the idea of error code.

I prefere to use numeric ASCII format for the error code,
since users can not understand a English text message for the error code
in Japan.
The device should transrate into local language message from the numeric
ASCII for the error code.

Regards.

Toru Maeda

-- 
*********************************
MAEDA Toru
CANON Research Centre France S.A.
*********************************

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 9 Jul 2001 09:52:33 -0700

I agree -- numeric is better.  But all of the acceptable values need to be
enumerated.

-d

> Sent: Friday, July 06, 2001 9:16 AM
> To: Dan Wing
> Cc: [email-masked]