Subject: Re: WG LAST CALL of draft-ietf-forces-requirements-03.txt - May 1 0-24

From: Ram Dantu <[email-masked]>
Date: Thu, 16 May 2002 15:06:11 -0500

Alex,
Please see my comments below.

Regards
Ram Dantu

-----Original Message-----
From: Alex Audu [mailto:[email-masked]]
Sent: Wednesday, May 15, 2002 4:41 PM
To: [email-masked]
Subject: WG LAST CALL of draft-ietf-forces-requirements-03.txt - May 1
0-24

David,

I am new to this mailing list, though I have been following the FORCes
effort for a while
and I have the comments about the requirements draft.

Section 6 (FE Model Requirements) . Since the logical functions of the
FE can be programmed
or selected by the CE,  it also makes sense to allow the capabilities of
those logical functions
to be programmed by the CE.  That way, it may not be necessary for the
CE to querry for the
capabilities of the FE before using it (since it already knows this by
virtue of being the programmer).
Can you add language here to clarify this?

[RD.Start] I assume that these queries happen during ForCES initialization
as well as due to changes in FE resources.
[RD.End]

Section 6.5 (Minimal Set of Logical Functions). Shouldn't we also
specify a minimum set of
functional/logical blocks every FE must contain? This will be akin to a
minimum toolset that
could be cobbled together to implement any of the main set of  packet
handling behaviors in a FE.
[RD.start] Imposing a minimal set may be a controversial subject. However,
we can say forwarding function is the minimum function. In the framework/architecture
document, we have mentioned some FE and CE functions.
[RD.End]

Also, are there any unique CE Model Requirements  identifiable?

[RD.Start] Each CE shall have to support one or more functions
that are related to controlling a particular FE. These functions
have to identified on a FE by FE basis by the FE/CE managers.
[RD.End]

Regards,
Alex.

> -----Original Message-----
> From: Putzolu, David [mailto:[email-masked]]
> Sent: Friday, May 10, 2002 4:14 AM
> To: [email-masked]
> Subject: WG LAST CALL of draft-ietf-forces-requirements-03.txt - May
> 10-24
> Importance: High
>
>
> All,
>
> This message marks the beginning of a last call
> for the ForCES requirements document.
>
> The last call period begins immediately and lasts
> until Friday, May 24th, 2002, at midnight GMT.
>
> Document URL:
> http://www.ietf.org/internet-drafts/draft-ietf-forces-requirem
ents-03.txt

Thanks,
David

---

From: Alex Audu <[email-masked]>
Date: Fri, 17 May 2002 09:47:21 -0500

Ram,

My comments were intended to try to reconcile the spirit of ForCES with that
expressed in P1520 (IEEE Programmable Interface for Network Elements).
In P1520, some resource building blocks are identified (e.g. classifiers, meters,
scheduler, queue, marker, dropper, shapper, counter, multiplexor,..), from
which services can be built. These allign with the logical functions identified in the
FE model.  We can definitly identify some minimum set of logical functions necessary
to realize a viable forwarding function in an FE.  May be some langauage can be
added to recommend a minimum set?

>have to identified on a FE by FE basis by the FE/CE managers.

Can we then add a CE Model Requirements section to the draft and
identify CE's requirements there?

Regards,
Alex.