Subject: FW: submitted draft-ietf-forces-requirements-03.txt to IETF

From: "(Ram Gopal )" <[email-masked]>
Date: Tue, 29 Jul 2003 10:39:29 -0400

Hello Jamal,

We had  this discussion sometime back on this issue both on the design mailing list and in 
teleconference.

Please find the email which avri sent out and it seems everyone agreed at that time to close the issue. 

Regards
Ramg

> -----Original Message-----
> From: avri [mailto:[email-masked]] 
> Sent: Monday, April 29, 2002 11:48 AM
> To: Khosravi, Hormuzd M
> Cc: Yang, Lily L; 'Margaret Wasserman'; [email-masked]';
> [email-masked]'; [email-masked]'; [email-masked]';
> Anderson, Todd A; [email-masked]'; Putzolu, David;
> [email-masked]'; 'Vip Sharma'
> Subject: Re: submitted draft-ietf-forces-requirements-03.txt to IETF
> 
> 
> I agree. it is enough that the applicabiity requirements doc
> will impose the restriction. i don't think it belongs in the
> requirements. we just define how it would be done if it were
> done.
> 
> the definiton of close proximity is still fuzzy, and i would
> like to see it stay that way. if we take it on in this doc
> we will need to define it.
> 
> a.
> 
> Khosravi, Hormuzd M wrote:
> 
> > Good point, but I am not sure if we should cover this or just
> > let the applicability statement talk about it. From what I 
> understood
> > in the last IETF meeting, the applicability statement is being used
> > as "anti-requirements", so as long as we don't contradict it, we
> should
> > be fine.
> > 
> > my 2 cents
> > Hormuzd
> > -----Original Message-----
> > From: Yang, Lily L 
> > Sent: Monday, April 29, 2002 11:10 AM
> > To: Khosravi, Hormuzd M; 'avri'; 'Margaret Wasserman';
> [email-masked]';
> > [email-masked]'; [email-masked]'; [email-masked]';
> > Anderson, Todd A; [email-masked]'
> > Cc: Putzolu, David; [email-masked]'; 'Vip Sharma'
> > Subject: RE: submitted draft-ietf-forces-requirements-03.txt to IETF
> > 
> > 
> >  In light of the recent discussion on the mailing list regarding
> proximity,
> > I find it odd that the requirement draft didn't mention 
> much about the
> > issue. The only relevant text I find is the following in section 7.
> ForCES
> > Protocol Requirements:
> > "4)Multihop 
> >    When the CEs and FEs are separated beyond a single hop, 
> the ForCES 
> >    protocol will make use of an existing RFC2914 compliant 
> L4 protocol
> 
> >    with adequate reliability, security and congestion control (e.g. 
> >    TCP, SCTP) for transport purposes."
> > 
> > I think we probably ought to say a bit more on the subject 
> -- what is
> MUST,
> > what is MAY or SHOULD, etc..
> >  
> > Lily
> > 
> > 
> >>-----Original Message-----
> >>From: Khosravi, Hormuzd M 
> >>Sent: Friday, April 26, 2002 5:13 PM
> >>To: 'avri'; 'Margaret Wasserman'; [email-masked]'; 
> [email-masked]';
> >>[email-masked]'; [email-masked]'; Anderson, Todd A;
> >>[email-masked]'
> >>Cc: Putzolu, David; [email-masked]'; Yang, Lily L; 'Vip Sharma'
> >>Subject: submitted draft-ietf-forces-requirements-03.txt to IETF
> >>
> >>
> >>Hi All
> >>
> >>I have submitted the new version 03 of the draft to the IETF.
> >>Its attached with this mail. I think its ready for last call,
> >>please do let me know what you think.
> >>
> >>Thanks
> >>Hormuzd
> >>
> >>
> > 
> 
> 
> -- 
> Mobile: +46 73 029 8019
> Office: +46 920 49 3030
> In US:  +1 401 663 5024
> 
> http://homepage.bethepeople.com/display/mp_page.php?page_id=5776
> 
> 
> 
> 
>

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 29 Jul 2003 01:26:19 -0400

hi Ram,

Noted (I think i wasnt paying attention to that exchange):

I think the term "single hop" is infact very ambigous.It could be a
single hop via a L3 or L2 tunnel which may imply that there are infact
many many devices between the CE and FE. It could be a hub or a mere
switch between them. I think vicinity description is more reflective of
what it really is supposed to mean.

I dont wanna have a description which sits in a requirements then 5
years from now have engineer-lawyers(engineers who pretend to be
lawyers).

cheers,
jamal

---

From: Margaret Wasserman <[email-masked]>
Date: Tue, 29 Jul 2003 19:53:49 -0400

Hi Jamal,

It might be possible to further clarify the term "single hop" to
make it explicit that it is referring to a layer 3 routing hop,
but I'm not sure that it is necessary.

The requirement doesn't forbid using an RFC 2914-compliant L4
protocol in other cases, and it would probably be advisable
in cases where the FORCES protocol is used over a complex
single-hop network (with multiple LAN segments bridged or
switched at layer 2), but I don't think that we want to make
this a requirement.

Margaret

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 29 Jul 2003 18:41:41 -0700

Margaret,

The "doesnt forbid"  part of your email is the kind of statement that
worries me. Sure you can get rid of this ambiguity over what "single hop"
means by using RFC 2914-compliant L4 transport. We really oughta fix the
document not the protocol. I am in agreement on simple and complex
hops concept. I would be satisfied if that language is added to clarify
things. I still think the language in the charter is sufficient and the
best description to use.

I'll tell you what i am bothered with:
I am not trying to stop anybody from using TCP over a interconnecting
switch (clearly a single hop); on the same token, i dont expect that
language which enforces such a requirement. It does not harm to clarify.

cheers,
jamal

---

From: avri <[email-masked]>
Date: Wed, 30 Jul 2003 14:30:48 +0900

Hi,

Oh, we here again.

On tisdag, jul 29, 2003, at 14:26 Asia/Seoul, Jamal Hadi Salim wrote:

> I think the term "single hop" is infact very ambigous.

I have to agree.  In the requirements document, there are 4 references
to hop.  Each other time, it is designated whether we are talking about
an IP address hop or a MAC address hop.  In this case we are talking
about an IP address hop, I believe - at least if we mean the same thing
as we mean in 6e - but we don't say so .  The draft should probably be
clarified to say so.

> It could be a

And here I have to disagree. We decide to leave the discussion, and
definitions, of vicinity out of this document.  As I was quoted as
saying, defining these terms requires effort.  At this point, having
concluded WG last call and having responded to IESG comments I don't
believe it is time to open up the draft and insert language that still
needs to be sufficiently defined.  And while the charter is a good
reference for defining what we may or may not work on as WG efforts,
it seems a poor reference for definitional items.  In this cause I
think it is suffiicient to just clarify this one ambiguous reference to
hop.

a.

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 30 Jul 2003 15:06:03 -0400

It is fine with me if we clarify the use of the term "single hop"
in this instance to refer to a L3 routing hop.

I agree with Avri that we shouldn't make significant requirement
changes at this point.

Margaret

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 31 Jul 2003 11:08:43 -0400

<sigh> I too dont wanna make any major changes to the requirements this
late into the game. That description is better than what is in there
already. So if thats the minimalist change to be made, so be it.I just
hope it is not misinterpreted in the future.

cheers,
jamal