Subject: Re: WG question: Accept draft-yang-forces-model-02.txt as WG doc?

From: "Renwick, John (John)" <[email-masked]>
Date: Mon, 28 Jul 2003 14:11:51 -0400

Hi Alan,

What Weiming is describing looks to me like what NPF has been
calling a "Director" block, which directs a packet to one of
two or more other blocks depending on the value of a metadata
"tag."  A few  months ago in one of the plenaries I asked
whether a Classifier block could "goto" multiple other blocks,
i.e. could it have an internal director.  The prevailing view
then was that a Classifier should simply assign a tag to a
packet, and the director function should be external to it.
From that I conclude that NPF (at least) needs a director LFB.

If that is indeed what Weiming is describing, then NPF has
seen the need for it, anyway.

Regards,

John

--
John Renwick                          Agere Systems
Software Technical Manager            1230 Northland Drive
Phone: (651) 675-2986                 Mendota Heights, MN 55120
FAX:   (707) 897-7928                 Cell:  (612) 669-9397
mailto:[email-masked]             http://www.agere.com

> -----Original Message-----
> From: Alan DeKok [mailto:[email-masked]]
> Sent: Sunday, July 27, 2003 8:50 PM
> To: [email-masked]
> Subject: Re: WG question: Accept
> draft-yang-forces-model-02.txt as WG doc?
>
>
> > Weiming Wang wrote:
>
> > 2. For FE block library, I recommend to add a quite functionarily
> > universal block, which may be called a match block,show in following
> > figure,
> ...
> > This block is insidely composed of a rule base and a matching
> > mechanism.
>
>   I don't see how this block is different than the classifier blocks
> which already exists in the document.  The classifier block
> already has
> internal state S, which encompases the "rule base" on which
> it makes its
> decisions.
>
> > It just does match according to the rule and outputs IP
> > packets according to the rule's action to specific egresses. This
> > block can be applied to classification, filtering, modifying,
> > routing(forwarding),and even dropping.
>
>   A block which is good for everything is good for nothing.
>
>   The whole purpose of having multiple FE logical blocks is to clearly
> define functionality.
>
>   You appear to be asking that every block contain a "match" (or
> classifier) block as part of its function.  Section 5.2.4, which
> describes the classifier block specifically addresses this
> misconception.
>
>   When a block uses some of its internal configuration to
> decide how to
> process input data, that block is NOT performing
> classification.  It is
> simply making local decisions which are internal to that block, and
> which are invisible outside of that block.  (Other than as edited
> packets, etc.)
>
>   The FE Classifier Block produces externally visible classification
> results, which is its purpose.
>
> > By using this block, ForCES
> > protocol may be more uniformly and simpl made, since attributes for
> > these block functions can maily be abstracted as rules,
> what we should
> > do is to add rules, delete rules, etc.
>
>   All you are saying here is that an FE block may have configuration
> data, which a CE may update or edit.  We do not need an
> additional block
> to describe this functionality.
>
> > For fear the message might not display correctly because of the txt
> > figure, I'v made a copy in Word in the attachment.
>
>   You should put such a the document on a web page, in a form
> that other
> people can read.  You have enough ideas that I suggest you write an
> internet-draft which summarizes your work.
>
>   Alan DeKok.
>

---

From: Alan DeKok <[email-masked]>
Date: Sun, 27 Jul 2003 23:08:39 -0400

"Renwick, John (John)" wrote:
> "tag."

  Please read Section 5.1.6 of the model document.  It specifically
defines a "redirector" block which uses metadata to perform its
redirection.

  Please also read Section 5.2.5 of the model document.  It specifically
addresses the concept of a classifier which redirects the packet to one
of N outputs.  That section also addresses the benefits and limitations
of the "redirection" model of a classifier, versus a non-redirecting
classifier, as in Section 5.2.4.

>  A few  months ago in one of the plenaries I asked

  From what I read of his message, he was saying that *every* block
would have a "match" block as part of its function.  This is a concept
which was proposed at NPF, and to which I am steadfastly opposed.  As I
said in my response to Weiming, the text in the model document
specifically addresses and refutes this issue.

  Alan DeKok.