Subject: Re: New draft "ForCES FE Functional Model Elements"

From: "Yang, Lily L" <[email-masked]>
Date: Sun, 6 Jul 2003 20:27:30 -0700

Hi, Zsolt and Steve --

First of all, congratulation on a job well done and a draft well written! I hate the fact that I had to squeeze in time for IETF draft reading in the midst of firework, BBQ, and beach combing over the long weekend, but luckily I found myself actually enjoy reading your draft on FE model. Thank you :-)

We've also just sent out an updated version of our contribution on FE model. Hopefully you will agree with me that there is quite some synergy between the two. 

I particularly like Section 5 in your draft which calls out a list of open issues very explicitly and this is a good way to move the discussion forward. Here is just some random thoughts while reading this draft:

1) There might be a subtle but significant difference in the goal of inter-operability that is worth calling out here: I believe the goal of ForCES, at least as the first order goal, is to enable inter-operability of CEs and FEs from different vendors; not yet the inter-operability of LFBs from different vendors. The inter-operability of LFBs is a much more ambitious goal than that of CEs and FEs. 

2) In your discussion in 5.2 (level of detail in LFB spec), 5.3 (packt format def), 5.4 (meta-data def), the kind of specifications that you suggest necessary seems to aim toward more ambitious inter-operability between LFBs from different vendors. We probably want to examine our exact goal more carefully here. For example, in 5.4, it is said, "A standardized metadata encoding protocol should be defined." But I don't think such a protocol is needed if the goal is less ambitious.

3) I very much like the discussion you have in 5.5, 5.6 and 5.7 around the topological versus encoded state approach. I agree with the design guidelines you provided there regarding the limit of topological approach to functionally different and static datapaths. 

4) This one sentence puzzles me though in 5.6: "we assume that the model allows for connecting more than one LFB output to a single LFB input". Don't you need a MUX to do that?

5) I also strongly agree with you on the different requirements for FE topology and LFB topology configuration (our draft uses the terminology of FE Block Topology): FE topology should NOT be configurable while LFB topology should be.

6) The discussion on meta-data (5.10 & 5.11) is very important and necessary. We also realize the importance of meta-data on FE model in our draft but we didn't discuss the actual mechanics of meta-data production and consumption. As Joel pointed out in his posting, meta-data is one of the things that we know we need to talk about but have not made up our mind as how to proceed. That is why I am especially pleased to see that you did try to address the issue. But again, I think we ought to carefully examine how much is absolutely necessary in order to just ensure FE-CE inter-operability first (but NOT LFB inter-opeability). 

7) I think Section 6 (FE model library) makes a good point that the actual language for model library definition is mostly for human understanding and encoding, and so it can be separate from the over-the-wire encoding scheme that is more performance sensitive. So we can choose XML as the model def language while still use binary encoding for the information element encoding in the protocol. 

8) The "resources" in this draft is called "internal state S" in our draft. I believe the only difference is in the terminology. 

I look forward to meeting you and Steve at Vienna and hope that we can move the discussion forward!

Thanks,
Lily

> -----Original Message-----
> From: Joel M. Halpern [mailto:[email-masked]]
> Sent: Tuesday, July 01, 2003 2:13 PM
> To: [email-masked]
> Subject: Re: New draft "ForCES FE Functional Model Elements"
> 
> 
> An interesting and useful approach to describing this.
> 
> Allow me to use this document as a hook to raise a question 
> that I think we
> have all been skirting.  Our documents talk about supporting and using
> meta-data.  Most of us assume that meta-data (support and usage) is
> important for getting workable solutions.
> 
> However, I suspect that we have as many models of meta-data as we have
> participants.  This document has one model in it (a collection of
> name-value pairs).  I have seen many others (including arbitrary text
> strings, arbitrary bit strings, a stack of name-value pairs,
> etc.  Different models treat the consumption of metadata
> differently.  (This one says you consume what you do not 
> explicitly pass
> on.  Others state that you pass on what you do not explicitly
> consume.  Others take different views.)
> 
> 1) It strikes me that we should be careful to be explicit whenever we
> assume a model of metadata usage.
> 2) I would personally like to concentrate on getting the core 
> work done,
> leaving the meta-data unspecified at first.  I think this has 
> the best hope
> of our getting a usable result in a modest amount of time.
> 3) If we are going to work on meta-data, I would like to treat it as a
> separate work item, and get moving on it.
> 
> Yours,
> Joel M. Halpern
> 
> PS: This is not a criticism of the Haraszti / Blake document.  This
> document is pretty good about explicitly describing its 
> meta-data model,
> particularly since this issue has not been raised in the 
> group thus far.
> 
> At 04:27 PM 7/1/2003 -0400, you wrote:
> >Zsolt Haraszti and I have put together a draft on the elements needed
> >for the ForCES FE functional model.  It is complimentary to
> >draft-yang-forces-model.  Since we missed the deadline for I-D
> >submissions, I have placed the draft at
> >
> >http://www.petri-meat.com/slblake/networking/drafts/draft-har
aszti-forces-model-00.txt
>
>We hope that this contribution helps move the model definition effort
>forward.  Any comments would be appreciated.
>
>
>Regards,
>
>=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>Steven L. Blake               <[email-masked]>
>Ericsson IP Infrastructure                +1 919-472-9913

---

From: Zsolt Haraszti <[email-masked]>
Date: Thu, 10 Jul 2003 15:33:42 -0300

Hi Lily,

Thank you very much for the positive comments on our draft.

I need to rush to the airport to catch my flight now, but I am
looking forward to meeting you at the IETF and working with you
in this area.

I am sure we will have many opportunities to go over the technical
issues at the meeting and/or on the mailing list after the meeting.

Cheers,
Zsolt

--
Zsolt Haraszti                                     Tel: +1 919 472 9949
Ericsson IP Infrastructure                         Fax: +1 919 472 9999
Raleigh NC USA                       Email: [email-masked]