Subject: Re: I-D ACTION:draft-khosravi-forces-tcptml-01.txt

From: "Putzolu, David" <[email-masked]>
Date: Thu, 24 Feb 2005 05:50:52 -0800

(hat off)
I agree on the value of defining a generic SAP,
and think it would be a natural fit as an appendix 
of the PL draft as it should be common to all TMLs.

In terms of the API draft, it is more challenging (but not
unprecedented) to do APIs in the IETF.  However, an
informative draft that documents how the SAP is realized as
an API (either generically or in Linux) would probably be
valuable and acceptable.

Cheers,
David

> -----Original Message-----
> From: Forwarding and Control Element Separation 
> [mailto:[email-masked]] On Behalf Of Joel M. Halpern
> Sent: Tuesday, February 22, 2005 10:04 AM
> To: [email-masked]
> Subject: Re: [FORCES] I-D ACTION:draft-khosravi-forces-tcptml-01.txt
> 
> My thanks to the authors for this revision of their work.
> This is a clear and useful description of a TML.
> 
> Two minor, related comments not so much about this document 
> but about how 
> the working group can handle one aspect of this.
> 
> It seems to me that for multiple TMLs to be useful, the upper 
> interface 
> provided by the different TMLs needs to be the same.  This 
> prompts two 
> thoughts:
>      Can the authors of other TML proposals please look at 
> the API defined 
> here, and let the working group know if that looks like the 
> interface they 
> would like to provide?
>      Once we get agreement, can we move that into the PL 
> document (since 
> the alternative, as far as I can tell, would be to try to 
> duplicate it 
> without change into each TML document.)
> 
> Next, could we possibly define this as a service interface 
> rather than an 
> API.  I don't think that we want to mandate that a PL must 
> invoke these 
> exact subroutine calls.  We do want to say that the PL will use these 
> services from the TML, resulting in a specific and 
> predictable on-the-wire 
> sequence.
> 
> Thank you,
> Joel
> 
> At 03:45 PM 2/21/2005, [email-masked] wrote:
> >A New Internet-Draft is available from the on-line Internet-Drafts 
> >directories.
> >
> >
> >         Title           : TCP/IP based TML (Transport 
> Mapping Layer) for 
> > ForCES protocol
> >         Author(s)       : H. Khosravi, et al.
> >         Filename        : draft-khosravi-forces-tcptml-01.txt
> >         Pages           : 25
> >         Date            : 2005-2-21
> >
> >This document defines the TCP/IP based TML (Transport Mapping Layer)
> >    for the ForCES protocol. It explains the rationale for 
> choosing the
> >    transport protocols and also describes how this TML addresses all
> >    the requirements described in the Forces [3] 
> requirements and ForCES
> >    protocol [7] document.
> >
> >A URL for this Internet-Draft is:
> >http://www.ietf.org/internet-drafts/draft-khosravi-forces-tcp
tml-01.txt

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 24 Feb 2005 10:04:37 -0500

I would like to continue on the path of a separate TML API 
approach for now. I have two couathors who joined me and we will be
revamping the draft. Opinions/suggestions from other people are welcome.
Lets defer to later to see if we need to make this part of the PL draft
or it should live its own life.
I think it is sensible to define the SAP and show an API format that
uses it (beginings of that API are shown in draft 00). We may have to
change the draft title.

cheers,
jamal