Subject: Re: Protocol Operations

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Tue, 8 Feb 2005 13:00:43 -0800

Here is what I am suggesting,

The Operation TLV =
 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
        |  Operation (ADD)      | Flags |               Length
|
 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
        |
|
        ~                         <Path-Data>+
~
        |
|
 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 

Operations = ADD/CREATE, DEL, UPDATE/REPLACE.
I guess DEL ALL == DEL followed by a Table ID (for example) so that is
not needed
Flags = SELECTOR Bits
-->00: indicates absence of the selector 
-->01(F_SELTAB): indicates what follows is a table. The
path should be sufficient to point to a table; so this flag
is redundant but here for completion sake
-->10(F_SELBLK): indicates that what follows is a BLKINFO
-->11(F_SELKEY): Indicates what follows is a KEYINFO

Let me know why this wont work, or what I am missing here ?

Thanks
Hormuzd

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Jamal Hadi Salim

You cannot remove the flags. If you could it may make sense to move
those two to the operations level. As it stands right now, either have
equal merit. If you look at the examples i posted, it is possible infact
to replace and create different items within one SET operation - but i
dont think this in itself stands as a reason for their existence. 

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 8 Feb 2005 16:26:07 -0500

Hormuzd,
I understood you earlier and yes that would work, but like i said
earlier (text still at the end of this email actually):
Why would this have _more_ merit than whats there right 
now. Essentially its a philosphical question: Is the glass half full or
half empty? 
If you feel strongly about it, please open an issue report
and we can revisit it later. 

cheers,
jamal