Subject: text for issue 26

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Sun, 17 Jul 2005 16:34:51 -0700

Here is the text for 26...

Teardown TLV

    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

    |  Type = Teardown reason       |               Length          |

    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

    |                      Teardown Reason                          |

    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

  Teardown reason (32 bits):

       This indicates the reason why the association is being

       terminated. Several reason codes are defined as follows.

0 - normal teardown by administrator

1 - error - out of memory

2 - error - application crash

255 - error - other or unspecified

Hormuzd

---

From: Alex Audu <[email-masked]>
Date: Sat, 23 Jul 2005 11:28:12 -0400

Hi Hormuzd,
 
Can you also tear down an association as a result of the heart-beat expiring?..bandwidth limitation?..
So may be we could use the following error codes:
 
0 - normal teardown by administrator
1 - error - loss of heart-beat
2 - error - out of bandwidth resource
3 - error - out of memory resource
4 - error - application crash
..
255 - error - other or unspecified
 
Error 2 may signal the system's reaction to DOS attack.  I have also arranged them
according to severity levels,..the crash being most severe. I am not sure if the 
ordering matters much though.
 
Cheers,
Alex.

-----Original Message-----
From: Khosravi, Hormuzd M <[email-masked]>
To: [email-masked]
Sent: Sun, 17 Jul 2005 16:34:51 -0700
Subject: text for issue 26

Teardown TLV

Hormuzd