Subject: section 6.1 grammar update

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 12 Oct 2005 12:15:07 -0400

Folks,
Please review this closely. Joel - if you can pay close attention to
this I would appreciate it. There has been some major updates to sync
with other sections etc.

I will follow up with the use cases appendix to reflect accurately the
details shown.

All the text in the rest of section 6 needs to be synchronized with this
section. Its more of mechanical time consuming work i.e nothing to
discuss really. I wont have time to touch that today.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Thu, 13 Oct 2005 17:52:44 +0800

Jamal,

I appreciate the update.  A suggestion of the text as below.

<origianl>
The BNF of the PL level PDU is as follows:
    PL level PDU := MAINHDR [MAIN-TLV]
   MAIN-TLV := [LFBselect-TLV] / [REDIRECT-TLV] /
               [ASResult-TLV] / [ASTreason-TLV]
   LFBselect-TLV :=   LFBCLASSID LFBInstance OPER-TLV
   .......
</original>

<supposed>
The BNF of the PL level PDU is as follows:
    PL level PDU := MAINHDR [MAIN-TLV]
   MAIN-TLV := [LFBselect-TLV] / [Redirect-TLV] /     !-- note the change of
lowercase of Redirect for the consistency
               [ASRresult-TLV] / [ASTreason-TLV]   !-- note the change of
ASRresult

Where,

            Redirect-TLV is only applied to the Packet Redirect Message, and the
definition of the TLV can be found in Section 6.8;
            ASRresult-TLV is only applied to Association Setup Response Message,
and the definition of the TLV can be found in Section 6.4.2;
            ASTreason-TLV is only applied to Association Teardown Message, and
the definition of the TLV can be found in Section 6.4.3.
            LFBselect-TLV is a common TLV that are applied to Configurtion
Messages, Query Messages, and Association Setup Message. The
BNF grammar is shown as below.

   LFBselect-TLV :=   LFBCLASSID LFBInstance OPER-TLV
   .......
</supposed>

Jamal, please just decide if the above text  is necessary or not under your
consideration.

Thanks,
Weiming