Subject: grammar section

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 2 Oct 2005 22:51:55 -0400

Folks,

1) I would like to propose renaming:
DATARAW to Sparse-data
and
PACKED-DATARAW to Full-data

since they sound more descriptive.
Recall DATARAW may contain optionally appearing elements
and PACKED-DATARAW is when all elements appear but not in ILVs.

Any objections or better descriptions?

2) isnt the KEY_DATA a DATA-TLV? i.e could be full or sparse?

cheers,
jamal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 2 Oct 2005 23:05:21 -0400

I have no problem with change 1.
Key-data is always a perfectly packed field with no options.  It does not 
need an extra TLV, as its length is specified by the wrapper.
It does however require the same mapping as the full-data, as there can be 
variable length fields.  (It is tempting to restrict key fields to being 
fixed length, but that is probably not justifiable.)

Yours,
Joel

---

From: Jamal Hadi Salim <[email-masked]>
Date: Mon, 3 Oct 2005 07:05:04 -0400

On Sun, 2005-02-10 at 23:05 -0400, Joel M. Halpern wrote

> need an extra TLV, as its length is specified by the wrapper.

Ok, so full-data then.

> fixed length, but that is probably not justifiable.)

I would say full-data then - is that agreeable?

cheers,
jamal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 3 Oct 2005 07:07:00 -0400

Sounds good to me.
Joel