Subject: updated section 3.2

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 20 Oct 2005 09:36:32 -0400

Folks, 
I have updated section 3.2 to indicate the down/up states for the FE.
This is the last of the know issues. Please comment as i am sure there
are a few glitches given the new introduced text and SM.
I will upload the new draft somewhere accessible as soon as i see
closure on this.
The draft will be submitted on sunday to the IETF.

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 20 Oct 2005 10:33:35 -0400

On Thu, 2005-20-10 at 22:07 +0800, Wang,Weiming wrote:
> Jamal,
> 
> By reading the following text,  I have some comments as:
> 
> 1. The FE state and the FE Object LFB state is very different, I think. Note
> that we have already mentioned in the FE Object LFB attributes that, the FE
> state is only an attribute of  FE Object LFB.
> 
> 2.  Therefore, we should carefully distinguish the "FE down" state and the "FEO
> down" state. They are quite different.   I can just see the "FE down"  you are
> talking about  are more "FEO down".  I think we should definitely define that
> "FE down" is "FE is totally dead", therefore, no way for CE to configure a down
> FE to an up FE, whereas we can have "FEO down" state as you described below.
> 

FEObject Admin is intended to imply that the FEStatus attribute of the
has been set to bring the FE state to admin up/down. If the text is
insufficient, i will change it to explicitly indicate so.

See my other email on what bringing an FE0 down would mean.

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 20 Oct 2005 11:48:15 -0400

On Thu, 2005-20-10 at 23:38 +0800, Wang,Weiming wrote:
> ----- Original Message -----
> From: "Jamal Hadi Salim" <[email-masked]>
> Subject: updated section 3.2
> 
>    The FE can only be in one of two states as indicated above.  When the
> [Weiming] FE has more state. We'v already defined in one of the "CE failover
> policy" that we may allow FE to keep its state and forwad packets continuously
> when the FE lost association.
> 

In that case the FE is still up. It is only DOWN when it is not
forwarding packets.

>    FE is in the DOWN state, it is not forwarding packets.  When the FE
>    in the UP state it is forwarding packets.
> 
>    On start up the FE is in the DOWN state unless explicitly configured
>    by the CE to transition to the UP state.  This MUST be done before
>    configuring any other LFBs that affect packet forwarding.
> [Weiming] I cannot understand this well. Why the FE is started while it is still
> in down state? I can accept that when the FE is booted, the FE is up, but the FE
> Object LFB is still in down state.
> 

There is no such thing as FE Object LFB going up or down. 
There is such a thing as an FE going down/up which is controlled by the
FEO FEStatus attribute.

When the FE is booted it is in down state because the FEO FEStatus
attribute indicates it is.
When it has lost association and still forwarding packets, it eventually
will stop forwarding packets depending on the policy. When that
transition happens, the FE transitions to a DOWN state.

> 
>    The FE transitions from the DOWN to the UP state when explicitly
>    configured to do so by the CE or when it looses its association with
> [Weiming] I also cannot understand well that how an FE can be configured when it
> is down. This is still more like the FEObject down.
> 

As indicated, the FE starts its state in DOWN. Only when the CE
administratively sets the FEO FEStatus attribute does this change.

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Thu, 20 Oct 2005 12:16:17 -0400

On Thu, 2005-20-10 at 23:59 +0800, Wang,Weiming wrote:

> So, what is a state of FE before it is started,I mean the state before it is
> rebooted(even before pre-association state),  'down' or 'dead'? How can a CE ask
> the FE to go to this state?
> 

We can introduce the INIT/DEASSOCIATED state which is entered only once
at the beginning. I was trying to avoid doing so. We really have only
two states as far as Forces is concerned; it is either associated or
not- and this is implicit in the messaging - but since the protocol
scenarios had the concept of an FE being told to go up (and Hormuzd siad
we had already agreed to have that feature) i agreed to introduce the
two explicit states.
If an FE is associated then you can apply Forces commands to it. If it
is not then you need to associate first before applying such commands. 
So to make it go back to its old state, you deassociate from it.

> I do think the FE down state you talked seems not a complete down state really,
> for it seems in this down state, the FE protocol LFB and the FE Object LFB, and
> even the TML are still alive, Or else, how can a FE be configured by CE when it
> is in down state?
> 

Refer to above please.

cheers,
jamal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 20 Oct 2005 21:21:28 -0400

The current wording "When the FE in the UP state it is forwarding packets" 
seems a little too strong.
When the FE is in the UP state, its LFBs can be configured to forward 
packets?  (Not quite right, some FEs probably have a default state that 
forwards packets to the CE.)
When the FE is in the UP state it is not prohibited from forwarding packets?
Something like that.
Joel

---

From: Jamal Hadi Salim <[email-masked]>
Date: Sun, 23 Oct 2005 12:17:15 -0400

> When the FE is in the UP state it is not prohibited from forwarding packets?

Made it to read as:

"   The FE can only be in one of two states as indicated above.  When
the FE is in the DOWN state, it is not forwarding packets.  When the FE
is in the UP state it may be forwarding packets depending on the
configuration of its specific LFBs.
"

cheers,
jamal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 23 Oct 2005 12:30:13 -0400

Works for me.  Thanks.
Joel