Subject: Message Types

From: Evangelos Haleplidis <[email-masked]>
Date: Mon, 28 Nov 2005 16:58:19 +0200

Greetings to the list,

During Implementation and in order to be in accordance to the document I
checked the Message Types that exist in the Appendix.

In Appendix-B it says that:

Message Types 0x00-0x0F
- The values assigne by this specification:

0x00 - Heartbeat
0x01 - Association Message
0x02 - Configuration Message
0x03 - Query Messages
0x04 - Event Notification
0x05 - Packet Redirection.

However in section 6 it says that:

Page 46 Section 6.4.1:

- Message Header:
The Message Type in the header is set MessageType='AssociationSetup'
    ------------                      ------------------------------

This also is declared everywhere in the document.

Page 48 Section 6.4.2:

- Message Header:
The Message Type in th header is set MessageType='AssociationSetupResponse'
    ------------                      -------------------------------------

Page 49 Section 6.4.3:

- Message Header:
The Message Type in the header is set MessageType='AssociationTeardown'
    ------------                      ---------------------------------

And so forth.

Also from the Main Header the recipient must be able to understand that it
is a response.

Unless the WG has created a new flag with the meaning that defines a
message to be either a RESPONSE or a REQUEST Message, which I cannot find
in the document.

And still the AssociationTeardown should be a stand-alone message type.

Is the Appendix-B not updated or Section 6 not updated?

Regards,

Evangelos Haleplidis.

---

From: Weiming Wang <[email-masked]>
Date: Tue, 29 Nov 2005 07:57:04 +0800

Hi Evangelos,

Thanks for the catch.  I suppose the following change. Note that a receiver
understands whether it is a response or a request just by the message type
rather than by an extra flag.

Avri,  the supposed chagne is as below:

 0x00 - 'AssociationSetup'
 0x01 - 'AssociationSetupResponse'
 0x02 - 'AssociationTeardown'
 0x04 - 'Config'
 0x05 - 'ConfigResponse'
 0x06 - 'Query'
 0x07 - 'QueryResponse'
 0x08 - 'EvenNotification'
 0x0a - 'PacketRedirect'
 0x0c - 'Heartbeat'

Thanks,
Weiming

----- Original Message -----
From: "Evangelos Haleplidis" <[email-masked]>