Subject: Re: [gaia] This Finnish startup has a solution to provide internet anywhere - and just raised $10 million in series A funding

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 2 Nov 2016 09:46:57 +0000

On 2016-10-31, at 11:34, Marco Zennaro <[email-masked]> wrote:
> Does anyone know about them?

My guess is that they have a close relation to the "Radio Arcala" club: http://g7vjr.org/2013/02/radio-arcala-visit-oh8x-finland/

The club had ideas for globe-spanning HF coverage with a few more of their monster antennas when I visited them ca. 2010.

Lars

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 2 Nov 2016 09:49:21 +0000

More at http://www.radioarcala.com