Subject: Re: [gaia] Ammbr: Happy Marriage of mesh and blockchain

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 21 Sep 2017 21:36:14 +0100

this post was interesting:
https://www.linkedin.com/pulse/slow-blockchain-mathematical-certainty-patrick-mcconnell/

On 12 August 2017 at 15:02, Jon Crowcroft <[email-masked]> wrote:
> ah, you could run global consensus (blockchain) on the transactions then use
> a route later - yes, that'd work....then you could get rid of reflationary
> stuff + remove unfairness....would take some care in design....
>
> On Sat, Aug 12, 2017 at 2:46 PM, Vint Cerf <[email-masked]> wrote:
>>
>> Jon,
>>
>> if you do not care about delays and you allow storing (encrypted) packets
>> until a link/route is available as in DTN networks, how would this analysis
>> change?
>>
>> vint
>>
>>
>> On Sat, Aug 12, 2017 at 5:03 AM, Jon Crowcroft
>> <[email-masked]> wrote:
>>>
>>> great! fab - checkout this thing we did a while on "currency" & ad hoc
>>> nets - there's a bit about inflationary/deflationary tendencies near the end
>>> might be worth factoring in...
>>> http://www.statslab.cam.ac.uk/~frank/PAPERS/micmahn.pdf
>>>
>>> On Fri, Aug 11, 2017 at 11:39 PM, Arjuna Sathiaseelan
>>> <[email-masked]> wrote:
>>>>
>>>> This article would be of interest to a new initiative to build a
>>>> decentralised network using blockchain - technically aiming to build the
>>>> world's largest blockchain network:
>>>> https://medium.com/@globalsecurepayments/the-happy-marriage-of-mesh-and-blockchain-276cce4a4909
>>>>
>>>> We are doing an initial coin offering September 1st if anyone wants to
>>>> invest :) (www.ammbr.com) - white paper will release next week.
>>>>
>>>> Please send me an email ([email-masked]) if you are interested to know
>>>> more about Ammbr.
>>>>
>>>> Regards
>>>>
>>>> _______________________________________________
>>>> gaia mailing list
>>>> [email-masked]
>>>> https://www.irtf.org/mailman/listinfo/gaia
>>>>
>>>
>>>
>>> _______________________________________________
>>> gaia mailing list
>>> [email-masked]
>>> https://www.irtf.org/mailman/listinfo/gaia
>>>
>>
>>
>>
>> --
>> New postal address:
>> Google
>> 1875 Explorer Street, 10th Floor
>> Reston, VA 20190
>
>

-- 
Arjuna Sathiaseelan
University of Cambridge | GAIUS Networks | Ammbr | GAIA Labs
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 22 Sep 2017 08:00:21 +0100

i think that post confuses bitcoin specifics with how to do scalable fast
consensus - there are quite a few papers on making consensus scale up to
very high speeds- forthcoming conext paper from keshav has some very
impressive transaction rates..
S. Rizvi, B, Wong, and S. Keshav, "Canopus: A Scalable and Massively
Parallel Consensus Protocol," To appear, Proc. CoNEXT 2017, December 2017.
but for the impatient, you can also read this paper on high throughput, low
latency from folks who are :
very expert in this space (cornell, imperial):
Teechan: Payment Channels Using Trusted Execution Environments
https://arxiv.org/abs/1612.07766

there's a lot of other solutions out there too (I believe deepmind/google
have some inhouse thing they are working on with a target of 10M
trsansactions per sec)....

much of this depends on the workload assumptions though

On Thu, Sep 21, 2017 at 9:36 PM, Arjuna Sathiaseelan <
[email-masked]> wrote:

> >>>> https://medium.com/@globalsecurepayments/the-
> happy-marriage-of-mesh-and-blockchain-276cce4a4909
> >>>>

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 22 Sep 2017 08:11:41 +0100

One question that has been lurking on my mind is - are these consensus
algorithms inherently unfair for nodes that are on high latency links? E.g.
if we have bitcoin mining nodes also in Chad - and most bitcoin
transactions happen in Russia, China and other parts in Europe - would
there be fairness in terms of earning mining revenue?

Regards

On 22 Sep 2017 08:00, "Jon Crowcroft" <[email-masked]> wrote:

> but for the impatient, you can also read this paper on high throughput,
> low latency from folks who are :
>> <https://maps.google.com/?q=1875+Explorer+Street,+10th+Floor+%0D+%3E%3E+Reston,+VA+20190&entry=gmail&source=g>
>> >> Reston, VA 20190
>> <https://maps.google.com/?q=1875+Explorer+Street,+10th+Floor+%0D+%3E%3E+Reston,+VA+20190&entry=gmail&source=g>
>> >
>> >
>>
>>
>>
>> --
>> Arjuna Sathiaseelan

---

From: Fernando Ramos <[email-masked]>
Date: Fri, 22 Sep 2017 09:22:13 +0100

Keshav’s work seems really interesting. To those that are really really impatient, as I was, you can check the slides here so you have an idea:

LOTKeeper: A Scalable and Massively Parallel Consensus Protocol <https://www.google.pt/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0ahUKEwiq0-TVqbjWAhXNSxoKHdOuA80QFggmMAA&url=http://blizzard.cs.uwaterloo.ca/iss4e/wp-content/uploads/2017/08/EnergyBlockchain.pptx&usg=AFQjCNHDrgfpoQf2hG_yjtRy1KnQZOPQfg>

NB: there are many hidden slides with more detail. Also note slide 76, based on the original one from Marko Vukolic, that shows pretty well what they achieve - very cool.

Thanks for sharing Jon.

Cheers,

Fernando

> No dia 22/09/2017, às 08:00, Jon Crowcroft <[email-masked]> escreveu:
> 
> i think that post confuses bitcoin specifics with how to do scalable fast consensus - there are quite a few papers on making consensus scale up to very high speeds- forthcoming conext paper from keshav has some very impressive transaction rates..
> S. Rizvi, B, Wong, and S. Keshav, "Canopus: A Scalable and Massively Parallel Consensus Protocol," To appear, Proc. CoNEXT 2017, December 2017.
> but for the impatient, you can also read this paper on high throughput, low latency from folks who are : 
> there's a lot of other solutions out there too (I believe deepmind/google have some inhouse thing they are working on with a target of 10M trsansactions per sec)....
> 
> On Thu, Sep 21, 2017 at 9:36 PM, Arjuna Sathiaseelan <[email-masked]> wrote:

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 22 Sep 2017 09:26:01 +0100

on a side note related to TEE - saw this post today:
https://blog.acolyer.org/2017/09/21/clkscrew-exposing-the-perils-of-security-oblivious-energy-management/amp/

security risks for Proof of Elapsed Time..

Regards

On 22 September 2017 at 08:00, Jon Crowcroft <[email-masked]> wrote:
> On Thu, Sep 21, 2017 at 9:36 PM, Arjuna Sathiaseelan

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 22 Sep 2017 10:20:25 +0100

indeed, possibly..

one of the goals of flxible paxos was to allow
tradeoffs to manage varying latency...eventually..
https://arxiv.org/abs/1608.06696

> >> >>> nets - there's a bit about inflationary/deflationary tendencies 
> near
> >> the end
> >> >>>> decentralised network using blockchain - technically aiming to 
> build
> >> the
> >> >>>> We are doing an initial coin offering September 1st if anyone 
> wants
> >> to
> >> >>>> Please send me an email ([email-masked]) if you are interested 
> to
> >> know
> >> >>>> more about Ammbr.
> >> >>>>
> >> >>>> Regards
> >> >>>>

---

From: Jane Coffin <[email-masked]>
Date: Fri, 22 Sep 2017 12:07:31 +0000

Hi All –

Just a reminder to post a note about why you are dropping a link into the GAIA list so that folks have context.

And, a reminder for those that have not been monitoring the list – we have a call out for presentations at the GAIA meeting during IETF 100 in Singapore.

Please let us know if you would like to present.

Best,
Jane
 
Internet Society | www.internetsociety.org

Skype:  janercoffin

Mobile/WhatsApp:  +1.202.247.8429

On 9/22/17, 4:26 AM, "gaia on behalf of Arjuna Sathiaseelan" <[email-masked] on behalf of [email-masked]> wrote:

    
    Regards

---

From: Jehan Tremback <[email-masked]>
Date: Fri, 22 Sep 2017 07:40:09 -0700

For Althea, we use payment channels. These allow payments to be made
with a transaction of a few hundred bytes, sent directly between
neighbors.
http://altheamesh.com/blog/altheas-multihop-payment-channels/

--
  Jehan Tremback
  [email-masked]

On Fri, Sep 22, 2017, at 05:07 AM, Jane Coffin wrote:
> Hi All –
>
> Just a reminder to post a note about why you are dropping a link
> into the> GAIA list so that folks have context.
>
> And, a reminder for those that have not been monitoring the list – we> have a call out for presentations at the GAIA meeting during
> IETF 100 in> Singapore.
>
> On 9/22/17, 4:26 AM, "gaia on behalf of Arjuna Sathiaseelan"
> <[email-masked] on behalf of [email-masked]>> wrote:
>
>     https://blog.acolyer.org/2017/09/21/clkscrew-exposing-the-perils-of-security-oblivious-energy-management/amp/>    
>     > i think that post confuses bitcoin specifics with how to do
>     > scalable fast>     > consensus - there are quite a few papers on making consensus
>     > scale up to>     > very high speeds- forthcoming conext paper from keshav has some
>     > very>     > impressive transaction rates..
>     > S. Rizvi, B, Wong, and S. Keshav, "Canopus: A Scalable and
>     >    Massively>     > Parallel Consensus Protocol," To appear, Proc. CoNEXT 2017,
>     > December 2017.>     > but for the impatient, you can also read this paper on high
>     > throughput, low>     > latency from folks who are :
>     > there's a lot of other solutions out there too (I believe
>     > deepmind/google>     > have some inhouse thing they are working on with a target of 10M>     > trsansactions per sec)....
>     >
>     >> https://www.linkedin.com/pulse/slow-blockchain-mathematical-certainty-patrick-mcconnell/>     >>
>     >> On 12 August 2017 at 15:02, Jon Crowcroft
>     >> <[email-masked]>>     >> wrote:
>     >> > ah, you could run global consensus (blockchain) on the
>     >> > transactions then>     >> > use
>     >> > a route later - yes, that'd work....then you could get rid of>     >> > reflationary
>     >> > stuff + remove unfairness....would take some care in
>     >> > design....>     >> >
>     >> > On Sat, Aug 12, 2017 at 2:46 PM, Vint Cerf <[email-masked]>
>     >> > wrote:>     >> >>
>     >> >> Jon,
>     >> >>
>     >> >> if you do not care about delays and you allow storing
>     >> >> (encrypted)>     >> >> packets
>     >> >> until a link/route is available as in DTN networks, how
>     >> >> would this>     >> >> analysis
>     >> >> change?
>     >> >>
>     >> >> vint
>     >> >>
>     >> >>
>     >> >>> great! fab - checkout this thing we did a while on
>     >> >>> "currency" & ad hoc>     >> >>> nets - there's a bit about inflationary/deflationary
>     >> >>> tendencies near>     >> >>> the end
>     >> >>>> This article would be of interest to a new initiative to
>     >> >>>> build a>     >> >>>> decentralised network using blockchain - technically
>     >> >>>> aiming to build>     >> >>>> the
>     >> >>>> https://medium.com/@globalsecurepayments/the-happy-marriage-of-mesh-and-blockchain-276cce4a4909>     >> >>>>
>     >> >>>> We are doing an initial coin offering September 1st if
>     >> >>>> anyone wants>     >> >>>> to
>     >> >>>> invest :) (www.ammbr.com) - white paper will release next
>     >> >>>> week.>     >> >>>>
>     >> >>>> Please send me an email ([email-masked]) if you are
>     >> >>>> interested to>     >> >>>> know
>     >> >>>> more about Ammbr.
>     >> >>>>
>     >> >>>> Regards
>     >> >>>>
> Email had 1 attachment:
> + smime.p7s
>   6k (application/pkcs7-signature)

---

From: Melinda Shore <[email-masked]>
Date: Fri, 29 Sep 2017 11:28:06 -0700

Hi, all:

There's a proposed IRTF research group, dinrg (Decentralized
Internet Infrastructure Research Group) just starting up, and
we'll be meeting at IETF 100.  dinrg is addressing some of the
problems being discussed in this thread and we hope that some
of the people involved in related work will be able and
interested to participate in dinrg discussions.  The proposed
charter is here: https://trac.ietf.org/trac/irtf/wiki/blockchain-federation,
and there's a mailing list at: https://www.ietf.org/mailman/listinfo/din.

The focus is not on distributed computing algorithms per se, but
on their application to problems related to building internet
infrastructure at scale.

Thanks,

Melinda

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 29 Sep 2017 21:22:03 +0100

Great Melinda.

I would like to propose a joint GAIA-DINRG workshop/meeting sometime
early next year if there is sufficient interest between the two
groups. Happy to organise this at Cambridge and can try and find some
dosh for sponsorship.

Regards