Subject: [Geojson] GeoJSON feature sequences repo and builds

From: Sean Gillies <[email-masked]>
Date: Sun, 28 Feb 2016 16:24:15 -0700

Hi all,

While waiting for feedback on the remaining GeoJSON issues, I updated the
https://github.com/geojson/geojson-feature-sequences repo. It builds
formatted versions of that draft for each push and saves the draft.txt and
draft.html artifacts. See for example

https://circle-artifacts.com/gh/geojson/geojson-feature-sequences/3/artifacts/0/home/ubuntu/geojson-feature-sequences/draft.html

Submitting ietf-geojson-01 is my top priority, but I thought you might like
to see that I haven't forgotten our other deliverable.

-- 
Sean Gillies

---

From: Erik Wilde <[email-masked]>
Date: Mon, 29 Feb 2016 09:17:15 +0100

hello sean.

On 2016-02-29 0:24 , Sean Gillies wrote:
> While waiting for feedback on the remaining GeoJSON issues, I updated
> the https://github.com/geojson/geojson-feature-sequences repo. It builds
> formatted versions of that draft for each push and saves the draft.txt
> and draft.html artifacts. See for example
> Submitting ietf-geojson-01 is my top priority, but I thought you might
> like to see that I haven't forgotten our other deliverable.

nice work, thanks!

cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: Allan Doyle <[email-masked]>
Date: Mon, 29 Feb 2016 09:45:07 -0500

Great start. I confess to not remembering the details of the original idea, and the following comments are not to be taken as an opinion about the direction this should take. Rather, I'd like to think out loud about what the natural "explosion" of GeoJSON would be.

To me it seems like it would be a series of complete GeoJSON objects, so you just scoop them up one at a time and feed them into a parser.

So to send a zillion-member FeatureCollection, I'd see sending the Features as objects, but sending the little disembodied bbox feels a little odd. Then the problem becomes one of how to deal with the bbox. Maybe either send a single FeatureCollection object with an empty list of features as the first text. Or maybe it gets sent out-of-band, as a separate object. Or maybe send a Feature object that has the bbox in it. 

I guess it comes down to the principle of least surprise. To me it's surprising to see a text that's not itself GeoJSON. But this is called GeoJSON Feature Sequences and not GeoJSON Sequences.

Anyway, I'm +1 on Sean's start, and neither +1 nor -1 on the explosion. And I don't want to say I'm 0. I guess I'm NaN. I just want to raise the point.

> On Feb 28, 2016, at 6:24 PM, Sean Gillies <[email-masked]> wrote:
> 
> Hi all,
> 
> While waiting for feedback on the remaining GeoJSON issues, I updated the https://github.com/geojson/geojson-feature-sequences <https://github.com/geojson/geojson-feature-sequences> repo. It builds formatted versions of that draft for each push and saves the draft.txt and draft.html artifacts. See for example
> 
>   https://circle-artifacts.com/gh/geojson/geojson-feature-sequences/3/artifacts/0/home/ubuntu/geojson-feature-sequences/draft.html <https://circle-artifacts.com/gh/geojson/geojson-feature-sequences/3/artifacts/0/home/ubuntu/geojson-feature-sequences/draft.html>
> 
> Submitting ietf-geojson-01 is my top priority, but I thought you might like to see that I haven't forgotten our other deliverable.
> 
> -- 
> Sean Gillies
> _______________________________________________
> GeoJSON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geojson

---

From: Erik Wilde <[email-masked]>
Date: Mon, 29 Feb 2016 16:19:14 +0100

hello allan.

On 2016-02-29 15:45 , Allan Doyle wrote:
> I guess it comes down to the principle of least surprise. To me it's
> surprising to see a text that's not itself GeoJSON. But this is called
> GeoJSON Feature Sequences and not GeoJSON Sequences.

just about this specific point: the question whether the model should 
indeed be limited to "feature object sequences" only. if it is, then 
specific issues such as your "where's the bbox?" question might be 
interesting to take into account. if it's more generally a way to stream 
any set of GeoJSON objects, then maybe that's out of scope. there's an 
open issue here:

https://github.com/geojson/geojson-feature-sequences/issues/5

also, about your surprise that it's not GeoJSON: this is going to be a 
new media type (necessarily so, because by definition this is not 
JSON/GeoJSON). if you understand this new media type, then you won't be 
surprised that it's something other than JSON encoding one GeoJSON object.

cheers,

dret.