Subject: Re: [Geojson] [draft-geojson] Start of a changes appendix (#160)

From: Erik Wilde <[email-masked]>
Date: Mon, 29 Feb 2016 09:41:27 +0100

hello.

sean has started addressing #125 in #160, starting with a list of 
changes that probably should be included in the "Changes" appendix:

On 2016-02-28 19:26 , Sean Gillies wrote:
> https://github.com/geojson/draft-geojson/pull/160

for now, this list looks like this:

* CRS other than the default are not recommended.
* Right-hand rule polygon winding order is recommended.
* Rules for bounding boxes at antimeridian and poles.
* Extension rules including restrictions on extensions.
* New application/geo+json media type.
* Explicit Cartesian interpretation of line segments.

if you think that there are more changes that should be added to the 
list, please respond or contribute to the PR.

i think the goal is that we list everything that is not just editorial. 
it should include anything that somebody deeply familiar with GeoJSON 
should re-read, so that there's an easy transition path.

thanks and cheers,

dret.

-- 
erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: Sean Gillies <[email-masked]>
Date: Mon, 29 Feb 2016 10:26:27 -0700

On Mon, Feb 29, 2016 at 1:41 AM, Erik Wilde <[email-masked]> wrote:

> hello.
>
> sean has started addressing #125 in #160, starting with a list of changes
> that probably should be included in the "Changes" appendix:
>
> if you think that there are more changes that should be added to the list,
> please respond or contribute to the PR.
>
> i think the goal is that we list everything that is not just editorial. it
> should include anything that somebody deeply familiar with GeoJSON should
> re-read, so that there's an easy transition path.
>
> thanks and cheers,
>
> dret.
>
>
Thanks, Erik. I'm thinking of categorizing changes as either normative or
informative. Is that agreeable to everyone?

-- 
Sean Gillies