Subject: [Geojson] proposal for #149

From: Erik Wilde <[email-masked]>
Date: Fri, 19 Feb 2016 22:20:14 +0100

hello.

https://github.com/geojson/draft-geojson/issues/149#issuecomment-186409778 
has a proposal for resolving #149. it is a small piece of ascii art 
showing the relationship of the most important GeoJSON constructs. this 
could go into the intro part of section 2, together with some text 
relating the shown concept very briefly. it is not meant to be complete, 
but a succinct overview. here it is for completeness:

                             +--------------------------+
                             |                          |
FeatureCollection           | GeometryCollection       |
                             |                          |
  |                          |  |                       |
  v features                 |  v geometries            |
                             |                          |
Feature  +----------------> | non-Collection (6 types) |
               geometries    |                          |
  |                          |  |              Geometry |
  |                          +--+-----------------------+
  |                             |
  v properties                  v coordinates

this shows things as if a GeometryCollection couldn't contain a 
GeometryCollection, which is not true, but recommended.

cheers,

dret.

-- 

erik wilde | mailto:[email-masked] |
            | http://dret.net/netdret    |
            | http://twitter.com/dret    |

---

From: Allan Doyle <[email-masked]>
Date: Fri, 19 Feb 2016 16:49:44 -0500

-1 on this diagram. I don't understand the issue anymore.

> On Feb 19, 2016, at 4:20 PM, Erik Wilde <[email-masked]> wrote:
> 
> hello.
> 
> https://github.com/geojson/draft-geojson/issues/149#issuecomment-186409778 has a proposal for resolving #149. it is a small piece of ascii art showing the relationship of the most important GeoJSON constructs. this could go into the intro part of section 2, together with some text relating the shown concept very briefly. it is not meant to be complete, but a succinct overview. here it is for completeness:
> 
> 
> this shows things as if a GeometryCollection couldn't contain a GeometryCollection, which is not true, but recommended.
> 
> cheers,
> 
> dret.
> 
> -- 
> 
> _______________________________________________
> GeoJSON mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geojson

---

From: Erik Wilde <[email-masked]>
Date: Fri, 19 Feb 2016 22:54:59 +0100

hello allan.

> -1 on this diagram. I don't understand the issue anymore.

the issue is to make it easier for people who are new to GeoJSON to 
understand how the main concepts relate. that's probably trivial for 
you, because you know the spec so well. so simply look at it as an 
attempt to make it easier for GeoJSON newbies to understand how the main 
concepts relate.

any issues with the diagram specifically, or you just don't like the 
idea of having one?

cheers,

dret.

---

From: Martin Daly <[email-masked]>
Date: Sat, 20 Feb 2016 14:10:34 +0000

> the issue is to make it easier for people who are new to GeoJSON to understand
> how the main concepts relate. that's probably trivial for you, because you know
> the spec so well. so simply look at it as an attempt to make it easier for
> GeoJSON newbies to understand how the main concepts relate.
> 
> any issues with the diagram specifically, or you just don't like the idea of having
> one?

I have a specific issue with the diagram: it is wrong.

MultiPoint, MultiLineString and MultiPolygon are homogeneous collections, and so cannot be included in any "non-collections" category.

If there is a need for a diagram - and I'm not convinced that there is - then it should be this one, but with a simple "Geometry" instead of an incorrect box, and then *another* diagram that breaks out Geometry. The Geometry diagram must include the correct relationships between Point and MultiPoint, LineString and MultiLineString, Polygon and MultiPolygon, and Point, LineString and Polygon and GeometryCollection.

The real diagram (which is also wrong, I see, missing as it does a relationship between MultSurface and GeometryCollection) is on p11 of:

http://portal.opengeospatial.org/files/?artifact_id=13227

I seriously doubt that you can do that sensibly with ASCII art.

Martin