Subject: Re: [Geojson] Polar bounding boxen (#47)

From: Sean Gillies <[email-masked]>
Date: Sun, 14 Feb 2016 18:30:29 -0700

Oops, missed the list when I replied to Martin.

I have a PR for a specification of polar bounding boxes at
https://github.com/geojson/draft-geojson/pull/146.

On Sun, Feb 14, 2016 at 5:57 PM, Sean Gillies <[email-masked]>
wrote:

> Martin,
>
> On Sat, Jan 30, 2016 at 12:20 AM, Martin Thomson <[email-masked]
> > wrote:
>
>> In reviewing this, I think that this is easy.  Antarctica can be
>> described by [-90, -180, -70 (or whatever), 180]  Obviously anything
>> less than the full 360 degrees of longitude will have a strange shape.
>> We should be clear that attempting to create a strange shape by using
>> latitudes greater than 90 or less than -90 is not valid.
>>
>>
> Yes, I think this should be straightforward. Bounding "boxes" that contain
> the pole are caps from the spherical point of view. See
>
>   https://www.jasondavies.com/maps/bounds/
>
> and spin it to the south pole for a moment. While there are many different
> boxes that equate to that one cap containing Antarctica, I think we want to
> get everyone to use one of them: the one with SW point 180W, 90S and NE
> point 180E, 63S. So, if your shape contains the South pole, its bounding
> box should be (using 63S as the highest latitude)
>
>   [-180, -90, 180, -63]
>
> At the North pole, the standard bounding box for a similarly shaped (and
> fictitious) continent would be something like
>
>   [-180, 63, 180, 90]
>
>
> --
> Sean Gillies
>

-- 
Sean Gillies

---

From: Martin Thomson <[email-masked]>
Date: Mon, 15 Feb 2016 12:38:55 +1100

> https://github.com/geojson/draft-geojson/pull/146.

Very nice.  A few editorial nits that I put on the PR, but this looks good.