Subject: No Minneapolis Meeting

From: Randall Gellens <[email-masked]>
Date: Tue, 05 Mar 2002 14:06:46 -0800

Because there hasn't been any discussion on the list of the several 
drafts published so far, I don't see much point in meeting in 
Minneapolis.

IETF working group meetings are a scarce and expensive resource, and 
should only be used to help make forward progress, typically to 
discuss issues that have been raised on the list where a face-to-face 
meeting can be helpful.

I apologize for the state of the group, and will work harder to help 
us make progress.

--Randy

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 05 Mar 2002 17:13:48 -0500

I think this is most unfortunate.
There has been list discussion on definitions - an absolutely
essential start.  We need to come to closure on this.

There are also large number of very perplexing questions of 
balancing utility and privacy that have not progressed.  
We need to make progress, and I think face-to-face is a good 
way to do that.  I think a meeting is in order.

If there is no meeting, then I think we should arrange a
bar-bof.

Brian

> -----Original Message-----
> From: Randall Gellens [mailto:[email-masked]]
> Sent: Tuesday, March 05, 2002 5:07 PM
> To: [email-masked]
> Cc: Allison Mankin
> Subject: No Minneapolis Meeting
> 
>

---

From: Ersue Mehmet <[email-masked]>
Date: Wed, 06 Mar 2002 16:12:51 +0100

I fully agree with Brian. We are missing the progress which 
is needed and we were hoping to achieve in Minneapolis.

To boost a goal-oriented discussion we should start the work 
on the requirements WG item. IMO there is enough material 
already available and we had sufficient discussion on terminology 
and scenarios.

IMO a lot of WG members will welcome it if we can meet in 
Minneapolis to discuss on a stable focus and the kick-off of 
the requirements WG item work.

Regards,

Mehmet

> -----Ursprüngliche Nachricht-----
> Von: Rosen, Brian [mailto:[email-masked]]
> Gesendet: Dienstag, 5. März 2002 23:14
> An: 'Randall Gellens'; [email-masked]
> Cc: Allison Mankin
> Betreff: RE: No Minneapolis Meeting
> 
>

---

From: Cuellar Jorge <[email-masked]>
Date: Wed, 06 Mar 2002 16:20:04 +0100

IMHO we have had quite a bit of discussion on terminology,
scenarios and requirements. We tried to reflect those 
discussions in the drafts that Mehmet, Kenji and I have
prepared. They will be announced shortly, but for your convenience,
and to have more discussion before Minneapolis we have them made
available at:

http://www.epic.roke.co.uk/epic/draft-cuellar-geopriv-reqs-01.txt
and
http://www.epic.roke.co.uk/epic/draft-cuellar-geopriv-scenarios-00.txt

Those are a new version of the requirements draft, 
and a new scenarios draft. We are in close discussion with
John Morris to merge our viewpoints, and we hope to
prepare a common draft before or during the IETF-53.

As much as we could, we have left the scope of the
drafts to what we think is a bear minimum, but if there are
any concrete suggestions we can restrict the scope even more.

IMHO much of the discussion is difficult because there is no clear 
consensus on what is on the scope of the WG. Is authentication of
policies in the scope? Are policies opaque? Is authentication of
requestors and responders in our scope? Is location data opaque?
Is a convenient abstraction of location data and transformations
in the scope? Is identity management (say, pseudonyms) in the scope?
Or is authentication based on public identities? There are many drafts
around and they already express different standpoints of a discussion.

I think that a WG meeting is actually necessary, and
I would expect a WG session to increase the discussion 
(as actually it was also the case at SLC).

I would like to meet in Minneapolis with anyone interested in
making progress in this discussion or collaborating on drafts. 

Best regards,

Jorge

---

From: "James M. Polk" <[email-masked]>
Date: Wed, 06 Mar 2002 11:51:31 -0600

At 08:45 AM 3/6/2002 -0700, Zmolek, Andrew (Andrew) wrote:

Snip>
>But geopriv is not chartered to design a general purpose presence and
>availability system. Rather, it attempts to force policy application all
>the way down to the location protocol itself. Can you imagine what the
>internet would be like if the same rationale were applied to echo
>request and reply protocols, traceroute protocols, and other similar
>tools?

Don't get me started on comparisons.... grrrrrrrrr!!

>
>Anyway, enough ranting. I'm 100% in support of a BoF. Given that iptel
>was meeting at the same time as geopriv, may I suggest we try to
>organize a meeting during the next group of sessions, Tuesday afternoon
>1545-1645. What do you think?

I have the same conflict with iptel, so the next slot is great with me. 

>
>--Andy Zmolek 
>    Technology & Standards Engineer 
>      CTO Standards 
>        Avaya Inc. 
>
>            [email-masked] 
>              +1 720 444 4001 
>
>
>
>From: Cuellar Jorge [mailto:[email-masked]]
>Sent: Wednesday, March 06, 2002 8:20 AM
>To: Rosen, Brian; 'Randall Gellens'; 'James M. Polk'; 'Kenji Takahashi';
>'John Morris'
>Cc: [email-masked]
>Subject: RE: No Minneapolis Meeting
>
>

*************************************
"People generally demand more respect for their own rights than they are
willing to allow for others"

James M. Polk
Consulting Engineer
Office of the CTO

Cisco Systems
2200 East President George Bush Turnpike 
Richardson, TX  75082 USA
w) 972.813.5208
f)  972.813.5280
www.cisco.com

---

From: Cuellar Jorge <[email-masked]>
Date: Thu, 14 Mar 2002 22:34:14 +0100

I agree with John, we should meet next week. And I
agree with the agenda that John proposes.

Perhaps the easiest, is to meet Tuesday 1415-1515 in
Salon D, as it was planned. Note that IPTel was also cancelled
(Andy Zmolek had a conflict here).

At 10:55 AM -0500 3/8/02, John Morris wrote:
><snip>
>If I were setting the agenda, I would make it simple (at least 
>simple in form, but not in substance):
>
>	1.  Discussion of the scope of charter and WG
>	2.  "Final" (pending posting and discussion back on the list, 
>of course) discussion of definitions and terminology
>	3.  Set concrete plan to (a) finish on terminology, if 
>needed, (b) create a scenarios document, if there is WG consensus to 
>create one, and (c) create a requirements document.
><snip>
> In any event, we should try to get together next week.  John

See you there! Best regards, Jorge

---

From: "Zmolek, Andrew (Andrew)" <[email-masked]>
Date: Thu, 14 Mar 2002 16:43:07 -0700

> Wait a minute at IETF it is not the members who convene the 
> meetings and make the agenda, it is the IETF, WG chairs who
> do this.

This has been pointed out ad nauseum already. That's one reason why this is an informal BoF, not a working group meeting. It's not binding on the working group in any way and is no different than any other similar discussion among interested parties within a working group. If it bothers you that a few working group members might want to get together to talk about some relevant topics, then I imagine this will be the least of your worries at Minneapolis.

> Next I have a question to Andrew, do you wish your draft 
> draft-zmolek-enum to be considered at geopriv?

Hmmm...the draft itself is a bit specific to enum as written--it doesn't address geopriv directly. However, the concepts surrounding the use of service resolution services (for presence or otherwise) present a reasonable approach to solving the geopriv problem. Trouble is, even with a draft targeted to geopriv, this approach is clearly out of charter due to the severe constraints placed on the geopriv solution (namely, solving the privacy issue at the transport layer). 

Are you asking this question because you want to hear more about this draft with respect to geopriv, or are you trying to find out if my motivation for meeting is somehow tied to finding an audience for this draft? If there is interest in the former, I'd like to hear about it. But I suspect you're asking the latter question, in which case let me make it clear that I am more interested in having a good discussion about solving the fundamental problems than pushing any particular viewpoint or draft. While it is unfortunate that the WG won't be discussing them, there's no reason the rest of us need to wait around for an excuse for a good technical discussion.

--Andy Zmolek 

            [email-masked] 
              +1 720 444 4001

---

From: John Morris <[email-masked]>
Date: Thu, 14 Mar 2002 22:52:57 -0500

Behcet is of course correct, as is Andrew.  So, in the absence of a WG 
meeting, any geopriv discussions will be informal, and will at best lead to 
some ideas/documents being brought back the WG.  That being said, I'm on 
board for talking informally as Jorge suggested:

>Salon D, as it was planned....

See you then.  John

At 04:43 PM 3/14/02 -0700, Zmolek, Andrew (Andrew) wrote:
>This has been pointed out ad nauseum already. That's one reason why this 
>is an informal BoF, not a working group meeting. It's not binding on the 
>working group in any way and is no different than any other similar 
>discussion among interested parties within a working group. If it bothers 
>you that a few working group members might want to get together to talk 
>about some relevant topics, then I imagine this will be the least of your 
>worries at Minneapolis.
>
>Hmmm...the draft itself is a bit specific to enum as written--it doesn't 
>address geopriv directly. However, the concepts surrounding the use of 
>service resolution services (for presence or otherwise) present a 
>reasonable approach to solving the geopriv problem. Trouble is, even with 
>a draft targeted to geopriv, this approach is clearly out of charter due 
>to the severe constraints placed on the geopriv solution (namely, solving 
>the privacy issue at the transport layer).
>
>Are you asking this question because you want to hear more about this 
>draft with respect to geopriv, or are you trying to find out if my 
>motivation for meeting is somehow tied to finding an audience for this 
>draft? If there is interest in the former, I'd like to hear about it. But 
>I suspect you're asking the latter question, in which case let me make it 
>clear that I am more interested in having a good discussion about solving 
>the fundamental problems than pushing any particular viewpoint or draft. 
>While it is unfortunate that the WG won't be discussing them, there's no 
>reason the rest of us need to wait around for an excuse for a good 
>technical discussion.
>
>--Andy Zmolek

---

From: Ersue Mehmet <[email-masked]>
Date: Fri, 15 Mar 2002 20:38:55 +0100

> >Salon D, as it was planned....

Sounds good. Decisions can only be made on the maillist anyway.
If we have some proposals we can post them to the maillist
together with the minutes.

CU all. Mehmet