Subject: Re: Notes from Non-meeting

From: Ricardo Cuellar <[email-masked]>
Date: Thu, 21 Mar 2002 23:35:18 +0100

Henning Schulzrinne <[email-masked]> schrieb am 21.03.02:

> Location information in a protocol only makes sense if it is associated
> with some identifier. Thus, I don't think that general discussion about
> the location of a cellphone vs. a person is sufficiently precise. It
> makes sense to say "identifier X in protocol Y has location property Z,
> where Y can be a location-specific protocol or a protocol whose primary
> purpose is something other than conveying location. It's users who then
> make associations with people, buses, taxis or other objects. We don't
> have intrinsic identifiers for these objects, certainly not a single
> one.

This is true: we do not have unique identifier for people. But that doesn’t
hinder you to ask where “Jorge” is, although many call me
"Ricardo". If the problem is that the name 
“Jorge” is not unique, well you could replace it by “[email-masked]” or whatever. 
The fact is that people have names by which they can be
 identified in certain contexts. For instance the 
Location Server may distribute names to the people 
who want to use the service (both for client and for target roles). 
More importantly, there are many types of credentials that you 
may obtain to prove ownership of your identifier. 

Ipsec, PKIX and many other groups at the IETF do not have problem with this.

Your argument applies not only to people, but as you note, to buses,
Taxis and other objects which do not have a single ID. For instance laptops,
handhelds, etc. Should the usability of geopriv be restricted to only cell phones, with a unique identifier? (Not all cell phones will have this
property either).

Regards, Jorge

-------------------------------------------------
Dr Jorge R Cuellar   Office: Tel +49 89 636 47585
Siemens CT IC 3              Fax +49 89 636 48000
Otto-Hahn Ring 6    [email-masked]
81730 München
---------  Out of town: -------------
    Fax & Voicebox: +49 (0) 12125-130-30-549 
    [email-masked]

________________________________________________________________
Keine verlorenen Lotto-Quittungen, keine vergessenen Gewinne mehr! 
Beim WEB.DE Lottoservice: http://tippen2.web.de/?x=13

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 21 Mar 2002 16:51:52 -0600

> “Jorge” is not unique, well you could replace it by “[email-masked]” or whatever.

Certainly, but we're not designing a generic directory protocol here.

> Ipsec, PKIX and many other groups at the IETF do not have problem with this.

I didn't say you had to have *exactly one* identifier, but at least one.

> handhelds, etc. Should the usability of geopriv be restricted to only cell phones, with a unique identifier? (Not all cell phones will have this

Again, the identifier doesn't have to be unique in the sense that one
object can have multiple identifiers. But it gets hard if one identifier
refers to multiple objects that may not always be in the same physical
place. Also, you need at least one - location information without some
protocol-representable idea of what it is for is pretty useless. This is
another argument why this problem gets much easier if you embed location
information in existing protocols since you usually already have means
to identify objects of interest.