Subject: Is behavior of a single element in scope

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 20 Mar 2002 21:35:19 -0500

I have a question to pose:

Is a discussion of the behavior of a single element in 
scope for discussion?  For standardization?
For example, suppose we have an element called a Location Server, 
which knew the location of many "targets".

Can we talk about what the Location Server can or
cannot do with the data?

In the IETF we do protocols.  Even in a case,
like geopriv, where we are defining an object,
it is a protocol object, which goes between (at least)
two elements.  We can talk about what information
is passed, and how.  We can talk about how it is
protected in transit.  

We can clearly talk about how an element MIGHT
use the information as background for why we
might need specific information elements or
protocol mechanism.

However, we don't standardize what a single
element does with the data.

Specifying behavior is a slippery slope,
and I'd like to stay away from it.

Brian

---

From: Bobby Sardana <[email-masked]>
Date: Wed, 20 Mar 2002 19:12:14 -0800

Some suggestions inline!

> scope for discussion?  For standardization?

The access part (request/reply) and the format of access should be
standardized.

> Can we talk about what the Location Server can or

This would restrict the implementation of Location Server. There are
many proposals of Location Framework (LIF, WAP etc.) but they all talk
about the mechanisms of location access, to retrieve the target location
object, but not the implementation. The Location Server should be free
to do/manage whatever it wants to with regards to location data.

> is passed, and how.  We can talk about how it is

Yes, this sounds like the right idea.

> element does with the data.

True and it limits the implementation which needs to be avoided.

regards,

Bobby Sardana.
[email-masked]