Subject: RE: AW: [Geopriv] Quickrandomcommentsondraft-ietf-geopriv-pdif-lo -profile-00

From: "James M. Polk" <[email-masked]>
Date: Thu, 14 Jul 2005 19:33:00 -0500

At 09:39 AM 7/15/2005 +1000, James Winterbottom wrote:

>In Line
>
> >They are however as explicit as the subfloor-basement B.
> >
> >Henning, are you suggesting that if we do a DHCP request and a DHCP
> >request for Geo that we put the results into the same
> >tuple->status->GeoPriv->location-info?
>
>I don't understand this question.
>
>If a client requests a DHCP Option 123, the client will get a 3 axis geo
>back (if altitude is known. There is no civic here.
>
>AJW-- If the altitude is expressed as floors, then yes you do have a civic 
>component. This in my opinion MUST be represented inside the same 
>location-info element. That is, the same location-info element will 
>contain a Geo for Lat Long, AND a civic detailing the floor.

so, under gml 3.0 speak (gml 3.1 replaces "point" with "pos" for position), 
you would produce something like this (subset) from a DHCP Option 123 Reply 
(I start at the status line, and omit all others above and below for brevity):

<status>
  <gp:geopriv>
   <gp:location-info>
    <gml:location>
     <gml:Point gml:id="point96" srsName="epsg:4326">
       <gml:coordinates>33.001111N
                 96.68142W</gml:coordinates>
     </gml:Point>
    </gml:location>
    <method>dhcp</method>
    <gml:location>
    <cl:civilAddress>
     <cl:FLR>2</cl:FLR>
    <cl:civilAddress>
    <method>dhcp</method>
   <gp:location-info>
  <gp:geopriv>
<status>

[I also purposely left out the retention and distribution elements]

Or would you want to create a larger PIDF-LO with more information within 
the Civic location-info portion of the message body?

>If this is the only "location" a client knows - Henning - are you asking for:
>
>AJW-- We need to be very careful what we mean by a PIDF-LO here. Do you 
>mean 2 location types in the same location-info element, 2 GeoPriv 
>elements in the same tuple->status, 2 separate tuples, or two PIDF documents?

this is what's not clear to me - which is the reason I give a partial 
example above to discuss.

>1) two PIDF-LOs (one for geo, and one just for the <FLR/> element)?
>
>2) one PIDF-LO - with a full vert/hor gml elements and altitude in the
>separate gl elements?
>
>3) something else?
>
> >My preference would be for there to be two tuples in this case, one for
> >the Geo and one for the civic, since they were provided with separate
> >requests.
>
>I think Henning is asking for two of your tuples from the same DHCP Option
>123 reply - and I don't like that.
>
>AJW-- Not quite sure that I agree here, isn't the Civic DHCP draft going 
>to have its own DHCP option?.. My suggestion and thoughts are that one 
>option, 1 location-info element, that is ONE GeoPriv status element.
>
> >This being the case, I see a need for both. The selection of which
> >location to actually use in any PIDF-LO can then be addressed with the
> >earlier rules.
> >
> >
> >_______________________________________________
> >Geopriv mailing list
> >[email-masked]
> ><https://www1.ietf.org/mailman/listinfo/geopriv>https://www1.ietf.org/mai 
> lman/listinfo/geopriv
>
>cheers,
>James
>
>                                  *******************
>                  Truth is not to be argued... it is to be presented.

cheers,
James

                                 *******************
                 Truth is not to be argued... it is to be presented.

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Carl Reed OGC" <[email-masked]>
Date: Fri, 15 Jul 2005 11:11:34 -0600

James -

As a follow-up to my previous email to you on GML. I forgot to show how this 
is embedded into your overall example!

<status>
  <gp:geopriv>
   <gp:location-info>
    <gml:location>
     <gml:Point gml:id="point96" 
srsName="http://www.opengis.org/CRScatalogue.xml#epsg_4326">
       <gml:pos>33.001111  96.68142</gml:pos>
     </gml:Point>
    </gml:location>
    <method>dhcp</method>
    <gml:location>
    <cl:civilAddress>
     <cl:FLR>2</cl:FLR>
    <cl:civilAddress>
    <method>dhcp</method>
   <gp:location-info>
  <gp:geopriv>
<status>

This example also shows how to use the traditional expression for the 
srsName. This was provided by one of the editors of the GML document.

Regards
Carl
OGC
----- Original Message ----- 
From: "James M. Polk" <[email-masked]>
To: "James Winterbottom" <[email-masked]>
Cc: "'GEOPRIV'" <[email-masked]>
Sent: Thursday, July 14, 2005 6:33 PM
Subject: RE: AW:[Geopriv] 
Quickrandomcommentsondraft-ietf-geopriv-pdif-lo -profile-00

> so, under gml 3.0 speak (gml 3.1 replaces "point" with "pos" for 
> position), you would produce something like this (subset) from a DHCP 
> Option 123 Reply (I start at the status line, and omit all others above 
> and below for brevity):
>
> <status>
>  <gp:geopriv>
>   <gp:location-info>
>    <gml:location>