Subject: RE: [Geopriv] PIDF-LO needs a "derived from another form" method

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 21 Jul 2005 11:28:28 +0100

I am not sure I see a problem with derived data, providing the original data is also provided.

I therefore think that where the location relates to an emergency situation, that SHOULD has to be a MUST. Otherwise Brian's text looks OK to me.

It then falls onto the PSAP to take the information it is best able to handle. That is assuming that we have made it possible to be always clear whether it is derived or not, and also clear what the source of each location is.

regards

Keith

Keith Drage
Lucent Technologies
[email-masked]
tel: +44 1793 776249

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Marc Berryman
> Sent: 20 July 2005 21:59
> To: Brian Rosen; GEOPRIV
> Cc: Cindy Clugy
> Subject: RE: [Geopriv] PIDF-LO needs a "derived from another form"
> method
> 
> 
> I am a strong believer in the conversion from a geo to a 
> civic location
> should be the sole responsibility of the PSAP. No other authority,
> agency, or agent should be allowed to assume that responsibility.
> 
> I have seen too many times in the Phase II world (bad analogy, but it
> illustrates a point) where the civic location "selected" for 
> the geo was
> incorrect and caused a delayed response.
> 
> >From the PSAP, the transformation must remain at the PSAP.
> 
> 
> 
> Marc B
> 
> 
> 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Brian Rosen
> Sent: Wednesday, July 20, 2005 1:33 PM
> To: 'GEOPRIV'
> Subject: [Geopriv] PIDF-LO needs a "derived from another form" method
> 
> 
> In draft-ietf-geopriv-pidf-lo-03, there is a "method" parameter that
> describes how the location was determined.  Although I don't like the
> whole
> idea, it seems clear that many folks want to allow transformations
> between
> civic and geo, and sending both forms in one tuple.  If we do 
> that, then
> the
> method should be "derived" or something like it, indicating that the
> location data was not determined originally by that method, but some
> transformation has been applied to it.  This needs another registered
> value.
> 
> I would like text that says, "If location is provided with method
> 'derived',
> the original version of the data, with the method actually used to
> determine
> it SHOULD also be provided".
> 
> Brian
> 
> 
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/geopriv
> 

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Marc Berryman" <[email-masked]>
Date: Thu, 21 Jul 2005 07:17:56 -0500

I have no problem with a translation service being offered as an option,
but for emergency services, the original data is needed.

Marc B

-----Original Message-----
From: Ted Hardie [mailto:[email-masked]] 
Sent: Wednesday, July 20, 2005 6:02 PM
To: Marc Berryman; Brian Rosen; GEOPRIV
Cc: Cindy Clugy
Subject: RE: [Geopriv] PIDF-LO needs a "derived from another form"
method

At 4:29 PM -0500 7/20/05, Marc Berryman wrote:
>Give me the original, unadulterated, raw, un-massaged data, and give it
>to me in a way I can tell it is the original data. I think that will be
>a rallying call from the majority of the PSAP's.
>
>The PSAP's know their local area better than anyone else (except maybe
>the firemen), they will (probably) not want any helpful service doing
>the translation for them, when they know their area and the day-to-day
>changes to the local geography.
>
>
>Marc B

Please remember that PIDF-LO will be used in many contexts outside
emergency services; having a mechanism that fits those contexts need
not impact the emergency service context at all. The transformation
method may well end up being more prominent in those use cases than
in emergency services.

			regards,
				Ted