Subject: [Geopriv] Clarification of comments on Relative Loc draft

From: "Winterbottom, James" <[email-masked]>
Date: Thu, 26 Jul 2007 14:18:16 -0500

Hi All,

This is just a clarification of my previous comments made on this draft,
as I am not sure that points I made are quite the points described in
Marc's final slide. (www.nostrum.com/~rjsparks/RelativeLoc.pdf)

Attached to this email is a very quickly thrown together XML schema that
crudely defines the form of location I was suggesting (this has
certainly got bugs in it). An example of what a fragment using this
schema might look like is included below.

<location-info>
<relativeLocation
xmlns:relLoc="urn:ietf:params:xml:ns:geopriv:relativeLoc">
    <referenceLoc>
        <gml:Point> -34.25626327 122.44447 </gml:Point>
    </referenceLoc>
    <xOrientation uom="urn:ogc:def:uom:EPSG::9102">
        45
    </xOrientation>
    <offset uom="urn:ogc:def:uom:EPSG::9001">
       <x>15</x>
       <y>26</y>
    </offset>
</relativeLocation>
</location-info>

Now to try and describe my view of the orientation parameter. It define
the orientation of the reference point with respect to North, and set
the vectors for the subsequent x,y and z offsets. If you look at slide 4
from Marc's pack, the elevator used as the reference point is oriented
at about 45 degrees to North. The offset is then measured from this
position with x being in line with the orientation defined.

I believe that this solution provides everything that Marc's
specification is trying to achieve, but without introducing x,y, z and
UOM into the civic form.

Cheers
James

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Marc Linsner" <[email-masked]>
Date: Sat, 28 Jul 2007 14:43:12 -0400

James,

A fundamental question.  Please provide the use case for expressing relative
location via geo?  (I'm sure there may be one, I just can't think of it
right now!)  Why would one not simply recalculate and provide a simple
point?

-Marc- 

> -----Original Message-----
> From: Winterbottom, James [mailto:[email-masked]] 
> Sent: Thursday, July 26, 2007 3:18 PM
> To: Geopriv
> Subject: [Geopriv] Clarification of comments on Relative Loc draft
> 
> Hi All,
> 
> This is just a clarification of my previous comments made on 
> this draft, as I am not sure that points I made are quite the 
> points described in Marc's final slide. 
> (www.nostrum.com/~rjsparks/RelativeLoc.pdf)
> 
> Attached to this email is a very quickly thrown together XML 
> schema that crudely defines the form of location I was 
> suggesting (this has certainly got bugs in it). An example of 
> what a fragment using this schema might look like is included below.
> 
> <location-info>
> <relativeLocation
> Now to try and describe my view of the orientation parameter. 
> It define the orientation of the reference point with respect 
> to North, and set the vectors for the subsequent x,y and z 
> offsets. If you look at slide 4 from Marc's pack, the 
> elevator used as the reference point is oriented at about 45 
> degrees to North. The offset is then measured from this 
> specification is trying to achieve, but without introducing 
> x,y, z and UOM into the civic form.
> 
> Cheers
> James
>

---

From: "Winterbottom, James" <[email-masked]>
Date: Sat, 28 Jul 2007 17:29:42 -0500

Hi Marc,

This was an example, though if I have the corner of a building's survey
coordinates and my X,Y measurements are in mm, again for example then
recalculating for simple geo may not be worth the trouble.

Also, I would put an extensibility point into the reference component of
my schema, so I could, for example, use the same mechanism to position
flaws or pits in rolled steel.

I like the idea of relative locations as I have said before, but I don't
like the currently proposed implementation in your draft as it muddies
the civic form. I have provide you with a schema that avoids this and
still allows you to represent what you were trying to do.

Cheers
James

> From: Marc Linsner [mailto:[email-masked]]
> Sent: Sunday, 29 July 2007 4:43 AM
> To: Winterbottom, James; 'Geopriv'
> Subject: RE: [Geopriv] Clarification of comments on Relative Loc draft
> 
> James,
>

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 30 Jul 2007 08:31:42 -0400

James,

> 
> I like the idea of relative locations as I have said before, 
> but I don't like the currently proposed implementation in 
> your draft as it muddies the civic form. I have provide you 
> with a schema that avoids this and still allows you to 
> represent what you were trying to do.

No, what you provided requires people to use geo.  Converting civic minded
people to geo is an argument I lost long ago.

-Marc-

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 30 Jul 2007 07:35:07 -0500

Marc,

Please look at the schema before making statements like the one below.
The schema allows either a civic or a geo reference point. Measurements,
will be X, Y and possible Z no matter what, as they are in your
proposal.

Cheers
James

> Sent: Monday, 30 July 2007 10:32 PM

---

From: "Marc Linsner" <[email-masked]>
Date: Mon, 30 Jul 2007 08:49:39 -0400

James,

Call me stupid.  I've included the schema you are suggesting.  It appears to
be a standalone location description to me, a geo reference point and
offset.  Please explain the opportunity to express civic descriptions within
your suggestion.

<location-info>
<relativeLocation

-Marc-

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 30 Jul 2007 15:10:08 -0500

Marc,

I shall refrain.
This is NOT the schema that was attached to the email I sent, but only
the example as I stated earlier.

The schema, that was an attachment, states the following:

<xs:complexType name="referenceLocation">
    <xs:complexContent>
      <xs:choice>
        <xs:element ref="ca:civicAddress"/>
        <xs:element ref="gml:Point"/>
      </xs:choice>
    </xs:complexContent>
  </xs:complexType>

Cheers
James

> Sent: Monday, 30 July 2007 10:50 PM
> Call me stupid.  I've included the schema you are suggesting.  It
appears
> to