Subject: [Geopriv] Comments for draft-marshall-geopriv-lbyr-requirements-02

From: Hannes Tschofenig <[email-masked]>
Date: Sat, 21 Jul 2007 20:23:24 +0200

I have a few high-level comments:

The entire draft is far too long. Shorten the introduction (max 1 page) 
and clarify that there are two sets of requirements in the document: 1) 
for the LCP and 2) for the dereferencing protocol.

Section 2:
Clarify that these requirements refer to the protocol rather than to the 
reqs in the doc

Section 3: Terminology

You need to decide whether you really want to replicate terms again. I 
suggest not todo that. If you copy them then do it 1:1.
I would also include the references to the used terms.

I suggest to use the term LbyR instead of "Location Reference Identifier"

I would combine Section 4, 5 and 6 into one section

Delete Section 7 since it is a repetition of a previous section. Delete 
Section 8, 9 and 10

Separate the requirements into two clusters: 1) LCP related requirements 
and 2) requirements that refer to the deref protocol

Rq1. Location Reference Identifier as a URI: The dereferencing protocol 
MUST support an LRI in URI form, and may support other non-URI forms.

I think we only spoke about URI based LbyRs.

You might want to combine Req2 & Req3 into something like "The LCP MUST 
support LbyRs with secure versions of URI schemes."

I would delete Req5.

Req7 & Req11 refer to the same requirement. Combine them

Req13 needs to be formulated as a requirement

Req9 and Req4 are the same.

Section 12: Security Considerations

Just refer to the security related reqs

Section 14: Contributors

You can copy the text from the other design team doc. Here is the XML code:
http://www.tschofenig.priv.at/svn/draft-tschofenig-geopriv-l7-lcp-ps/

Delete Section 15

Delete the following references
[I-D.ietf-ecrit-lost]
[I-D.ietf-ecrit-security-threats]
[I-D.ietf-geopriv-loc-filters]
[I-D.ietf-geopriv-dhcp-civil]
[RFC3261]
[RFC3825]

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Roger Marshall" <[email-masked]>
Date: Tue, 24 Jul 2007 15:40:24 -0700

Hannes:
Thank you for your review of draft-marshall-geopriv-lbyr-requirements-02

Please see my responses in-line, below.

-roger marshall.

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Saturday, July 21, 2007 11:23 AM
> To: GEOPRIV
> Subject: [Geopriv] Comments for 
> draft-marshall-geopriv-lbyr-requirements-02
> 
> The entire draft is far too long. Shorten the introduction 
> (max 1 page) and clarify that there are two sets of 
> requirements in the document: 1) for the LCP and 2) for the 
> dereferencing protocol.

Agree to shorten text, but as to requirements, we need to change the
title of the draft, since its currently titled as "Requirements for a
Location-by-Reference Mechanism used in Location Configuration and
Conveyance".

This should be changed to at least include "Dereferencing", but do we
rule out the Conveyance reqs (LbyR is a part of James Polk's
sip-conveyance draft).

> 
> Section 2:
> Clarify that these requirements refer to the protocol rather 
> than to the reqs in the doc

I'll take a look.

> 
> Section 3: Terminology
> 
> You need to decide whether you really want to replicate terms 
> again. I suggest not todo that. If you copy them then do it 1:1.

Suggest the term "LbyR Identifier".  What then do we do with "Location
URI"?

> I would combine Section 4, 5 and 6 into one section

Agree.

> 
> Delete Section 7 since it is a repetition of a previous 
> section. Delete Section 8, 9 and 10

No objection to condensing/combining Sect 7 with other earlier text.
I do think some mention of how LbyR might be used in non-L7 LCP
protocols should be mentioned.

> 
> Separate the requirements into two clusters: 1) LCP related 
> requirements and 2) requirements that refer to the deref protocol

No objection here, though need to clarify whether LbyR applies to
Conveyance or not.

> I think we only spoke about URI based LbyRs.

Agreed.

> support LbyRs with secure versions of URI schemes."

No objection.

> I would delete Req5.

No objection.

> Req7 & Req11 refer to the same requirement. Combine them

No objection.

> Req13 needs to be formulated as a requirement

Agreed.

> Req9 and Req4 are the same.

Yes, (duplication due to lcp-ps import).

> Just refer to the security related reqs

Ok.

> http://www.tschofenig.priv.at/svn/draft-tschofenig-geopriv-l7-lcp-ps/

Ok. Thanks.

> [I-D.ietf-geopriv-dhcp-civil]

Ok.

> Hannes

The information contained in this message may be privileged and/or confidential. If you are not the intended recipient, or responsible for delivering this message to the intended recipient, any review, forwarding, dissemination, distribution or copying of this communication or any attachment(s) is strictly prohibited. If you have received this message in error, please so notify the sender immediately, and delete it and all attachments from your computer and network.