Subject: [Geopriv] Comments for draft-winterbottom-geopriv-held-identity-extensions-02.txt

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 22 Jul 2007 17:39:57 +0200

Thanks for the draft. It is certainly interesting. I have read the draft 
and I have a few high-level comments:

The main usage of this document is for
* LIS-to-LIS communication: 
http://tools.ietf.org/wg/geopriv/draft-winterbottom-geopriv-lis2lis-req-00.txt
* On-Behalf-of functionality

I believe that the draft is focusing too much on the HELD usage when the 
Target itself queries its own location. The reason is that you use the 
IP address in this case.
Right?

I think that this needs to be made very clear.

There are many identifiers in this document. That's fine. I do, however, 
wonder how some scenarios look like.

I think every identifier needs to come with a description with who has 
to know and append the identity to the HELD request. This would give 
some indication what the usage scenario could be.

I did not understand how the link identifier work.

I believe that the "depend" identifier should go into a document that 
describes the "location signing". This would provide the proper semantic 
for the identifier.
That's not a big problem though

Section 5.1: Example 1

What is the <profile></profile>?

Ciao
Hannes

_______________________________________________
Geopriv mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/geopriv

---

From: "Winterbottom, James" <[email-masked]>
Date: Sun, 22 Jul 2007 10:57:35 -0500

Hi Hannes,

I think that your observations are generally inline with what I was thinking.

<link> is perhaps a poor name. The suggested thoughts for this parameter are things like AoRs, and somebody suggested that even GRUUs could be used.
My original use-case was for a scenario that I doubt would ever occur, but I can see that identifying URIs of some kind might be a good identification source in some deployments.

As for <profile> you got me. I noticed this error the other day. It is hang-up from when HELD support a profile element allowing it to tell the LIS/LCS what it should put in fields like the <retransmission-allowed> entity etc. This will be gone for the next version.

Cheers
James

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]]
Sent: Sun 7/22/2007 10:39 AM
To: GEOPRIV
Subject: [Geopriv] Comments fordraft-winterbottom-geopriv-held-identity-extensions-02.txt

Section 5.1: Example 1

Ciao
Hannes

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 22 Jul 2007 19:52:34 +0200

Hi James,

thanks for a quick response.

> My original use-case was for a scenario that I doubt would ever occur, but I can see that identifying URIs of some kind might be a good identification source in some deployments.
do you think that the functionality should be kept in the document in 
the future?

Ciao
Hannes