Subject: Re: [Geopriv] comments on draft-ietf-geopriv-relative-location

From: Martin Thomson <[email-masked]>
Date: Wed, 1 Aug 2012 10:23:29 -0700

On 31 July 2012 17:07, Kipp Jones <[email-masked]> wrote:
> Can you clarify the situation described on page 7, section 4.1 wrt dynamic
> location information.  I'm not sure I quite get how the dynamic information
> modifies the coordinate system.  In particular, how do the <speed> and
> <heading> change the coordinate system?  It seems these would only affect
> things that were measured over time, not at a point in time.

Speed and heading determine how the coordinate system moves.  Any
movement is added to the movement of the relative location.

For instance, I might have a reference frame that is heading due north
at 12m/s.  Within this frame, the Target might be moving 5m/s in the x
direction (perpendicular to the motion of the reference frame).  In
the global reference frame, the speed of the Target is 13m/s.

> Section 4.11.2.1, page 21.  wrt the 3rd coordinate in the map offset, I
> assume the origin and orientation of the 3rd dimension are left purposefully
> vague?  Is there any guidance on how that should be understood?  Seems like
> generally you could assume the 3rd dimension is vertical and positive would
> indicate 'up' with a value of 0 being the 'bottom' of the map.

The orientation of the axes in the map are intentionally vague because:

   This value is measured in a map-type
   dependent manner, using the coordinate system of the map

Different maps have different conventions and up == third positive
axis is not actually consistently used.

> Section 4.11.2.2, page 21, first paragraph, 3rd sentence should read "...sum
> of the orientation field..."

Brian...

> Other than that, great stuff, I'm all for it!
>
> Cheers,
>
> Kipp
> ..............................................
> Kipp Jones
> Chief Architect/Privacy Czar
> [email-masked]
> m: 404.213.9293 | @skykipp
>
>
> _______________________________________________
> Geopriv mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/geopriv
>

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 24 Aug 2012 17:46:10 -0400

Kipp, do the responses from Carl and Martin resolve your issues?

Alissa

---

From: Kipp Jones <[email-masked]>
Date: Sat, 25 Aug 2012 09:41:16 -0500

Yes, makes sense now, appreciate the follow ups.

I'm still fuzzy on how the map orientation is communicated, but I'm assuming that is outside the scope of this document. 

Thanks again,

Kipp

---

From: Martin Thomson <[email-masked]>
Date: Sat, 25 Aug 2012 23:09:29 -0700

> I'm still fuzzy on how the map orientation is communicated, but I'm assuming that is outside the scope of this document.

What constitutes "north", "east", "up", etc for a map are something
that the map will have to describe.  The draft describes how an image
is (normally) oriented: north is negative y, east is positive x.
Other document formats might have more precise definitions of how
these appear.