Subject: [GROW] On BGP Communities

From: Benoit Donnet <[email-masked]>
Date: Tue, 4 Dec 2007 10:55:46 +0100

Dear Grow Working Group,

During the past years, we have seen an increasing usage of the BGP  
community attribute.  For instance, in a recent BGP table dump from  
routeviews, 99% of the routes stored by the router carries BGP  
communities.

In this context, we are currently working on a BGP community  
taxonomy, i.e., we want to classify and document communities  
according to their usage.  We describe our taxonomy on the following  
url: http://inl.info.ucl.ac.be/communities

Based on this taxonomy, we tried to collect as much as possible  
information on BGP communities.  This was a daunting task as we  
mainly relied on public database, such as whois server and ISP web  
sites.

Our current database of classified BGP communities currently contains  
more than 27,000 entries.

As researchers, we are now in the process of writing a paper on our  
work on BGP communities.

We plan to submit this paper to ACM SIGCOMM Computer Communication  
Review for the April issue.  This is an editorial paper (max. 4 pages).

You can find a preprint of the paper at the following URL: http:// 
inl.info.ucl.ac.be/communities or directly at  http:// 
inl.info.ucl.ac.be/system/files/communities.pdf

Any comments on the paper is welcome.

Thank you very much.

Keep on Rockin'

Dr. Benoit Donnet & Prof. Olivier Bonaventure

--
Dr. Benoit Donnet
Université Catholique de Louvain (UCL)
Faculté des Sciences Appliquées - Département d'Ingénierie  
Informatique (INGI)
Place Sainte Barbe, 2
1348 Louvain-la-Neuve
Belgium
Phone: +32 10 47 87 18
Home page: http://inl.info.ucl.ac.be/donnet

_______________________________________________
GROW mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/grow

---

From: "Michael Hallgren" <[email-masked]>
Date: Tue, 4 Dec 2007 16:59:06 +0100

Hi Benoit,

A minor correction:

<quote>
AS. This community indicates the AS from which a route was learned. This is
different 
from the Type of Peer type as it does not give any information on the type
of route. 
For instance, for AS8938, all routes learned from TeleGlobe are tagged with
8938:2100.
</quote>

is not the case in AS6453 (Teleglobe). Out of curiosity, how did you source
that info?

mh (AS6453) 

> -----Message d'origine-----
> De : Benoit Donnet [mailto:[email-masked]] 
> Envoyé : mardi 4 décembre 2007 10:56
> À : [email-masked]
> Objet : [GROW] On BGP Communities
> 
> Dear Grow Working Group,
> 
> During the past years, we have seen an increasing usage of 
> the BGP community attribute.  For instance, in a recent BGP 
> table dump from routeviews, 99% of the routes stored by the 
> router carries BGP communities.
> 
> Based on this taxonomy, we tried to collect as much as 
> possible information on BGP communities.  This was a daunting 
> task as we mainly relied on public database, such as whois 
> server and ISP web sites.
> 
> Our current database of classified BGP communities currently 
> contains more than 27,000 entries.
> 
> As researchers, we are now in the process of writing a paper 
> on our work on BGP communities.
> 
> We plan to submit this paper to ACM SIGCOMM Computer 
> Communication Review for the April issue.  This is an 
> editorial paper (max. 4 pages).
> 
> You can find a preprint of the paper at the following URL: 
> http:// inl.info.ucl.ac.be/communities or directly at  
> http:// inl.info.ucl.ac.be/system/files/communities.pdf
> 
> Informatique (INGI) Place Sainte Barbe, 2
> 1348 Louvain-la-Neuve
> Belgium
> Phone: +32 10 47 87 18

---

From: Benoit Donnet <[email-masked]>
Date: Tue, 4 Dec 2007 17:10:54 +0100

Hello Michael,

> is not the case in AS6453 (Teleglobe). Out of curiosity, how did  

You got a point!  This is an error in the paper :(

I really apologize for that and thanks so much for the correction!

I should be more rigorous with that.

Keep on Rockin'

Benoit

---

From: "Michael Hallgren" <[email-masked]>
Date: Tue, 4 Dec 2007 17:21:35 +0100

> 
> Hello Michael,
> 
> > is not the case in AS6453 (Teleglobe). Out of curiosity, 
> how did you 
> > source that info?
> 

No problem. You're welcome.

> I should be more rigorous with that.

In a nutshell, AS6453 provide "customer facing community values" as follows:

- RFC1998 style ones,
- I'm a peer-route signal,
- Import geo-origin codes (site granularity),
- A series of values that may be used to influence the propagation of a pfx
to
  peers, 
- black-hole signalling.

> Keep on Rockin'

Same to you

mh

> >> http:// inl.info.ucl.ac.be/communities or directly at http:// 
> >> Université Catholique de Louvain (UCL) Faculté des Sciences 
> >> Appliquées - Département d'Ingénierie Informatique (INGI) Place 
> >> Sainte Barbe, 2
> >> 1348 Louvain-la-Neuve
> >> Belgium
> >> Phone: +32 10 47 87 18

---

From: "Kris Foster" <[email-masked]>
Date: Tue, 4 Dec 2007 11:37:41 -0500

> -----Original Message-----
> From: Benoit Donnet [mailto:[email-masked]] 
> Sent: Tuesday, December 04, 2007 11:11 AM
> To: Michael Hallgren
> Cc: [email-masked]
> Subject: Re: [GROW] On BGP Communities
> 
> 
> Hello Michael,
> 

I'm not sure this is an error. AS8938 is claiming in their IRR remarks that they are setting 8938:2100 on prefixes learned from AS6453 (not AS6453 setting this community).

aut-num: AS8938 
...
remarks: all routes from TeleGlobe tagged with 8938:2100

Kris

> >> Informatique (INGI) Place Sainte Barbe, 2 1348 Louvain-la-Neuve
> >> Belgium
> >> Phone: +32 10 47 87 18

---

From: "Michael Hallgren" <[email-masked]>
Date: Tue, 4 Dec 2007 17:58:56 +0100

> > You got a point!  This is an error in the paper :(

Hi Kris,

> 
> I'm not sure this is an error. AS8938 is claiming in their 
> IRR remarks that they are setting 8938:2100 on prefixes 
> learned from AS6453 (not AS6453 setting this community).
> 
> aut-num: AS8938
> ...

gin-b1d-core1#sh ip b reg ^8938_
BGP table version is 275750669, local router ID is 66.110.0.93
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i62.29.128.0/17   66.110.0.107             0    100      0 8938 i
* i                 66.110.0.107             0    100      0 8938 i
*>i                 66.110.0.107             0    100      0 8938 i
* i                 66.110.0.107             0    100      0 8938 i
* i                 66.110.0.107             0    100      0 8938 i
* i                 66.110.0.107             0    100      0 8938 i
<snip/>

gin-b1d-core1#sh ip bgp com 8938:2100

gin-b1d-core1#

because we control the set of communities that we accept at import time
(to the well-known ones and the set of values that we operate on).

mh

> > >> Envoyé : mardi 4 décembre 2007 10:56 À : [email-masked] Objet : 
> > >> [GROW] On BGP Communities
> > >>
> > >> Dear Grow Working Group,
> > >>
> Communication 
> > >> Sainte Barbe, 2 1348 Louvain-la-Neuve Belgium
> > >> Phone: +32 10 47 87 18
> Appliquées 
> > - Département d'Ingénierie Informatique (INGI) Place Sainte Barbe, 2
> > 1348 Louvain-la-Neuve
> > Belgium
> > Phone: +32 10 47 87 18

---

From: Richard A Steenbergen <[email-masked]>
Date: Tue, 4 Dec 2007 12:13:53 -0500

> mainly relied on public database, such as whois server and ISP web  

Charlie Gucker provides a free service of archiving BGP community guides 
from multiple networks. The archive is currently at:

http://www.onesc.net/communities/

Some of these are public and easy to obtain, some are not. :)

I also did a NANOG presentation which tries to throughly cover the kind 
of information that a service provider might want to encode into 
communities, and how they might best go about doing that:

http://www.nanog.org/mtg-0706/steenbergen2.html

-- 
Richard A Steenbergen <[email-masked]>       http://www.e-gerbil.net/ras
GPG Key ID: 0xF8B12CBC (7535 7F59 8204 ED1F CC1C 53AF 4C41 5ECA F8B1 2CBC)

---

From: "Kris Foster" <[email-masked]>
Date: Tue, 4 Dec 2007 13:57:23 -0500

> because we control the set of communities that we accept at 
> import time (to the well-known ones and the set of values 
> that we operate on).

This is the behaviour that is expected. The community 8938:2100 is presumably set by AS8938 and visible in AS8938's BGP RIBs on all routes with paths matching ^6453_. 

Neighbors of AS8938 may also see 8938:2100 (depending on policy).

Kris

> > > >> [email-masked] https://www1.ietf.org/mailman/listinfo/grow
> > > >>
> > > >>
> > > >
> > > >
> > > >
> > > >

---

From: "Michael Hallgren" <[email-masked]>
Date: Tue, 4 Dec 2007 22:08:09 +0100

> > because we control the set of communities that we accept at import 
> > time (to the well-known ones and the set of values that we operate 
> > on).
> 
> This is the behaviour that is expected. The community 
> 8938:2100 is presumably set by AS8938 and visible in AS8938's 
> BGP RIBs on all routes with paths matching ^6453_.

Yes. Right.
 
> Neighbors of AS8938 may also see 8938:2100 (depending on policy).

Sure. We restrict this among other to avoid having neighbors 
Potentially send values that may interfere with other internally 
used community values.

mh

> > > > >> Review for the April issue.  This is an editorial 
> paper (max. 4 
> > > > >> pages).
> > > > >>