Subject: [GROW] FIB scaling through configuration

From: Paul Francis <[email-masked]>
Date: Wed, 28 May 2008 03:36:00 -0400

Gang,

As some of you may know, my students and I have been working of a way to
reduce DFZ FIB size in routers using a technique that requires only
modifications in router configuration...no software or protocol changes are
needed...and that can be independently deployed by individual ISPs.  The
approach is called Virtual Aggregation (VA), because effectively what it does
is create virtual (MPLS tunneled) networks around "virtual prefixes" (i.e.
the collection of destinations within a large, otherwise unaggregatable
prefix like a /7).  VA has a trade-off of increasing path-length and load
with shrinking the FIB, but the increase is negligible for even a 10x FIB
reduction, which can extend the lifetime of a router for years.

I was giving a talk on this at the last RIPE, and Jari Arkko suggested that I
should see if GROW is interested in pursuing this.  (It doesn't appear
appropriate for either RRG or IDR, in effect because those groups are looking
at mechinisms that actually change routers.)

The idea would be to have GROW flush out and improve the basic approach we
have specified so far, with a goal of writing a best practices type RFC. 

Details of VA can be found in
http://www.cs.cornell.edu/people/francis/va-wp.pdf.  I'd be very willing to
turn this into an I-D that could be discussed in Dublin.

I need to point out that Cornell owns IPR on this.  Though Cornell hasn't
released an official statement about it, at worst it would be offered on fair
and reasonable terms, and at best for free with no restrictions.

Thanks,

PF

ps. We have an analogous piece of work that effectively eliminates the FIB
for L3-VPN entries, but that is probably a topic for a different WG.

_______________________________________________
GROW mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/grow

---

From: Geoff Huston <[email-masked]>
Date: Wed, 28 May 2008 17:51:13 +1000

> I need to point out that Cornell owns IPR on this.

Even though this precise approach was described and discussed in the Big-Internet mailing list back in 1992? For those with memories that extend back to then such claims of proprietary ownership of the same concept some 16 years later appear to be somewhat ambitious.

[As a side note, this IPR stuff is getting to be overwhelming in a number of ways. I have an increasing sympathy for the view that espouses that open standards should work within a scope of describing openly available unencumbered technology, and that private ownership of a concept with restrictions and encumberences on third party use should take it out of the public realm of open standardisation. But thats a topic for another mailing list of course!]

In any case, for the record, I oppose bringing this IPR-encumbered work into GROW. If Cornell are prepared to make a firm undertaking to the IETF in the usual manner of unrestricted and unencumbered access, or are prepared to withdraw their IPR claim (well, I can dream!), then my opposition to this proposal for GROW to take on this approach may change.

regards,

  Geoff

---

From: Paul Francis <[email-masked]>
Date: Wed, 28 May 2008 04:15:55 -0400

Obviously we wouldn't be making IPR claims if we knew that the approach was
already described.  I'll go ahead and dig through the Big-I mailing from
around '92 myself, but if you can point me to specifics (name of the
approach, authors of the approach, etc.), that'd be much appreciated.
 
PF

________________________________

From: Geoff Huston [mailto:[email-masked]]
Sent: Wed 5/28/2008 3:51 AM
To: Paul Francis
Cc: [email-masked]
Subject: Re: [GROW] FIB scaling through configuration

> I need to point out that Cornell owns IPR on this.

Even though this precise approach was described and discussed in the
Big-Internet mailing list back in 1992? For those with memories that extend
back to then such claims of proprietary ownership of the same concept some 16
years later appear to be somewhat ambitious.

[As a side note, this IPR stuff is getting to be overwhelming in a number of
ways. I have an increasing sympathy for the view that espouses that open
standards should work within a scope of describing openly available
unencumbered technology, and that private ownership of a concept with
restrictions and encumberences on third party use should take it out of the
public realm of open standardisation. But thats a topic for another mailing
list of course!]

In any case, for the record, I oppose bringing this IPR-encumbered work into
GROW. If Cornell are prepared to make a firm undertaking to the IETF in the
usual manner of unrestricted and unencumbered access, or are prepared to
withdraw their IPR claim (well, I can dream!), then my opposition to this
proposal for GROW to take on this approach may change.

regards,

  Geoff

---

From: Paul Francis <[email-masked]>
Date: Wed, 28 May 2008 05:43:04 -0400

You know, I'm being stupid about this.  The IPR was established a while back
to keep my options open for doing a startup.  I've long since given up on
that idea, so we'll make the IPR unrestricted and unencumbered, and I'll look
into having the IPR claim withdrawn altogether.
 
Sorry for the run around.
 
PF

regards,

  Geoff

---

From: Geoff Huston <[email-masked]>
Date: Wed, 28 May 2008 22:13:41 +1000

I which case I have no further objection for this work to be taken on by GROW - indeed, given this response from Paul I support this being taken on by GROW.

Thanks very much Paul for your response.

Geoff

Paul Francis wrote:
> You know, I'm being stupid about this.  The IPR was established a while 
> back to keep my options open for doing a startup.  I've long since given 
> up on that idea, so we'll make the IPR unrestricted and unencumbered, 
> and I'll look into having the IPR claim withdrawn altogether.
>  
> ------------------------------------------------------------------------
> *From:* Geoff Huston [mailto:[email-masked]]
> *Sent:* Wed 5/28/2008 3:51 AM
> *To:* Paul Francis
> *Cc:* [email-masked]
> *Subject:* Re: [GROW] FIB scaling through configuration
> 
> Big-Internet mailing list back in 1992? For those with memories that 
> extend back to then such claims of proprietary ownership of the same 
> concept some 16 years later appear to be somewhat ambitious.
> 
> [As a side note, this IPR stuff is getting to be overwhelming in a 
> number of ways. I have an increasing sympathy for the view that espouses 
> that open standards should work within a scope of describing openly 
> available unencumbered technology, and that private ownership of a 
> concept with restrictions and encumberences on third party use should 
> take it out of the public realm of open standardisation. But thats a 
> topic for another mailing list of course!]
> 
> In any case, for the record, I oppose bringing this IPR-encumbered work 
> into GROW. If Cornell are prepared to make a firm undertaking to the 
> IETF in the usual manner of unrestricted and unencumbered access, or are 
> prepared to withdraw their IPR claim (well, I can dream!), then my 
> opposition to this proposal for GROW to take on this approach may change.
> 
> regards,
> 
>   Geoff
>

---

From: Paul Francis <[email-masked]>
Date: Wed, 28 May 2008 09:21:12 -0400

Thanks.  I'm still very curious about what went on in Big-I that predates
this.  I know lots of ideas were thrown around, and of course some of them
involved tunneling, but I don't recall any that were very similar to VA.  In
any event, equipment in the field has evolved enough that this can now be
done, so good to have a fresh look.

PF

> -----Original Message-----
> Sent: Wednesday, May 28, 2008 8:14 AM
> To: Paul Francis
> Cc: [email-masked]
> I which case I have no further objection for this work to be 
> taken on by GROW - indeed, given this response from Paul I 
> support this being taken on by GROW.
> 
> > You know, I'm being stupid about this.  The IPR was established a 
> > while back to keep my options open for doing a startup.  I've long 
> > since given up on that idea, so we'll make the IPR unrestricted and 
> > unencumbered, and I'll look into having the IPR claim 
> withdrawn altogether.
> >  
> > number of ways. I have an increasing sympathy for the view that 
> > espouses that open standards should work within a scope of 
> describing 
> > openly available unencumbered technology, and that private 
> ownership 
> > of a concept with restrictions and encumberences on third party use 
> > should take it out of the public realm of open standardisation. But 
> > thats a topic for another mailing list of course!]
> > 
> > In any case, for the record, I oppose bringing this IPR-encumbered 
> > work into GROW. If Cornell are prepared to make a firm 
> undertaking to 
> > the IETF in the usual manner of unrestricted and 
> unencumbered access, 
> > or are prepared to withdraw their IPR claim (well, I can 
> dream!), then 
> > my opposition to this proposal for GROW to take on this 
> approach may change.
> > 
> > regards,
> > 
> >   Geoff
> > 
> 
>

---

From: Geoff Huston <[email-masked]>
Date: Wed, 28 May 2008 23:39:58 +1000

I'm relying on a memory of a mail conversation from 16 years ago :-(

Fortunately, the list archive is around (ftp://munnari.oz.au/big-internet/list-archive) but I really don't have the time to do the search though the archive to find the thread - maybe someone else has both the time and the motivation!

   Geoff

---

From: Paul Francis <[email-masked]>
Date: Wed, 28 May 2008 10:15:54 -0400

Other than giving credit where credit is due (which us academics are big on),
it probably won't matter much...we need to rethink the whole thing in the
modern context anyway.

Would love to hear from other GROW-folks about interest or lack thereof in
pursuing VA-style operational fixes to scaling!

PF

> Sent: Wednesday, May 28, 2008 9:40 AM
> To: Paul Francis
> Cc: [email-masked]
> Fortunately, the list archive is around 
> (ftp://munnari.oz.au/big-internet/list-archive) but I really 
> don't have the time to do the search though the archive to 
> find the thread - maybe someone else has both the time and 
> the motivation!
> 
>    Geoff
> 
> 
> Paul Francis wrote:
> > Thanks.  I'm still very curious about what went on in Big-I that 
> > predates this.  I know lots of ideas were thrown around, 
> and of course 
> > some of them involved tunneling, but I don't recall any 
> that were very 
> > similar to VA.  In any event, equipment in the field has evolved 
> > enough that this can now be done, so good to have a fresh look.
> > 
> > PF
> > 
> > 
> >> I which case I have no further objection for this work to 
> be taken on 
> >> by GROW - indeed, given this response from Paul I support 
> this being 
> >> taken on by GROW.
> >>
> ---------------------------------------------------------------------
> >> -
> >>> --