Subject: [GROW] I-D Action: draft-ietf-grow-ops-reqs-for-bgp-error-handling-01.txt

From: [email-masked]
Date: Tue, 28 Jun 2011 04:00:23 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Global Routing Operations Working Group of the IETF.

	Title           : Operational Requirements for Enhanced Error Handling Behaviour in BGP-4
	Author(s)       : Rob Shakir
	Filename        : draft-ietf-grow-ops-reqs-for-bgp-error-handling-01.txt
	Pages           : 26
	Date            : 2011-06-28

   BGP-4 is utilised as a key intra- and inter-Autonomous System routing
   protocol in modern IP networks.  The failure modes as defined by the
   original protocol standards are based on a number of assumptions
   around the impact of session failure.  Numerous incidents both in the
   global Internet routing table and within Service Provider networks
   have been caused by strict handling of a single invalid UPDATE
   message causing large-scale failures in one or more Autonomous
   Systems.

   This memo describes the current use of BGP-4 within Service Provider
   networks, and outlines a set of requirements for further work to
   enhance the mechanisms available to a BGP-4 implementation when
   erroneous data is detected.  Whilst this document does not provide
   specification of any standard, it is intended as an overview of a set
   of enhancements to BGP-4 to improve the protocol&#39;s robustness to suit
   its current deployment.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-grow-ops-reqs-for-bgp-error-handling-01.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-grow-ops-reqs-for-bgp-error-handling-01.txt

---

From: Rob Shakir <[email-masked]>
Date: Tue, 28 Jun 2011 17:08:21 +0100

Hi GROW!

> 	Filename        : draft-ietf-grow-ops-reqs-for-bgp-error-handling-01.txt

The diff for this -01 can be found at http://tools.ietf.org/rfcdiff?url2=draft-ietf-grow-ops-reqs-for-bgp-error-handling-01.txt - if you have time to review it, it would be much appreciated.

To give an executive summary of the changes that I made in this version:

- One of the comments (from Chris Morrow, and Jeff Haas) regarding the draft was that it was very loose on how it defined different error cases. I've therefore added a new section discussing what elements of the UPDATE message might be able to be recovered, and put some wording around how this should influence the error handling that is required. There was some debate around whether this needs to be more explicit (i.e. addressing how the requirements for optional transitive, optional non-transitive, et al, and how they could be user-configurable in terms of error handling behaviour). I would be interested in hearing comments on the new Section 2 - and as to whether there is a feeling that this should be further revised to be more explicit about the operational requirements here?

- After a large amount of discussion of the various requirement approaches for how, operationally, we might require further visibility into the BGP-4 protocol, based on additional complexity added as a result of requiring more focused error handling behaviour, I have added some discussion as to the required capabilities in terms of this monitoring. A lot of this debate focuses around what messaging plane it is suitable to have in-band to the BGP session, and what might be achieved via other developments. As such, I am very interested to solicit the working group's input on this matter - particularly around whether the current requirements in the draft seem suitable.

Thanks very much to Shane Amante and Bruno Decraene for the discussions leading to this revision.

Many thanks in advance for any feedback!

Kind regards,
r.