Subject: Re: [GROW] Call for WG Adoption - draft-shishio-grow-isp-rfd-implement-survey-01

From: Shishio Tsuchiya <[email-masked]>
Date: Mon, 27 Jun 2011 15:43:29 +0900

Chairs and All
We have published latest version.
http://tools.ietf.org/html/draft-shishio-grow-isp-rfd-implement-survey-02
We could get 63 response from global operator groups.
If you have any comments,I really appreciate it.

(2011/04/01 16:55), Christopher Morrow wrote:
> Given the discussion in IDR yesterday and in GROW today, it seems that
> the room temperature pushed to adoption the survey work and potential
> default's change discussion to GROW. Could we get some discussion
> on-list about this, draft:
> draft-shishio-grow-isp-rfd-implement-survey-01
> 
> <http://tools.ietf.org/html/draft-shishio-grow-isp-rfd-implement-survey-01>
> 
> "BGP Route Flap Damping [RFC2439] is a mechanism that targets route
>     stability.  It penalyzes routes that flap with the aim of reducing
>     CPU load on the routers.
> 
>     But it has side-effects.  Thus, in 2006, RIPE recommended not to use
>     Route Flap Damping (see RIPE-378).
> 
>     Now, some researchers propose to turn RFD, with less aggressive
>     parameters, back on [draft-ymbk-rfd-usable].
> 
>     This document describes results of a survey conducted amoung service
>     provider on their use of BGP Route Flap Damping."
> 
> Again, with the goal to pick up the draft as a WG Item, and end up
> feeding Route Flap Dampening defaults back into vendor
> implementations.
> 
> Thanks!
> -Chris
> grow-co-chair
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow
>

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 27 Jun 2011 16:42:16 -0400

> If you have any comments,I really appreciate it.

Hello Grow Folks, could we have some discussion about where this doc
sits? It seems, to me, that we're pretty close to
no-substantive-comments from the WG, so WGLC should be imminent...

-Chris

---

From: "George, Wesley" <[email-masked]>
Date: Tue, 28 Jun 2011 11:24:32 -0400

I guess my first question would be, "what do we hope to accomplish by having GROW adopt this, vs having it remain an individual submission?"

The data are interesting, and while it's no fault of the survey organizers, I'm not sure that 63 respondents is something that I'd consider statistically significant. Additionally, I wish that there were some characterization of the relative size and type of the networks the respondents represent. Since network size and application figures into how much of a scaling/customer impact consideration using/not using/tweaking RFD represents, that's an important point to have. For example, large transit networks may care about RFD as a tradeoff between improved scale/performance and potential customer impact. Small/stub networks care about it from the perspective of how often they or their customers are impacted by upstream dampening.  These may lead to widely different conclusions about if and how RFD should be applied.

In terms of updates that could be made to the draft:
I think that the draft is a bit light on conclusion. Are the survey results meant to be interpreted as support for draft-ymbk-rfd-usable, or simply demonstration that updated guidance is needed, or just as points of data left to the reader to interpret?

It would be helpful (if you have the data) to discuss whether the same respondents answered NO or skipped 3.5 as answered NO or skipped 3.6 and 3.7, as that would help to explain the answers as either actively disagreeing with the premise behind "RFD considered usable" or an opinion that does not take that work into account because the respondent was not aware of it.

Thanks,

Wes George

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christopher Morrow
Sent: Monday, June 27, 2011 4:42 PM
To: Shishio Tsuchiya
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [GROW] Call for WG Adoption - draft-shishio-grow-isp-rfd-implement-survey-01

-Chris

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Shishio Tsuchiya <[email-masked]>
Date: Fri, 01 Jul 2011 01:19:44 +0900

Wes
Thanks for your comments.
> I guess my first question would be, "what do we hope to accomplish by having GROW adopt this, vs having it remain an individual submission?"

I prefer GROW adoption if it is possible.

> I think that the draft is a bit light on conclusion. Are the survey results meant to be interpreted as support for draft-ymbk-rfd-usable, or simply demonstration that updated guidance is needed, or…

draft-shishio-grow-isp-rfd-implement-survey just shows data of what operators are doing now.
The survey asking all of RFC related document,and showes the result. 
http://tools.ietf.org/agenda/80/slides/grow-5.pdf
This slide's page 4 explained relationship with the draft and another documents.

> It would be helpful (if you have the data) to discuss whether the same respondents answered NO or skipped 3.5 as answered NO or skipped 3.6 and 3.7, as that would help to explain the answers as eit…

Yes,I have the data.
The number is eleven. (5 Engineer of NI/SI+1 Engineer of Vender+4 BGP operators.)

I think it is not so many.

Regards,
-Shishio

> 2011/6/27 Shishio Tsuchiya<[email-masked]>:
>> Chairs and All