Subject: Re: [GROW] FW: New Version Notification for draft-manderson-routing-intent-00.txt

From: Geoff Huston <[email-masked]>
Date: Fri, 15 Jul 2011 10:36:57 +1000

Hi,

> I seek your feedback on the I-D below.

To what extent does this draft further alaborate on part 7 of the list in the IANA Considerations of RFC5736?

To remind the WG, that document states that the registry includes:

7.  The registry will also note, for each designation, the intended
       routing scope of the address, indicating whether the address is
       intended to be routable only in scoped, local, or private
       contexts, or whether the address prefix is intended to be routed
       globally.

So I'm left wondering what this I-D is trying to achieve over and above what is already
in RFC5736?

thanks,

  Geoff

On 22/06/2011, at 10:39 AM, Terry Manderson wrote:

> Chairs and WG,
> 
> I seek your feedback on the I-D below.
> 
> I'd also like to present this to the WG in Quebec.
> 
> Cheers
> Terry
> 
> 
> ------ Forwarded Message
>> From: <[email-masked]>
>> Date: Tue, 21 Jun 2011 17:31:50 -0700
>> To: Terry Manderson <[email-masked]>
>> Cc: Terry Manderson <[email-masked]>
>> Subject: New Version Notification for draft-manderson-routing-intent-00.txt
>> 
>> A new version of I-D, draft-manderson-routing-intent-00.txt has been
>> successfully submitted by Terry Manderson and posted to the IETF repository.
>> 
>> Filename:        draft-manderson-routing-intent
>> Revision:        00
>> Title:           Signalling Public Routing Intent (PRI) for Internet Protocol
>> Addresses in IANA Registries
>> Creation date:   2011-06-22
>> WG ID:           Individual Submission
>> Number of pages: 12
>> 
>> Abstract:
>>   This document provides direction to IANA to mark existing and future
>>   IANA IPv4 and IPv6 allocations with generic terms pertaining to the
>>   Public (global) Routing Intent (PRI).
>> 
>> 
>> 
>> 
>> The IETF Secretariat
> 
> ------ End of Forwarded Message
> 
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow

--

Geoff Huston
Chief Scientist, APNIC

+61 7 3858 3100
[email-masked]

---

From: Terry Manderson <[email-masked]>
Date: Thu, 14 Jul 2011 18:32:21 -0700

Hi,

RFC5736 deals with only the IANA IPv4 Special Purpose Address Registry, a
registry that at present contains one entry for DS-lite.

There are two ways that the instruction for IANA contained in
draft-manderson-routing-intent-01 can be taken with respect to the IANA IPv4
Special Purpose Address Registry. Either add and additional column for
Public Routing Intent (PRI) or replace the existing routing scope column
with PRI. So a clarification is worthwhile.

There are arguments for both in uniformity versus simplicity and utility.
The latter option leaves the reader to investigate routing particulars (if
not intended to be globally routable) in the RFC which made the address
assignment. 

Additionally it's also possible to add words to
draft-manderson-routing-intent to exclude the IANA IPv4 Special Purpose
Address Registry from acquiring change, as it already has a routing
designator.

What say you WG?

Cheers
Terry