Subject: [GROW] I-D Action: draft-ietf-grow-ops-reqs-for-bgp-error-handling-02.txt

From: [email-masked]
Date: Thu, 20 Oct 2011 01:44:29 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Global Routing Operations Working Group of the IETF.

	Title           : Operational Requirements for Enhanced Error Handling Behaviour in BGP-4
	Author(s)       : Rob Shakir
	Filename        : draft-ietf-grow-ops-reqs-for-bgp-error-handling-02.txt
	Pages           : 27
	Date            : 2011-10-20

   BGP-4 is utilised as a key intra- and inter-Autonomous System routing
   protocol in modern IP networks.  The failure modes as defined by the
   original protocol standards are based on a number of assumptions
   around the impact of session failure.  Numerous incidents both in the
   global Internet routing table and within Service Provider networks
   have been caused by strict handling of a single invalid UPDATE
   message causing large-scale failures in one or more Autonomous
   Systems.

   This memo describes the current use of BGP-4 within Service Provider
   networks, and outlines a set of requirements for further work to
   enhance the mechanisms available to a BGP-4 implementation when
   erroneous data is detected.  Whilst this document does not provide
   specification of any standard, it is intended as an overview of a set
   of enhancements to BGP-4 to improve the protocol&#39;s robustness to suit
   its current deployment.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-grow-ops-reqs-for-bgp-error-handling-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-grow-ops-reqs-for-bgp-error-handling-02.txt

---

From: Rob Shakir <[email-masked]>
Date: Thu, 20 Oct 2011 11:08:59 +0100

Hi GROW,

Please find an updated copy of the current BGP error handling draft working group document at the usual URLs (referenced below).

This version has had some updates to handle some editorial issues, but also:

- Some clarity has been added in around the expected behaviours around different types of errors in BGP UPDATE messages - following on from a number of discussions in both Québec, and Prague, this was a request from the WG chairs, and a number of other participants. The categories of errors described attempts to capture where it would be expected that a 'targeted' error handling mechanism can be used as opposed to cases where a session reset is unavoidable. Thanks to Alton Lo for his invaluable input on this section.

- Further to discussions around reducing the impact of a session reset - and how Graceful Shutdown may be applicable to this case - an additional subsection has been added to describe this behaviour. Thanks again to Bruno Decraene for his input on both this section, and a number of other sections of the requirements.

As such, I'd like to start a discussion with the working group and chairs as to what is outstanding in this document, or whether it is ready for WGLC. There are a couple of questions on this:

1. Are the requirements captured here complete, or is there anything that has been omitted?

2. Is further operational documentation of issues in BGP deployments, that are motivating this work, suitable for inclusion in this document, or should its scope be limited to the protocol requirements to avoid further instances of these incidents?

As always, your input is much appreciated. I won't be in Taipei, but hope that we can discuss any comments either on or off list.

Many thanks,
r.

On 20 Oct 2011, at 09:44, [email-masked] wrote:

> _______________________________________________
> GROW mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/grow