Subject: [GROW] I-D Action: draft-ietf-grow-route-leak-problem-definition-01.txt

From: [email-masked]
Date: Mon, 09 Mar 2015 14:15:43 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Global Routing Operations Working Group of the IETF.

        Title           : Problem Definition and Classification of BGP Route Leaks
        Authors         : Kotikalapudi Sriram
                          Doug Montgomery
                          Danny McPherson
                          Eric Osterweil
	Filename        : draft-ietf-grow-route-leak-problem-definition-01.txt
	Pages           : 10
	Date            : 2015-03-09

Abstract:
   A systemic vulnerability of the Border Gateway Protocol routing
   system, known as 'route leaks', has received significant attention in
   recent years.  Frequent incidents that result in significant
   disruptions to Internet routing are labeled "route leaks", but to
   date we have lacked a common definition of the term.  In this
   document, we provide a working definition of route leaks, keeping in
   mind the real occurrences that have received significant attention.
   Further, we attempt to enumerate (though not exhaustively) different
   types of route leaks based on observed events on the Internet.  We
   aim to provide a taxonomy that covers several forms of route leaks
   that have been observed and are of concern to Internet user community
   as well as the network operator community.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-grow-route-leak-problem-definition/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-grow-route-leak-problem-definition-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-grow-route-leak-problem-definition-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Mon, 9 Mar 2015 21:51:03 +0000

This is -01 version with revisions.
Andrei Robachevsky and Brian Dickson had offered comments and suggestions 
in person to me in Honolulu. This revised version includes changes based on their suggestions.
In particular, route leaks classification has been expanded to include Types 6 and 7.
Other changes include improvement of clarity in some places, and we've also added several additional relevant references.

Further comments/suggestions welcome.

Sriram  

-----Original Message-----
From: GROW [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, March 09, 2015 5:16 PM
To: [email-masked]
Cc: [email-masked]
Subject: [GROW] I-D Action: draft-ietf-grow-route-leak-problem-definition-01.txt

Abstract: