Subject: Re: [GROW] Separating the BMP Initiation and Peer Up namespaces

From: John Scudder <[email-masked]>
Date: Wed, 16 Jan 2019 21:51:28 +0000

Also bumping this one.

--John

> On Dec 14, 2018, at 6:41 PM, John Scudder <[email-masked]> wrote:
> 
> Hi All,
> 
> As I mentioned in the other thread, I think it was a mistake for Peer Up and Initiation to share a namespace in RFC 7854. The fact that it's difficult to get the text right in draft-ietf-grow-bmp-local-rib demonstrates this.
> 
> My suggestion is that we separate the namespaces. I've written and submitted a short draft to do it, draft-scudder-grow-bmp-peer-up-00.txt [1]. It seemed the most expedient way to describe the suggested approach. If the WG likes the idea, we can adopt it, or if the WG wants to fix it a different way, let's discuss.
> 
> An alternate solution would be to embrace the Information TLV as a namespace that's shared between multiple messages (the implication in draft-ietf-grow-bmp-local-rib that the Information TLV could be included in Peer Down suggests that's what the authors imagine would happen). I don't prefer this because it requires enumeration of exceptions ("foo Information type only applies when carried in such-and-such BMP message type..."). Independent namespaces ends up being a little wordier but less error-prone, IMO.
> 
> Regards,
> 
> --John
> 
> [1] https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_id_draft-2Dscudder-2Dgrow-2Dbmp-2Dpeer-2Dup-2D00.txt&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=D7IqMWtdausMkdGGw6TfUPIh8G7-jy-nCqGt8a4mysw&s=KiqiStww6xXZe8HN7VoUO2WcW049EmV0bIpjjeFkvPg&e=
> _______________________________________________
> GROW mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_grow&d=DwICAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=D7IqMWtdausMkdGGw6TfUPIh8G7-jy-nCqGt8a4mysw&s=7y0yLjzXTHGgjIubMs5n5pu9fspj-FApMH7efiVImRU&e=

---

From: Paolo Lucente <[email-masked]>
Date: Wed, 23 Jan 2019 15:05:04 +0100

Hi John,

[shared text] Ideally, i would like every BMP message type to have a (optional) TLV section, each with a own namespace. If the idea is shared, i’d look forward to see how to get there.

Given the above, I do support this. 

Paolo

> On 15 Dec 2018, at 00:41, John Scudder <[email-masked]> wrote:
> 
> Hi All,
> 
> [1] https://www.ietf.org/id/draft-scudder-grow-bmp-peer-up-00.txt
> https://www.ietf.org/mailman/listinfo/grow