Subject: RE: Question on Connection Management Messages

From: [email-masked]
Date: Fri, 7 Jan 2000 08:47:55 -0600

From: EXT Clint Bishard [mailto:[email-masked]]
> 
> GSMP connection management messages only seem to allow a 
> single set of QoS
> parameters for a given connection.  Since each connection 
> within a switch
> actually involves two different ports, shouldn't the 
> connection management
> messages have a QMS and service selector field for both the 
> input port and
> the output port instead of just one for the connection?  This seems
> necessary given that the services on the ports may be 
> different, such as
> building a connection from a FR port to an ATM port, or a 
> connection from an
> ATM port to an MPLS port.

the traffic/qos parameters assigned to a connection apply at
the output. qos management for the input is performed by the
upstream switch.

c u
tom

---

From: Clint Bishard <[email-masked]>
Date: Fri, 07 Jan 2000 11:25:46 -0600

Tom,
Thanks for the response.  It still seems like the flexibility to define per
port QoS parameters would me necessary.

I would consider policing a function of QoS, and this would occur at the
ingress port, or ingress traffic shaping may be another function that would
need to be controlled at the ingress port.  Therefore, I can see were we
would need to specify the service parameters for each port individually
given the specific service.
For example, say a switch has two UNI ports to a customer.  One of the UNI
ports is a FR port and the other UNI port is an ATM port.  We want to build
a connection between these ports and offer a FR to ATM interworking service.
We want policing on both ingress ports.  A CIR and EIR is specified for the
FR port and a PCR, SCR, MBS is specified for the ATM port.  Instead of being
constrained to just providing ATM parameters or FR parameters and the switch
doing a conversion to the others,  we want to explicitly state these
parameters to the switch for each port.  How could we do this with the
current GSMP framework?  Could this be done by building the connection with
two GSMP connections and specifying FR in one and ATM in another?

Thanks,
Clint

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, January 07, 2000 8:48 AM
To: [email-masked]
Subject: RE: Question on Connection Management Messages

c u
tom

---

From: "tom worster" <[email-masked]>
Date: Sun, 16 Jan 2000 19:04:21 -0500

From: [email-masked] [mailto:[email-masked]]On Behalf Of Clint
Bishard
> two GSMP connections and specifying FR in one and ATM in another?

explicit control of policing parameters is an interesting
question. you mentioned interworking examples which are
valid but, thinking about it, explicit control of policing
parameters is useful in general. it was perhaps a mistake
to assume that the policing parameters to be used for a
connection would be the same as the parameters used for
resource allocation.

i'm not keen on the idea of using two add branch messages
as you suggest. wouldn't it make more sense to allow
policing parameters to be specified in the add branch
message? by the nature of policing, they would apply at
the input.

c u
tom