Subject: [Hipsec] personal HI

From: [email-masked]
Date: Mon, 13 Sep 2004 18:22:01 +0200

Hi there!
I'd like to know some functionality about HIP, if it can provide a personal
key, a sort of HI static that a host can use everywhere in order to be recognized
(even if he has different IP addresses) by a particular a router who gives
him a certain QoS.
I want to use this key to make a corrispondence with a physical person and
to give him a QoS wherever he uses internet. Is it possible using HIP?

Another question: how HIT can generate a collision? Is the generation of
the HI random, so it can happen that a random generated key is already in
use by any other one?

_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Pekka Nikander <[email-masked]>
Date: Mon, 13 Sep 2004 21:41:59 +0300

> (even if he has different IP addresses)

Yes, so far.

> by a particular a router who gives him a certain QoS.

No, that QoS has been beyond the scope of the work.

> to give him a QoS wherever he uses internet. Is it possible using HIP?

Maybe.  Not with the way it has been specified right now, but I don't
see any reason why it couldn't be extended in such a way.

> the HI random, so it can happen that a random generated key is already 

Well, HI generation is random.  The probability that two hosts
generate the same HI is extremely low, though, unless the hosts
happen to use the same faulty random number generator.

However, the probability that two different HIs hash into the same
HIT is very small but not that small that it couldn't happen in real
life.

--Pekka