Subject: RE: [Hipsec] Base HIP: 02 PRE1

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 15 Feb 2005 19:15:40 -0800

> -----Original Message-----
> From: Pekka Nikander [mailto:[email-masked]] 
> Sent: Monday, January 31, 2005 2:35 AM
> To: Henderson, Thomas R
> Cc: Petri Jokela; [email-masked]
> Subject: Re: [Hipsec] Base HIP: 02 PRE1
> 
> >>>> 3.2  Local Scope Identifier (LSI)
> >>
> >> While I think that we are doing good progress with LSIs 
> currently at 
> >> the RG discussion, it might still be a good option to move 
> LSIs into 
> >> a separate draft.  Such a document could discuss LSIs, how 
> they are 
> >> used at the APIs and by applications, and _also_ define a HIP 
> >> protocol extension for informing about used/assigned LSIs.
> >> Opinions?
> >
> > I would favor such a document, scoped as "Using HIP with 
> legacy APIs" 
> > and it could contain more discussion about the LSIs and incorporate 
> > the material in current Appendix A.
> >
> > I'd be willing to take a first cut at it.
> 
> Great!

A draft should be hitting the IETF-announce list soon that is intended
to replace Appendix A.  I would suggest that Appendix A be removed from
the base draft at some point.  However, the new draft does not cover
LSIs in detail, so I will back off (for now) the request to remove
LSIs from the base draft.

Some other comments on the pre2 draft:

I reviewed only looking at the UPDATE portions, since they are
coupled to the mobility draft (which will soon be updated as well).

In Section 8.9, someone (Petri?) raised the issue of whether 
UPDATE retransmissions should be exponentially backed off, like in
TCP and many other protocols.  I agree.. perhaps change 8.9 item
4 to say also "The UPDATE timer MAY be exponentially backed 
off for subsequent retransmissions."

Section 8.10, item 3 should start:
"Additionally (or alternatively),..." since item 2 may not hold.

For now, that is all I have on the UPDATE-- I think that it was a good
first cut at extracting out the NES/ESP material.  

Tom
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Andrew McGregor <[email-masked]>
Date: Wed, 16 Feb 2005 16:24:18 +1300

> off for subsequent retransmissions."

May I recommend SHOULD?

Andrew