Subject: RE: [Hipsec] Base HIP: 02 PRE1

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 15 Feb 2005 19:30:31 -0800

> -----Original Message-----
> From: Andrew McGregor [mailto:[email-masked]] 
> Sent: Tuesday, February 15, 2005 7:24 PM
> To: Henderson, Thomas R
> Cc: Petri Jokela; [email-masked]; Pekka Nikander
> Subject: Re: [Hipsec] Base HIP: 02 PRE1
> 
> 
> On 16/02/2005, at 4:15 PM, Henderson, Thomas R wrote:
> 
> >
> > In Section 8.9, someone (Petri?) raised the issue of whether UPDATE 
> > retransmissions should be exponentially backed off, like in TCP and 
> > many other protocols.  I agree.. perhaps change 8.9 item
> > 4 to say also "The UPDATE timer MAY be exponentially backed off for 
> > subsequent retransmissions."
> >
> 
> May I recommend SHOULD?
> 

Yes, I guess that these are generally SHOULDs instead of MAYs.

Tom
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Kevin Grace <[email-masked]>
Date: Wed, 16 Feb 2005 07:26:39 -0500

Considering that retransmissions could be due to lossy wireless links, 
recommending exponential backoff (a congestion avoidance mechanism) may 
not be always appropriate. "MAY" seems to recognize this possibility 
more than "SHOULD".

Kevin