Subject: RE: sticking with 128-bit HITs (was Re: [Hipsec] SHA1 broken? )

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 22 Mar 2005 16:39:24 -0800

>    0      5    7                                              127
>    +------+----+------------------------------------------------+
>    | Prfx | HA | Hash                                           |
>    +------+----+------------------------------------------------+
> 
>     Prfx (5 bits) - Fixed prefix, TBD.  All other values reserved.
> 
>          Suggested prefix for testing: 01000
> 
>     HA (3 bits) - Hash algorithm.
> 
>        000 - SHA-1  (as currently defined)
>              All other values reserved.
> 
>     Hash (120 bits) - Hash (as specified by HA) of the public key.
> 
> Comments?
> 

Actually, that is mostly consistent with what I was arguing for.  I
appreciate the reasons for not having arbitrary lengths-- my main
motiviation for suggesting non-128 bit HITs was in case we wanted to use
larger structures like i3 triggers (256 bits) as ULIDs-- but I think it
is fine to leave that possibility for future research.

Tom 
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Petri Jokela <[email-masked]>
Date: Thu, 24 Mar 2005 07:35:21 +0200

> is fine to leave that possibility for future research.

If there are no objections, I will put this kind of a HIT in the next 
version of the base draft.

A minor change, proposed earlier by Tom: Shall we replace the name "HIT" 
with "ULID" to make the identifier more generic or stick with the "HIT"? 
I would like to stay with the "HIT" and use the "ULID" in the future 
versions of HIP.

/petri

-- 
Petri Jokela                        Tel:    +358 9 299 2413
Research scientist                  Fax:    +358 9 299 3535
NomadicLab, Ericsson Research       Mobile: +358 44 299 2413
Oy L M Ericsson Ab                  email: [email-masked]
_______________________________________________
Hipsec mailing list
[email-masked]
http://honor.trusecure.com/mailman/listinfo/hipsec

---

From: Julien Laganier <[email-masked]>
Date: Thu, 24 Mar 2005 10:40:06 +0100

(...)

> If there are no objections, I will put this kind of a HIT in the
> next version of the base draft.

I'm fine with the new HIT format.

> A minor change, proposed earlier by Tom: Shall we replace the name
> "HIT" with "ULID" to make the identifier more generic or stick with
> the "HIT"? I would like to stay with the "HIT" and use the "ULID"
> in the future versions of HIP.

Well, my understanding is that although a HIT is a kind of ULID, it 
encompasses a far more broader scope than a typical ULID. For example 
it has a channel binding property (w.r.t. the associated HI), it is 
mostly derived from a flat/unstructured bitstring (at least for Type 
1 HITs, and in the sense that they are not routable).

Hence, I would rather suggest that we add some text explaining that a 
HIT is a kind of ULID, along with some other (rather nice) 
properties.

Thoughts?

--julien