Subject: [Hipsec] Comments on draft-cao-hip-geolocation

From: Cullen Jennings <[email-masked]>
Date: Fri, 14 Nov 2008 16:07:49 -0700

Due to the requirements of managing the privacy of geo and civil  
location information, I think this type of information is much better  
transfered at an application layer than at the transport layer.

Cullen in my individual contributor role

_______________________________________________
Hipsec mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hipsec

---

From: "Hui Deng" <[email-masked]>
Date: Tue, 18 Nov 2008 09:24:30 +0800

Hi, Cullen,

Thanks for your comments,

It could be understand from another direction, if the mobile users use HIP.
Here are some reasons listed below.

-- HIP has the  security mechanisms (i.e. ENCRYPTED)
-- GEOPRIV security framework can be integrated into HIP call flow
-- the geo-location changes of mobile user may not be cared or covered by
many applications.
-- delivering geo-location in HIP can provide the generic mechanism and
interface for the up-layer applications;
-- delivering geo-location in HIP can greatly reduce the redundant work for
up-layer applications.
Basically, operator sometime prefer use infrastructure layer to transmit
this information.

thanks for your understanding.
Best regards,

-Hui Deng
2008/11/15 Cullen Jennings <[email-masked]>

>
> Due to the requirements of managing the privacy of geo and civil location
> information, I think this type of information is much better transfered at
> an application layer than at the transport layer.
>

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Mon, 17 Nov 2008 19:30:12 +0200

I believe that conveying location in HIP is a misguided approach. 
Wrong layer! 

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hui Deng
	Sent: 18 November, 2008 03:25
	To: Cullen Jennings; Hui Deng
	Cc: HIP
	Subject: Re: [Hipsec] Comments on draft-cao-hip-geolocation

	Hi, Cullen,

	It could be understand from another direction, if the mobile users
use HIP. Here are some reasons listed below. 

	-- HIP has the  security mechanisms (i.e. ENCRYPTED) 
	-- GEOPRIV security framework can be integrated into HIP call flow
	-- the geo-location changes of mobile user may not be cared or
covered by many applications.
	-- delivering geo-location in HIP can provide the generic mechanism
and interface for the up-layer applications; 
	-- delivering geo-location in HIP can greatly reduce the redundant
work for up-layer applications.
	
	Basically, operator sometime prefer use infrastructure layer to
transmit this information.

	-Hui Deng

		Due to the requirements of managing the privacy of geo and
civil location information, I think this type of information is much better
transfered at an application layer than at the transport layer.

---

From: "Hui Deng" <[email-masked]>
Date: Tue, 18 Nov 2008 11:37:10 +0800

Hi, Hannes,

Please help to explain any issue with that, other than like this.

Thanks

-Hui

2008/11/18 Hannes Tschofenig <[email-masked]>