Subject: Re: [hiprg] HIPRG charter discussion

From: "Mingwei Xu" <[email-masked]>
Date: Fri, 1 Jul 2011 17:24:12 +0800

Hi, Andrei,

Tsinghua University has great interest on the hierarchical HIT research work. 
We have had some study on HIP and Name Based Socket (NBS). I think HIP
has its advantages in ID/LOC schems. We want to do more work on mobility
and security based on H-HIP. We will attend the HIPRG meetings continually
and contribute to H-HIP drafts development.

Mingwei Xu

From: Andrei Gurtov <gurtov at hiit.fi> 
To: Wendong WANG <wdwang at bupt.edu.cn> 
Cc: hiprg <hiprg at irtf.org> 
Date: Thu, 30 Jun 2011 09:32:24 +0300 
In-reply-to: <201106301130508243153 at bupt.edu.cn> 
References: <201106281659415514469 at bupt.edu.cn> <201106301130508243153 at bupt.edu.cn> 

--------------------------------------------------------------------------------
Can you commit to attend the HIPRG meetings at IETF for one-two years to
 contribute to h-hip draft development or at least provide active
feedback on the mailing list (e.g. at least one email/week)?

Same question also applies to China mobile.

Andrei

Wendong WANG wrote:
> 
>  
> Our team has
> interesting on the hierarchical HIT research work. we have already implemented a demo of ID-Locator mapping services based on HIP. 
> We also hope to do more works on it for the future Internet mobility and security functions.
> Wendong WANG
> Beijing Universty of Posts and Telecommunications (BUPT) 
> 2011-06-30
>  
>  
>  
>> -----éäåä-----
>> åää: Andrei Gurtov [mailto:gurtov at hiit.fi]
>> åéæé: 2011å6æ14æ 17:44
>> æää: Xu Xiaohu
>> æé: 'Henderson, Thomas R'; hiprg at irtf.org; irtf-chair at irsg.org
>> äé: Re: [hiprg] HIPRG charter discussion
>> 
>> 
>> Hei Xiaohu,
>> 
>> That's an interesting topic, but there should be interest of several
>> organizations to discuss and develop it jointly at HIPRG. Can you think
>> of others who would be willing to commit to this topic for a couple
>> years? Maybe China mobile, Tsinghua University?
>> 
>> Andrei
>> 
>> Xu Xiaohu wrote:
>> > Hi Tom and all,
>> >
>> > I propose to consider taking the hierarchical HIT research as a new charter
>> > item. IMHO, there are at least two major benefits of using hierarchical HITs
>> > from the commercial deployment perspectives:
>> >
>> > First, the ID/HIT registration management service and the ID-to-Locator
>> > mapping service corresponding to the hierarchical HITs could be run in a
>> > hierarchical manner. In other words, such global mobility management
>> service
>> > systems could be operated by different countries and different operators
>> > with clear administrative domain boundaries and reasonable business
>> models,
>> > just like the telephone number space in the telephone network and the home
>> > address space in the mobile IP network. In addition, the existing DNS
>> > infrastructure doesn't need to be changed largely. That's to say, HITs of
>> > the HIP hosts could be stored directly as their corresponding AAAA RRs in
>> > the existing DNS infrastructure.
>> >
>> > Second, the usage of hierarchical HITs will ease the transition for HIP. For
>> > instance, legacy IPv6 hosts could access mobile HIP hosts via provider-owned
>> > HIP proxy devices (just as home agents in the mobile IP network) since the
>> > hierarchical HITs could be routable in the Internet. On the contrary,
>> > ORCHIDs are not routable in the Internet since there is no reasonable
>> > business motivation for operators to deploy HIP proxy devices for such flat
>> > identifiers.
>> >
>> > There has been some proposals and presentations discussing about
>> > hierarchical HITs in HIPRG before as follows:
>> > http://tools.ietf.org/html/draft-xu-hip-hierarchical-02
>> > http://tools.ietf.org/html/draft-kuptsov-hhit-02
>> > http://tools.ietf.org/html/draft-xu-rangi-04
>> >
>> > By the way, we have implemented the RANGI
>> > (http://tools.ietf.org/html/draft-xu-rangi-04) prototype which uses a
>> > hierarchical and cryptographic host IDs with delegation-oriented structure.
>> > Hope we could have a chance to show the implementation details and
>> > verification results at the forthcoming IETF meeting in Quebec City.
>> >
>> > Best regards,
>> > Xiaohu
>> >
>> >
>> >> -----éäåä-----
>> >> åää: hiprg-bounces at irtf.org [mailto:hiprg-bounces at irtf.org] äè
>> >> Henderson, Thomas R
>> >> åéæé: 2011å6æ6æ 22:49
>> >> æää: hiprg at irtf.org
>> >> æé: 'irtf-chair at irsg.org'
>> >> äé: [hiprg] HIPRG charter discussion
>> >>
>> >> With the completion of the experiment report (our main RG charter item
>> > since
>> >> the RG's inception), I would like to ask about future directions of the
>> > RG.
>> >> Outside of completing our current RG drafts, we need to try to define some
>> >> new collaborative work items and define what role the RG will play
>> > relative to
>> >> the WG.
>> >>
>> >> These work items should ideally satisfy the following criteria:
>> >> - is the research area clear and relevant for the Internet community and
>> > for
>> >> HIP in particular?  What are the expected outcomes and impact?
>> >> - will the RG foster work that would not be done otherwise?  For instance,
>> >> participation drawn from more than a single institution or country.  Can
>> > we
>> >> try to identify individuals for this anticipated participation?
>> >>
>> >> We can have some discussion of this at the next meeting but I would like
>> > to see
>> >> whether we can start identifying some topics on the list before the
>> > meeting.
>> >> - Tom

---

From: Zhen Cao <[email-masked]>
Date: Sun, 3 Jul 2011 16:04:08 +0800

Hi Andrei,

Attendance is not a problem.  China Mobile has been actively attending
IETF for more than 6 years, 10 people each time.  And we are also
always alive on the mailing list.

Thank you,
Zhen
-China Mobile

On Thu, Jun 30, 2011 at 2:32 PM, Andrei Gurtov <[email-masked]> wrote:
>>> -----邮件原件-----
>>> 发件人: Andrei Gurtov [mailto:[email-masked]]
>>> 发送时间: 2011年6月14日 17:44
>>> 收件人: Xu Xiaohu
>>> 抄送: 'Henderson, Thomas R'; [email-masked]; [email-masked]
>>> 主题: Re: [hiprg] HIPRG charter discussion
>>>
>>>
>>> Hei Xiaohu,
>>>
>>> >> -----邮件原件-----
>>> >> 发件人: [email-masked] [mailto:[email-masked]] 代表
>>> >> Henderson, Thomas R
>>> >> 发送时间: 2011年6月6日 22:49
>>> >> 收件人: [email-masked]
>>> >> 抄送: [email-masked]'
>>> >> 主题: [hiprg] HIPRG charter discussion
>>> >>
>>> >> _______________________________________________
>>> >> hiprg mailing list
>>> >> [email-masked]
>>> >> https://www.irtf.org/mailman/listinfo/hiprg
>>> >
>>> > _______________________________________________
>>> > hiprg mailing list
>>> > [email-masked]
>>> > https://www.irtf.org/mailman/listinfo/hiprg
>>
>>
>> ------------------------------------------------------------------------
>>
>> _______________________________________________
>> hiprg mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/hiprg
>
> _______________________________________________
> hiprg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hiprg
>

-- 
Best regards,
Zhen