Subject: [Hipsec] Orchid generation algorithm - where should it be specified?

From: Tobias Heer <[email-masked]>
Date: Tue, 02 Mar 2010 16:28:26 +0100

Hello Julien and Tom, 

the algorithm for generating the hash part of the HITs in the new ORCHID format and its index should be specified somewhere. The question is where.

Since not all protocols that use ORCHIDS are required to use the same bits/algorithms, it might make sense to specify the actual ID and algorithm in the context of the protocol that uses the ORCHID.
In our case, we could start with a simple allocation for:

ID 0 - SHA2-256 truncated to 96 bits

This could be defined in any HIP document. I think RFC5201-bis would make sense, wouldn't it?
We can later extend it to use some hash chain extension mechanism (e.g., as ID 1) but I think a simple mechanism is a good start.

Any opinions on this?

Tobias

--  

Dipl.-Inform. Tobias Heer, Ph.D. Student
Distributed Systems Group 
RWTH Aachen University, Germany
tel: +49 241 80 207 76
web: http://ds.cs.rwth-aachen.de/members/heer

---

From: "Laganier, Julien" <[email-masked]>
Date: Tue, 2 Mar 2010 08:19:30 -0800

Hello Tobias,

Tobias Heer wrote:
> 
> Hello Julien and Tom,
> 
> the algorithm for generating the hash part of the HITs in the new
> ORCHID format and its index should be specified somewhere. The question
> is where.
> 
> Since not all protocols that use ORCHIDS are required to use the same
> bits/algorithms, it might make sense to specify the actual ID and
> algorithm in the context of the protocol that uses the ORCHID.

I agree.

> We can later extend it to use some hash chain extension mechanism (e.g.,
> as ID 1) but I think a simple mechanism is a good start.
> 
> Any opinions on this?

I agree that 5201bis is the logical place to do that.

--julien

---

From: "Henderson, Thomas R" <[email-masked]>
Date: Tue, 2 Mar 2010 08:44:13 -0800

> -----Original Message-----
> From: Laganier, Julien [mailto:[email-masked]]
> Sent: Tuesday, March 02, 2010 8:20 AM
> To: Tobias Heer; Henderson, Thomas R
> Cc: [email-masked] WG
> Subject: RE: Orchid generation algorithm - where should it be
> specified?
>
> Hello Tobias,
>
> Tobias Heer wrote:
> >
> > Hello Julien and Tom,
> >

+1

Tom