Subject: [homenet] Fwd: I-D Action: draft-haddad-homenet-gateway-visibility-00.txt

From: Wassim Haddad <[email-masked]>
Date: Wed, 26 Oct 2011 12:25:41 -0400

Dear all,

A New Internet-Draft is available from the on-line Internet-Drafts directories.

Title: Ensuring Home Network Visibility to Home Gateway

This memo describes a mechanism designed to increase the home gateway visibility on the home network that it is serving.  This includes knowledge of all IPv6 addresses configured using prefixes assigned by
the home gateway and advertised by router(s) attached to it.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-haddad-homenet-gateway-visibility-00.txt

Your comments are appreciated!

Regards,

Wassim H.

---

From: David R Oran <[email-masked]>
Date: Wed, 26 Oct 2011 12:42:03 -0400

> Your comments are appreciated!
The draft says "In such scenario, it can be useful for the HGW(s)
   to keep track of all IPv6 addresses configured by different types of
   end devices that get attached to the home network via router(s)
   connected to the HGW(s)."

but give zero justification for WHY it might be useful. I can't think of any reason at all, but I assume you can but just thought it too obvious to write down.

Could you educate me?

Thanks, 
DaveO.
 
> 
> Regards,
> 
> Wassim H.
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

---

From: Mark Townsley <[email-masked]>
Date: Fri, 28 Oct 2011 14:55:13 +0200

> but give zero justification for WHY it might be useful. I can't think of any reason at all, but I assume you can but just thought it too obvious to write down.

Ray and I would like to know as well, in particular we're trying to see where this fits into the homenet architecture (considering the 5 areas we are chartered to target as well). If nothing else, we need to know this in order to fit it into the Taipei homenet agenda assuming you want some time to discuss it there.

Thanks,

- Ray & Mark

---

From: james woodyatt <[email-masked]>
Date: Fri, 28 Oct 2011 16:02:56 -0700

> Ray and I would like to know as well, in particular we're trying to see where this fits into the homenet architecture (considering the 5 areas we are chartered to target as well). If nothing else,…

Looks to me like somebody really wants the functionality of I-D.woodyatt-ald, only just for IP addresses and not for protocol and port numbers as well.  If you gonna hoover up everything, why not go big?

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: Wassim Haddad <[email-masked]>
Date: Mon, 31 Oct 2011 12:57:51 -0700

Hi,

> Ray and I would like to know as well, in particular we're trying to see where this fits into the homenet architecture (considering the 5 areas we are chartered to target as well). If nothing else,…

=> The reason is that if we consider that in-home services are getting increasingly complex then it makes sense to aggregate control as much as possible in one device (i.e., the home GW) in order to make average user's life simpler and easier. IMHO, having one router at home is already a burden to the "average user" in terms of grappling with all configurations so one could justifyably argue that the situation will get much worse with multiple ones!
Furthermore, the traditional assumption for service controllers like UPnP, is that the network is bridged while homenet WG seems to be leaning towards a  routed internal network (note also that this gets even more complicated if we add that a DLNA certified device does not mean at all that all features are implemented). 
Consequently, in order to keep the home network control simple, a single point of service control is helpful to both the home user and the network service provider.

As an example, I have a medical device at home connected to a router that is two hops away from the home GW. The medical device requires special treatment for both downstream and upstream traffic. IMHO, it would be very helpful if the service control point (i.e., home GW) can discover the device and engage directly with in suitable exchanges to determine what it needs to ensure it works in the most optimal way, then make necessary configurations accordingly. 

Regards,

Wassim H.

---

From: james woodyatt <[email-masked]>
Date: Mon, 31 Oct 2011 13:48:56 -0700

everyone--

I am now thoroughly confused.  I completely fail to understand how the proposal in section 4 follows from the motivation described in section 3.