Subject: [homenet] a few drafts...

From: Jari Arkko <[email-masked]>
Date: Tue, 25 Oct 2011 16:03:48 +0200

Here's a couple of drafts inspired by discussions from the interim meeting:

http://tools.ietf.org/html/draft-acee-ospf-ospfv3-autoconfig-00.txt

    OSPFv3 is a candidate for deployments in environments where auto-
    configuration is a requirement.  One such environment is the IPv6
    home network where users expect to simply plug in a router and have
    it automatically use OSPFv3 for intra-domain routing.  This document
    describes the necessary mechanisms for OSPFv3 to be self-configuring.

http://tools.ietf.org/html/draft-arkko-homenet-prefix-assignment-00.txt

    This memo describes a prefix assignment mechanism for home networks.
    It is expected that home gateway routers are assigned an IPv6 prefix
    through DHCPv6 Prefix Delegation (PD).  This prefix needs to be
    divided among the multiple subnets in a home network.  This memo
    describes a mechanism for such division via OSPFv3.  This is an
    alternative design to using DHCPv6 PD also for the prefix assignment.
    The memo is input to the working group so that it can make a decision
    on which type of design to pursue.  It is expected that a routing-
    protocol based assignment uses a minimal amount of prefixes.

Comments appreciated!

Jari

---

From: Laurent Toutain <[email-masked]>
Date: Wed, 26 Oct 2011 17:41:38 +0200

Hi Jari,

I'm very please to see that this idea is coming back, we proposed some
similar ideas several years ago in the late zerouter WG.
ftp://ftp.utl.pt/rfc/ftp.isi.edu/internet-drafts/draft-chelius-router-autoconf-00.txt.
We also published some papers to study performances for SID allocation (
http://conferences.sigcomm.org/sigcomm/2007/ipv6/1569041157.pdf). The good
news is if you have a /60 and need to allocate 15 prefixes, it can be done
in 3 rounds.

Laurent

On Tue, Oct 25, 2011 at 16:03, Jari Arkko <[email-masked]> wrote:

> http://tools.ietf.org/html/**draft-acee-ospf-ospfv3-**autoconfig-00.txt<http://tools.ietf.org/html/draft-acee-ospf-ospfv3-autoconfig-00.txt>
>
> http://tools.ietf.org/html/**draft-arkko-homenet-prefix-**
> assignment-00.txt<http://tools.ietf.org/html/draft-arkko-homenet-prefix-assignment-00.txt>
>
> ______________________________**_________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/homenet<https://www.ietf.org/mailman/listinfo/homenet>
>

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: Jari Arkko <[email-masked]>
Date: Wed, 26 Oct 2011 20:19:44 +0300

Thanks for these pointers. We need to take a look at your analysis. It is great to have already some understanding of how well these types of mechanisms work!

Jari

On 26.10.2011 18:41, Laurent Toutain wrote:
> Hi Jari,
>
> I'm very please to see that this idea is coming back, we proposed some similar ideas several years ago in the late zerouter WG.
> ftp://ftp.utl.pt/rfc/ftp.isi.edu/internet-drafts/draft-chelius-router-autoconf-00.txt. We also published some papers to study performances for SID allocation (http://conferences.sigcomm.org/sigcomm/2007/ipv6/1569041157.pdf). The good news is if you have a /60 and need to allocate 15 prefixes, it can be done in 3 rounds.
>
> Laurent
>
> On Tue, Oct 25, 2011 at 16:03, Jari Arkko <[email-masked] <mailto:[email-masked]>> wrote:
>
>     _______________________________________________
>     homenet mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/homenet
>
>
>
>
> -- 
> Laurent Toutain
> | Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit :
> | Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  | http://class.touta.in