Subject: Re: [homenet] draft-ietf-homenet-arch-04

From: RJ Atkinson <[email-masked]>
Date: Wed, 26 Sep 2012 10:23:51 -0400

On Saturday, 22 September 2012, Joel M Halpern wrote:
> The argument on /64 as the longest prefix is not that it is
> magically unnatural.  Rather, it is that there are a number of
> current and evolving protocols that depend upon that /64.
> The obvious example is that SLAAC does not work if subnets
> are longer than /64.
>  
> The rules in this regard are written into approved RFCs.
> If homenet wants to change that, it really needs to go to 6man
> with a strong case. (for point-to-point inter-router links
> this was recently relaxed.  
>  
> At the same time, andy operator who insists on giving homes
> a /64 is being inappropriately restrictive.  Homenet should
> say that, rather than trying to change the IPv6 architecture.
>  
> Yours,
> Joel

+1 to all of the above.

Please particularly note that SLAAC is especially likely 
to be deployed in home environments, much more likely than
any other alternative (e.g. DHCPv6).  Several widely deployed
consumer electronic devices ONLY support IPv6 via SLAAC,
and won't work with DHCPv6 (at present).  So breaking SLAAC 
is VERY bad operationally in a home deployment at present,
and for the foreseeable future.

Yours,

Ran Atkinson

---

From: Curtis Villamizar <[email-masked]>
Date: Sun, 30 Sep 2012 19:33:24 -0400

> and for the foreseeable future.

Ran,

Breaking SLAAC is bad.

Consumer oriented providers handing out /64s to homenets is also bad.

But if a homenet does get nothing more than a /64 and multiple subnets
are needed, then SLAAC gets broken.

Curtis

PS- Please reply to this part off list: What "widely deployed consumer
    electronic devices" do you have in mind?  Any chance of firmware
    upgrade or is the firmware too thoroughly baked in?  Note that
    just about anything running android can be upgraded in the field
    and a DHCPv6 client might only need to be an app, not an upgrade.