Subject: [homenet] I-D Action: draft-ietf-homenet-prefix-assignment-02.txt

From: [email-masked]
Date: Mon, 05 Jan 2015 09:25:48 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Home Networking Working Group of the IETF.

        Title           : Distributed Prefix Assignment Algorithm
        Authors         : Pierre Pfister
                          Benjamin Paterson
                          Jari Arkko
	Filename        : draft-ietf-homenet-prefix-assignment-02.txt
	Pages           : 18
	Date            : 2015-01-05

Abstract:
   This document specifies a distributed algorithm for automatic prefix
   assignment.  Given a set of delegated prefixes, it ensures at most
   one prefix is assigned from each delegated prefix to each link.
   Nodes may assign available prefixes to the links they are directly
   connected to, or for other private purposes.  The algorithm
   eventually converges and ensures that all assigned prefixes do not
   overlap.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-homenet-prefix-assignment/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-homenet-prefix-assignment-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-homenet-prefix-assignment-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Pierre Pfister <[email-masked]>
Date: Tue, 6 Jan 2015 09:06:32 +0100

Hello group,

Following the publication of DNCP (part of HNCP + PA drafts split), here is a rewritten version of the prefix assignment algorithm.
The document has been entirely refactored for the sake of clarity and genericity. But the algorithm is similar to what was there since more than one year now.

Although the previous version of the document was specifying both prefix assignment and hosts and routers configuration, this new version only focuses on the former. The later will be included in hncp-03.

As most discussions about the previous versions were focusing on parts of the draft which will be moved to hncp-03, and because the algorithm has been there for quite a while now, we believe this document could reach consensus fairly quickly. Which is why we would like to have a few reviews so we can move forward on this document, and focus on HNCP and RP selection.

- Pierre

> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet