Subject: [homenet] How is prefix delegation handled on OpenWRT/CeroWRT in a homenet configuration?

From: Ted Lemon <[email-masked]>
Date: Wed, 8 Apr 2015 09:48:56 -0400

Sorry to delve into an operational question when we're having so much fun discussing layer 9 stuff, but are any of the OpenWRT folks around who could tell me what OpenWRT is doing to get its delegation from the ISP?   ISC DHCP?   dhcpcd?  dnsmasq?

I ask because I want to replicate a homenet environment at home, but my edge router is a server running Ubuntu, and I don't want to put a Wifi router between it and the internet.   Clues appreciated.

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 8 Apr 2015 22:54:56 +0900

On Wed, Apr 8, 2015 at 10:48 PM, Ted Lemon <[email-masked]> wrote:

> Sorry to delve into an operational question when we're having so much fun
> discussing layer 9 stuff, but are any of the OpenWRT folks around who could
> tell me what OpenWRT is doing to get its delegation from the ISP?   ISC
> DHCP?   dhcpcd?  dnsmasq?
>

https://github.com/sbyx/odhcpd

I ask because I want to replicate a homenet environment at home, but my
> edge router is a server running Ubuntu, and I don't want to put a Wifi
> router between it and the internet.   Clues appreciated.
>

Run a DHCPv6 server on the ubuntu box?

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 8 Apr 2015 22:57:00 +0900

> https://github.com/sbyx/odhcpd

Actually, that's the server. I think the client is
https://github.com/sbyx/odhcp6c .

---

From: Dave Taht <[email-masked]>
Date: Wed, 8 Apr 2015 08:36:43 -0700

I note that I was unsuccessful in getting PD to work properly on
ubuntu. dhclient would assign /68s, dibbler (as currently released)
would crash, and
dibbler rc2 also had issues, all this compounded by switching between
these daemons - causing the dhcp server on the cable modem I was using
- to reject more PD requests and then run wild sending not in the spec
error messages - which then drove the dhcp clients wild...

https://github.com/sbyx/odhcp6c/issues/27

When you get it working let us know. That was a little too much
dogfood in that weekend for me.

On Wed, Apr 8, 2015 at 6:48 AM, Ted Lemon <[email-masked]> wrote:
> _______________________________________________
> homenet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homenet

-- 
Dave Täht
We CAN make better hardware, ourselves, beat bufferbloat, and take
back control of the edge of the internet! If we work together, on
making it:

https://www.kickstarter.com/projects/onetswitch/onetswitch-open-source-hardware-for-networking

---

From: Ted Lemon <[email-masked]>
Date: Fri, 10 Apr 2015 07:46:06 -0400

Thanks, Ray!   I'm actually trying to get my ubuntu machine to be the homenet edge router rather than simulating an ISP edge router, but in fact in the process of doing this I've concluded that for testing purposes a setup like the one you've described would be very useful!   :)