Subject: [homenet] Fwd: ANNOUNCE: babeld-1.6.0

From: Juliusz Chroboczek <[email-masked]>
Date: Tue, 14 Apr 2015 14:21:57 +0200

Subject: ANNOUNCE: babeld-1.6.0
From: Juliusz Chroboczek <[email-masked]>
To: [email-masked]
Date: Tue, 14 Apr 2015 14:21:30 +0200

Dear all,

I am happy to announce that babeld-1.6.0 is available from

  http://www.pps.univ-paris-diderot.fr/~jch/software/files/babeld-1.6.0.tar.gz
  http://www.pps.univ-paris-diderot.fr/~jch/software/files/babeld-1.6.0.tar.gz.asc

For more information about babeld and the Babel routing protocol, please see

  http://www.pps.univ-paris-diderot.fr/~jch/software/babel/

The main news in this version is that source-specific routing is part of
the stock babeld daemon.  This is a large change, and is due to Matthieu
Boutier.  For more information about source-specific routing, please see

  Matthieu Boutier and Juliusz Chroboczek.
  Source-specific routing.
  To appear in Proc. IFIP Networking 2015.
  http://arxiv.org/pdf/1403.0445

Enjoy,

-- Juliusz Chroboczek

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 15 Apr 2015 16:07:18 +0200 (CEST)

On Tue, 14 Apr 2015, Juliusz Chroboczek wrote:

Hi,

could you please elaborate on one sentence in the abstract from 
http://arxiv.org/pdf/1403.0445.pdf:

"to our knowledge, the first complete implementation of a sourcespecific 
dynamic routing protocol —"

What do you mean by "complete"? What is it that you have done, that wasn't 
done in the OSPF and ISIS implementations that have been shown so far in 
the homenet context over the past few years?

"While we enjoy working with distance-vector protocols, much of the 
networking community appears to have converged on using the OSPF protocol 
for internal routing."

Coming from the ISP side, I also question OSPF being mentioned as IGP 
while totally excluding ISIS. I dare to say that a majority of the larger 
ISP networks of today are running ISIS as their IGP.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 15 Apr 2015 23:09:18 +0900

> ISP networks of today are running ISIS as their IGP.

What does that have to do with it? Unless your statement is "because big
backbones with big iron hardware and big support teams are running ISIS,
that means home networks with constrained hardware and no support should
run ISIS as well"...

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 15 Apr 2015 16:13:58 +0200 (CEST)

> that means home networks with constrained hardware and no support should 

This was outside the homenet context. Julius et al are making statements 
in that paper that I don't agree with and I'm making my objection known.

---

From: Ray Bellis <[email-masked]>
Date: Wed, 15 Apr 2015 14:18:07 +0000

> On 15 Apr 2015, at 15:13, Mikael Abrahamsson <[email-masked]> wrote:
> 
> This was outside the homenet context.

Let's please keep this outside the Homenet list, then.

thanks,

Ray

---

From: Juliusz Chroboczek <[email-masked]>
Date: Thu, 16 Apr 2015 13:39:53 +0200

> could you please elaborate on one sentence in the abstract from

Answered by private mail, as requested by Ray.

-- Juliusz