Subject: [homenet] Trouble with hnet-full on WiTi Router from mqmaker

From: Rich Brown <[email-masked]>
Date: Thu, 28 Jul 2016 19:32:57 -0400

I have had half-success (that is, one out of two routers worked) installing hnet-full.
 
1) I have a Netgear WNDR3800 where the instructions I posted at https://gist.github.com/richb-hanover/ec88b851c4da074e48003e6fe9276901 seem to work fine. 

2) I have had trouble with a mqmaker.com WiTi router. Steps 1-9 (above) work fine. I can configure the two radios and the WAN port to hnet, leaving the LAN port on 192.168.1.1, and the router works as expected. Both W24 and W5 give out DHCP addresses, and E0 acquires a DHCP address from the upstream (Ethernet) router.

When I convert the lan port to hnet as described in Step 10, everything comes to tears. After the reboot, the LAN ports do not give DHCP addresses, and I cannot connect to either wireless interface...

What other information could I provide? Would it help to have a copy of /etc for the afflicted router? I also have a serial interface, so could send along the boot logs...

Many thanks,

Rich

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 29 Jul 2016 12:42:53 +0200

> When I convert the lan port to hnet as described in Step 10, everything
> comes to tears. After the reboot, the LAN ports do not give DHCP
> addresses, and I cannot connect to either wireless interface...

I assume you have no serial console on this board?

What I would suggest would be to convert the WAN and WLAN interfaces to
Homenet, but keep the LAN statically configured.  Then, log in on the LAN
interface twice, and in one window say

  logread -f

and in the other say

  /etc/init.d/networking restart

-- Juliusz

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 29 Jul 2016 12:54:22 +0200

> Homenet, but keep the LAN statically configured.

Er, sorry.  I missed the bit where you say that things only go wrong when
you convert the LAN interface to hnet.

I'm afraid you're going to have to log in through the WAN interface, which
requires some minor firewall tweaks.

-- Juliusz

---

From: Rich Brown <[email-masked]>
Date: Fri, 29 Jul 2016 10:49:13 -0400

Hi Juliusz,

Thanks again for your insights.

> On Jul 29, 2016, at 7:34 AM, Juliusz Chroboczek <[email-masked]> wrote:
> 
>> WiTi router.
> 
> That looks like a nice board.  Please let me know how well it goes.

I got it at a good price through kickstarter/indiegogo/can't remember. But I wouldn't recommend it (they're undercapitalized, poor English skills, not particularly forthcoming with technical info). Virtually all their support comes from their community forum, but they continue to say good things about it.

>> comes to tears.
> The Ethernets are connected in strange ways.  Are you sure you got your
> ifnames right?

I thought so, but I'm a real beginner here. What's the best way to get info to you? I thought of:

- sending a zip of /etc/
- sending the console log (I do have a serial interface)
- Anything else?
> -- Juliusz

Thanks again.

Rich

---

From: Rich Brown <[email-masked]>
Date: Sat, 30 Jul 2016 15:49:59 -0400

It's still not working, but I have a new clue... Here's the experimental setup:

- Install LEDE r1141 (28Jul2016 version) with current hnet-full 2016-06-28-606dye9046..e-1

- Config hnet on W24, W5 & E0 (but not LAN Ethernet) as described in Steps 1-9 of the Guide https://gist.github.com/richb-hanover/ec88b851c4da074e48003e6fe9276901

- Everything looks fine. I can connect to W24 & W5, ping external addresses, connect to https://lede-witi.home and ssh [email-masked]

Then do step 10, disabling 'lan' interface and creating E1. The pastebin at http://pastebin.com/Aj6BGf79 shows the state of the config files before issuing /etc/init.d/network restart

I have a serial console attached, and it shows the lines at the end of this message. 

After restarting the network, neither the LAN ethernet, nor the W24/W5 ports work (no DHCP on E1, my Macbook refuses to connect to either W24 or W5...)

I suspect it has something to do with the "disabling br-lan" messages, but I don't know where that config comes from. (I searched all files in /etc, and there is no occurrence of 'br-lan')

What other information could I provide? Thanks.

Rich

--- Serial console after /etc/init.d/network restart shows:

[  995.350000] br-lan: port 1(eth0.1) entered disabled state
[  995.380000] device eth0.1 left promiscuous mode
[  995.390000] br-lan: port 1(eth0.1) entered disabled state
[  995.420000] device eth0 left promiscuous mode
[  995.440000] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[  998.110000] device eth0 entered promiscuous mode
[  999.340000] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
[  999.660000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 1000.070000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1000.740000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

---

From: Juliusz Chroboczek <[email-masked]>
Date: Sat, 30 Jul 2016 23:45:12 +0200

> I suspect it has something to do with the "disabling br-lan" messages,
> but I don't know where that config comes from.

No, that's just that as you change the configuration, the software bridge
is being removed.  What you're seeing are STP state transitions.

Can you please paste a full boot log with the new configuration?

-- Juliusz

---

From: Rich Brown <[email-masked]>
Date: Sun, 31 Jul 2016 15:49:10 -0400

> On Jul 30, 2016, at 5:45 PM, Juliusz Chroboczek <[email-masked]> wrote:
> 

I added it to: http://pastebin.com/Aj6BGf79

Thanks.

Rich