Subject: [homenet] Tcpdump support for HNCP

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 29 Jul 2016 12:37:13 +0200

Hi,

A cleaned-up version of Antonin's and Jean-Raphaël's code for tcpdump is
available in the hncp-20160728 branch of their github repository:

  https://github.com/MisterDA/tcpdump/tree/hncp-20160728

  git clone -b hncp-20160728 https://github.com/MisterDA/tcpdump

The pull request is here:

  https://github.com/the-tcpdump-group/tcpdump/pull/534

If you need to get in touch with them, they're in CC of this mail.

-- Juliusz

---

From: Michael Richardson <[email-masked]>
Date: Fri, 29 Jul 2016 10:38:42 -0400

> https://github.com/the-tcpdump-group/tcpdump/pull/534

<tcpdump.org hat>
Thank you... the 4.8.0-rc2 will go out on Monday with it.
There are some wpcap.dll issues that we are also waiting on.
</tcpdump.org hat>

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 29 Jul 2016 17:09:46 +0200

> Thank you... the 4.8.0-rc2 will go out on Monday with it.

Jean-Raphaël is in my office, he's telling me "I thought upstreaming was
supposed to be difficult" ;-)

-- Juliusz

---

From: Michael Richardson <[email-masked]>
Date: Fri, 29 Jul 2016 12:41:10 -0400

> supposed to be difficult" ;-)

You guys did your homework, posted your code with (unit) test cases, and so
all the other tests passed.  (Thanks travis-ci.org!)

More packet captures from homenet systems would naturally be very welcome...

---

From: Juliusz Chroboczek <[email-masked]>
Date: Fri, 29 Jul 2016 21:55:31 +0200

> all the other tests passed.

Thanks for the kind words.  And thanks to you for the speedy pull, guys
can go for holidays with clear confirmation that their internship was
a success.

-- Juliusz