Subject: Re: [homenet] About Ted's naming architecture presentation and document

From: "Ray Hunter (v6ops)" <[email-masked]>
Date: Thu, 01 Dec 2016 16:52:22 +0100

james woodyatt wrote:
> On Nov 16, 2016, at 17:31, Michael Richardson <[email-masked] 
> <mailto:[email-masked]>> wrote:
>>
>> But, do you agree that publishing your home lighting controller to 
>> the DNS is
>> how you manage to control your lights from your phone when you are out of
>> wifi distance, as you roam to 3G. (I switch to 3G when I get to the 
>> front of
>> my rather modest driveway, as the AP is in the back of the basement)?
>
> If anybody is currently shipping, or has announced plans to ship, any 
> kind of home automation device that does this, please speak up on the 
> mailing list. I’d like to calibrate my perhaps mistaken apprehension 
> that nobody would seriously consider doing this. Everyone I know in 
> this field plans to do this by providing a single public rendezvous 
> point with high availability servers that communicate in turn to home 
> automation controllers acting as private clients.
>
>
> --james woodyatt <[email-masked] <mailto:[email-masked]>>
>
>
RFC3724.

 >  End user choice and empowerment, integrity of service, support for 
trust, and "good network citizen behavior" are all properties that have 
developed as a consequence of the end-to-end principle.

Rendezvous points are themselves an attack vector/ anti-privacy snooping 
vector/ commercial lock-in/ convenience, depending on your point of view.

So please let's empower the end user to either "opt in" or "opt out".

-- 
regards,
RayH
<https://www.postbox-inc.com/?utm_source=email&utm_medium=siglink&utm_campaign=reach>

---

From: james woodyatt <[email-masked]>
Date: Thu, 1 Dec 2016 12:45:51 -0800

On Dec 1, 2016, at 07:52, Ray Hunter (v6ops) <[email-masked]> wrote:
> james woodyatt wrote:
>> 
>> If anybody is currently shipping, or has announced plans to ship, any kind of home automation device that does this, please speak up on the mailing list. I’d like to calibrate my perhaps mistaken apprehension that nobody would seriously consider doing this. Everyone I know in this field plans to do this by providing a single public rendezvous point with high availability servers that communicate in turn to home automation controllers acting as private clients.
> 
> RFC3724.
> 
> >  End user choice and empowerment, integrity of service, support for trust, and "good network citizen behavior" are all properties that have developed as a consequence of the end-to-end principle. 

Funny. I would have cherry-picked *this* quote from that RFC:

>> These conflicts [between service providers, end users, etc.] will inevitably be reflected in the Internet architecture going forward.  Some of these conflicts are impossible to resolve on a technical level, and would not even be desirable, because they involve social and legal choices that the IETF is not empowered to make […]

> Rendezvous points are themselves an attack vector/ anti-privacy snooping vector/ commercial lock-in/ convenience, depending on your point of view.

Indeed. “Depending on your point of view.” Hence, the quote I picked above as a counterpoint.

> So please let's empower the end user to either "opt in" or "opt out”.

>  <https://www.postbox-inc.com/?utm_source=email&utm_medium=siglink&utm_campaign=reach>
Already done and done. End users are free to “opt out” by not using the products and services that require the use of rendezvous points to facilitate end-to-end communication between home networks and roaming mobile handsets. Alternatively, they may build and run their own bespoke gear that works differently according to whatever optional security method they are managing themselves at the border of their home network. The default we are recommending in the HNCP draft is to turn on the simple security firewall, and therefore require the rendezvous point. Can you blame industry for expecting that most end users will never feel moved to opt out of this convention?