Subject: Re: [homenet] A TOFU approach to naming things in the homenet (with code!)

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Sun, 11 Jun 2017 19:09:19 +0200

Toke Høiland-Jørgensen <[email-masked]> writes:

> Ted Lemon <[email-masked]> writes:
>
>> On Apr 17, 2017, at 3:16 PM, Toke Høiland-Jørgensen <[email-masked]> wrote:
>>
>>  Hmm, turns out RFC6763 already defines a way to do this (in section 11).
>>  r._dns-sd._udp.<domain>. where <domain> is either the in-addr.arpa zone
>>  derived from the network address of a host address, or "local.". I guess
>>  I'll teach the nsregc client to resolve that...
>>
>> Cool!   Sorry I didn't mention it earlier—haven't had a chance to try
>> the code yet. 
>
> No worries. I added auto-discovery to the client, and improved
> configuration for both client and server (and the client will now run
> without any configuration with sensible defaults). The server also
> supports synthesising reverse PTR records now.
>
> Only thing missing now for my own use case is the ability to add local
> records to Unbound (for having a separate internal view while keeping
> private addresses out of the global DNS).

I've added the missing Unbound support, and also wrote a blog post about
nsregd, and how to use ohybridproxy to enable DNS-SD on a routed network
using OpenWrt:

https://blog.tohojo.dk/2017/06/naming-and-service-discovery-on-a-routed-ipv6-network.html

I'm happy to present some of this in Prague if you think that would be
useful :)

-Toke

---

From: Ted Lemon <[email-masked]>
Date: Sun, 11 Jun 2017 13:25:07 -0400

I think it would be worth presenting your work, yes.   In addition to this, I've been working with Stuart Cheshire on an enhancement to the hybrid proxy that I expect to present in Prague.   It would be interesting to tie your work in with that.   I'm going to write up some initial documents that talk about this in the next couple of days.   The work we are doing will happen in dnssd, not homenet, but it's directly related to the work I've been doing on the homenet naming architecture, and will be reflected in the next version of that document.

I don't know if your work is more something that should be presented in homenet, or should be presented in dnssd, or some combination.   We should talk about this once the documents are out.

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Fri, 16 Jun 2017 00:01:34 +0200

Ted Lemon <[email-masked]> writes:

> I think it would be worth presenting your work, yes. In addition to this, I've
> been working with Stuart Cheshire on an enhancement to the hybrid proxy that I
> expect to present in Prague. It would be interesting to tie your work in with
> that. I'm going to write up some initial documents that talk about this in the
> next couple of days. The work we are doing will happen in dnssd, not homenet,
> but it's directly related to the work I've been doing on the homenet naming
> architecture, and will be reflected in the next version of that document.
>
> I don't know if your work is more something that should be presented in homenet,
> or should be presented in dnssd, or some combination. We should talk about this
> once the documents are out.

ACK. Let me know when that is :)

-Toke

---

From: Toke Høiland-Jørgensen <[email-masked]>
Date: Fri, 30 Jun 2017 11:14:59 +0200

> ACK. Let me know when that is :)

Ping?

-Toke

---

From: Tim Chown <[email-masked]>
Date: Fri, 30 Jun 2017 09:44:25 +0000

> On 30 Jun 2017, at 10:14, Toke Høiland-Jørgensen <[email-masked]> wrote:
> 

The deadline for draft updates or new drafts is 3rd July.

tim

---

From: Ted Lemon <[email-masked]>
Date: Fri, 30 Jun 2017 08:38:34 -0400

Sorry, it’s taking longer than I’d hoped. Will be done before deadline, probably later today. 

> On Jun 30, 2017, at 5:14 AM, Toke Høiland-Jørgensen <[email-masked]> wrote:
> 
> Ping?