Subject: [hrpc] Turkey and draft-tenoever-hrpc-research-05

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 18 Sep 2016 18:42:19 +0200

The current text says (section 5.2.4.2) that DPI is used to modify
DNS answers in Turkey. There is no evidence of that (specially in the
mentioned article), quite the contrary: during recent censorship
events in Turkey, switching to an alternative resolver worked, proving
there was no DPI (another trick used was route hijacking, see
presentation at RIPE
<https://ripe68.ripe.net/presentations/158-bortzmeyer-google-dns-turkey.pdf>)

I suggest to rewrite as
<https://github.com/bortzmeyer/IRTF-HRPC/commit/1edbf4e803841dd63340bcc8b6cf0d46d9bf3428>:

> all DNS protocol messages are inspected by the network, and
> objectionable content is distorted, as in China. [China replacing Turkey]

See
<https://mailarchive.ietf.org/arch/msg/hrpc/rBvp0nBo3EfVT-gaMJiKLU3TkEg> and
<https://mailarchive.ietf.org/arch/msg/hrpc/4B6TdRYBtdgRo_2euBsDf8ck5tI> for
previous remarks about Turkey.

---

From: Niels ten Oever <[email-masked]>
Date: Mon, 19 Sep 2016 17:08:55 +1200

Agreed, accepted with minor grammar changes.

Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                   678B 08B5 A0F2 636D 68E9

On 09/19/2016 04:42 AM, Stephane Bortzmeyer wrote:
> _______________________________________________
> hrpc mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/hrpc
>