Subject: [hrpc] Lerna, and the use of software for good and bad

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 31 Aug 2018 15:45:19 +0200

This is about software development, but it can probably be applied to
protocols. Is it possible / sensible to ban bad uses of a technology?

A good summary of the Lerna case
<https://motherboard.vice.com/en_us/article/pawnwv/open-source-devs-reverse-decision-to-block-ice-contractors-from-using-software>

The famous pull request <https://github.com/lerna/lerna/pull/1616>

Apologies and explanations from the project
<https://github.com/lerna/lerna/pull/1633> (note how the Terms of Use,
called "Code of Conduct", were used to silence the guy who was at the
origin of the crisis)

An opinion <https://sfconservancy.org/blog/2018/aug/30/big-tent/> (I'm
looking for a good text supporting the opposite opinion. Any reference?)

Next step, a word in RFCs "This protocol mus not be used by ISIS /
ICE / PLA"? Remember the JSON case <https://www.json.org/license.html> (but
it was much less specific that the very short-lived Lerna license.)

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 31 Aug 2018 18:39:44 +0000 (UTC)

Stephane,

> protocols. Is it possible / sensible to ban bad uses of a technology? 

I have my own opinions on this (as you might imagine!). 

But, I will not be expressing them as I feel that this email list 
is not a safe place to express differences of opinion or to have an 
intellectual discussion. 

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

________________________________
From: Stephane Bortzmeyer <[email-masked]>
To: [email-masked] 
Sent: Friday, August 31, 2018 6:45 AM
Subject: [hrpc] Lerna, and the use of software for good and bad

_______________________________________________
hrpc mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/hrpc

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 31 Aug 2018 18:50:43 +0000

We don't agree on many things, but I very sad to hear you say that.

I suggest you contact the ombudsteam.

---

From: Nalini J Elkins <[email-masked]>
Date: Fri, 31 Aug 2018 19:05:45 +0000 (UTC)

> We don't agree on many things, but I very sad to hear you say that. 

Thank you for saying that, Rich.   Indeed we do not agree on many things. 

But one of the things that I have always prized about the IETF is that, 
unlike other areas of my life, here, I did not constantly have to monitor 
my words.   And, that fervent intellectual discussion and disagreement 
sometimes leads to really good engineering solutions. 

Thanks,

Nalini Elkins
CEO and Founder
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360