Subject: [http-auth] HOBA Client and Server(RFC 7486)

From: Andrew Mcconachie <[email-masked]>
Date: Tue, 17 May 2016 20:55:32 +0000

I’ve written a HOBA client and server. Both are licensed under GPLv3.

The client is a Firefox plugin that can be downloaded here:
https://addons.mozilla.org/en-US/firefox/addon/hoba/

The server lives here currently:
https://synonomic.com/hoba

Code for both is on Github:
https://github.com/smutt/HOBA
https://github.com/smutt/HOBA-server

Neither client nor server are going to win any awards for UI design :) They’re both rather ugly, but they work.

I did some things slightly differently than RFC 7486. The biggest difference is that I used JWK for public key format instead of PEM. There are a few other little things as well.

This was a personal project unrelated to my day job.

--Andrew

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 17 May 2016 22:11:31 +0100

Excellent! (As I said earlier when Andrew mailed me off list:-)

I'll take a peek when I get a chance. If making some changes meant
the difference between this getting adopted or not, I'd be fine with
most any change;-)

Cheers,
S.

On 17/05/16 21:55, Andrew Mcconachie wrote:
> _______________________________________________
> http-auth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/http-auth
>