Subject: Re: [httpapi] draft-ietf-httpapi-deprecation-header and the status code

From: Roberto Polli <[email-masked]>
Date: Wed, 19 Jan 2022 10:32:28 +0100

Should we explicit that deprecation header is not related to the status
code?

My 2c,
R

Il mar 9 nov 2021, 16:44 Erik Wilde <[email-masked]> ha scritto:

> hello stephane.
>
> On 2021-11-09 16:08, Stephane Bortzmeyer wrote:
> > I do not find a mention of the HTTP status code to use then adding the
> > deprecation header. Does it mean it can be used with 200, 404, 410?
>
> it can (we're not disallowing it), but it probably doesn't make a lot of
> sense to use it on 4xx or 5xx codes, since these indicate a problem that
> has to be resolved. that means that nothing keeps you from using the
> header field with error messages, but it's unlikely that this would be
> very useful.
>
> cheers,
>
> dret.
>
> --
> erik wilde | mailto:[email-masked] |
>             | http://dret.net/netdret    |
>             | http://twitter.com/dret    |
>
> --
> httpapi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/httpapi
>

---

From: Erik Wilde <[email-masked]>
Date: Wed, 19 Jan 2022 10:37:20 -0800

hello roberto.

> Should we explicit that deprecation header is not related to the status 

usually i am not a big fan of listing everything that is not related 
because that list can get long. but if people are thinking this would be 
useful to have then we should probably add it.

https://github.com/ietf-wg-httpapi/deprecation-header/issues/17 is where 
i have created an issue for discussing this. if anybody feels strongly 
about this issue, please comment over there. thanks!

cheers,

dret.

---

From: Roberto Polli <[email-masked]>
Date: Wed, 19 Jan 2022 21:05:26 +0100

Hi Erik,

 I agree with you about listing unrelated things.
For ratelimit we continuously received questions related to
status codes, so we decided to explicit the (un)relations.

Let's see how frequently this question arises, and we'll get an answer :)

Kind regards,
R.

-- 
Roberto Polli
API Expert
M. +39 3406522736
MID
DIPARTIMENTO PER LA
TRASFORMAZIONE
DIGITALE
Presidenza del Consiglio dei Ministri - Ministro per l'innovazione
tecnologica e la digitalizzazione
https://innovazione.gov.it/

Il Dipartimento per la Trasformazione Digitale, salvo eccezioni,
comunica con le altre Amministrazioni via posta elettronica ordinaria
e non posta elettronica certificata, in conformità a quanto previsto
dall’art.47 del Codice dell’Amministrazione Digitale.