Subject: Re: [httpapi] Linkset draft: move from informational to proposed standard?

From: "Salz, Rich" <[email-masked]>
Date: Sat, 22 Jan 2022 15:29:51 +0000

Also speaking as an individual, my answers are yes and yes.

And I want to mention that it was Darrel, in offline conversation, who basically proposed B.

From: Darrel Miller <Darrel.Miller=[email-masked]>
Date: Friday, January 21, 2022 at 5:40 PM
To: "[email-masked]" <[email-masked]>
Cc: Francesca Palombini <[email-masked]>
Subject: Re: [httpapi] Linkset draft: move from informational to proposed standard?

Speaking as an individual, my answers to the questions are yes and yes.

Darrel

From: Salz, Rich<mailto:rsalz=[email-masked]>
Sent: January 21, 2022 3:49 PM
There are two questions I’d like the WG to consider:

  *   A. Should the “linkset” draft be a Proposed Standard?
  *   B. Should we assume everything we do is Proposed Standard unless otherwise discussed?

Please post your thoughts about A and/or B within the next two weeks.

---

From: Francesca Palombini <[email-masked]>
Date: Mon, 24 Jan 2022 13:30:37 +0000

Rich, Darrel, thanks for starting this thread.

As a reviewer of the document, I think this one could be published as either Informational or Proposed Standard. I’ve encountered many documents that aimed to register media-types and the text around is considered informational, so this would not be new. In practice, I agree with Mark. As responsible AD, it is good to have this conversation in the wg and come to a conclusion to motivate the choice, so I will be looking out for the chairs summary. Something to note is that I might need to restart a 2 week Last Call if the working group decides that Proposed standard is the way to go, as the first LC was for Informational (it is easy to change status from Proposed standard to Informational, but the other way requires more care).

Finally for B: I agree with Martin that some chartered items will require something else than Proposed standard. In general, my opinion is that it would be better the working group does not assume anything but rather consider the question of which is the right intended status for each draft, before sending it forward, so the document can be Last Called correctly. If the intended status is obvious, it won’t be much work, but if it is not the question will anyway come up and require motivation at some point during review.

Francesca

From: Salz, Rich <[email-masked]>
Date: Saturday, 22 January 2022 at 16:30
To: Darrel Miller <Darrel.Miller=[email-masked]>, [email-masked] <[email-masked]>
Cc: Francesca Palombini <[email-masked]>
Subject: Re: [httpapi] Linkset draft: move from informational to proposed standard?
Also speaking as an individual, my answers are yes and yes.

Darrel

-          A. Should the “linkset” draft be a Proposed Standard?

-          B. Should we assume everything we do is Proposed Standard unless otherwise discussed?

---

From: Darrel Miller <[email-masked]>
Date: Tue, 25 Jan 2022 04:54:35 +0000

Speaking as an individual, my initial reaction to Mark’s email is to defer to his experience here.  I do agree that we don’t want to overstate our authority and the fact that it is a straightforward process to bring something that is Informational to Proposed Standard is a good thing.

However, I am concerned about repurposing “Informational” because the meaning of “Proposed Standard” has broadened over time.  2026 describes Informational with examples such as:

  *   “things that can’t be practiced”,
  *   descriptions of vendor created protocols,
  *   “work…that has been dropped for some reason”

As Martin rightly called out, “Best practices and other documentation for HTTP API designers” definitely should be considered as Informational.

However, work on HTTP extensions, in my opinion should be indicated as Proposed Standard, as was the original intent of the status, even if we are the new kids on the block.

I will concede that asserting all our efforts should default to “Proposed Standard” is probably not a good idea.  We should probably make the decision on a case by case basis.

Darrel

From: Francesca Palombini<mailto:francesca.palombini=[email-masked]>
Sent: January 24, 2022 8:30 AM
To: Salz, Rich<mailto:[email-masked]>; Darrel Miller<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [httpapi] Linkset draft: move from informational to proposed standard?

Francesca

Darrel