Subject: RE: Security Requirements for HTTP, draft -00

From: Paul Leach <[email-masked]>
Date: Tue, 5 Feb 2008 17:23:41 -0800

From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Sayre
Sent: Thursday, January 31, 2008 12:26 AM

Servers need to be able to ignore message bodies from clients that don't know the shared secret. auth-int requires that the server buffer the entire request before determining that the client knows the shared secret.
[Paul Leach] I agree that this is true, but I don't this is the best way to help people understand the problem. To see this, imagine that the client sent both an "auth" response and an "auth-int" response (disregarding whether that is currently legal). The "auth" response would prove that the client knew the shared secret before the message body is recieved, but that doesn't mean that the server should accept the message body: it still has to wait until it has determined that it hasn't been tampered with by a man-in-the-middle.

Here's another shot at proposed wording:

"Digest includes many modes of operation, but only the simplest modes enjoy any degree of interoperability.  For example, most implementations do not implement the mode that provides full message integrity.  Perhaps one reason is that implementation experience has shown that in some cases,

especially those involving large requests or responses such as streams, the message integrity mode is impractical because it requires servers to analyze the full request before determining whether the client knows the shared secret or whether message-body integrity has been violated and hence whether the request can be processed."

---

From: Robert Sayre <[email-masked]>
Date: Wed, 06 Feb 2008 04:08:38 +0000

On Feb 5, 2008, at 8:23 PM, Paul Leach wrote:
>
> “Digest includes many modes of operation, but only the simplest  
> modes enjoy any degree of interoperability.  For example, most  
> implementations do not implement the mode that provides full message  
> integrity.  Perhaps one reason is that implementation experience has  
> shown that in some cases,
> especially those involving large requests or responses such as  
> streams, the message integrity mode is impractical because it  
> requires servers to analyze the full request before determining  
> whether the client knows the shared secret or whether message-body  
> integrity has been violated and hence whether the request can be  
> processed."

I agree with the substance of this text. I find it a little hard to  
parse, but I trust the editors can remedy that.

- Rob