Subject: Fwd: I-D ACTION:draft-nottingham-http-link-header-01.txt

From: Mark Nottingham <[email-masked]>
Date: Tue, 18 Mar 2008 09:25:34 +1100

As discussed. If there are a few nodding heads here, I'll start  
socialising it with the Atom and HTML/W3C communities to see what they  
think.

Begin forwarded message:

> From: [email-masked]
> Date: 18 March 2008 5:30:01 AM
> To: [email-masked]
> Subject: I-D ACTION:draft-nottingham-http-link-header-01.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> 	Title		: HTTP Header Linking
> 	Author(s)	: M. Nottingham
> 	Filename	: draft-nottingham-http-link-header-01.txt
> 	Pages		: 13
> 	Date		: 2008-3-17
> 	
> This document clarifies the status of the Link HTTP header and
>   attempts to consolidate link relations in a single registry.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-nottingham-http-link-header-01.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

--
Mark Nottingham     http://www.mnot.net/

---

From: "Frank Ellermann" <[email-masked]>
Date: Tue, 18 Mar 2008 10:38:25 +0100

Mark Nottingham wrote:

> If there are a few nodding heads here

Nod, in essence.  Some nits and questions:

Maybe I missed it, but please mention that <URI-reference>
is specified in STD 66.  Some folks confuse URIs with IRIs,
and then get it completely wrong.  This confusion could be
bad enough for a security consideration.

You mention "Made", but you don't list it in the registry.
IMO it should be "made", and you should mention that such
relative URIs are supposed to be case-insensitive.  Maybe
the IANA Webmaster will be annoyed by this idea, and this
needs work (?)

Maybe add "updates 2626" (?) to get rid of it for 2616bis
Maybe deprecate "rev" (?) as proposed by the HTML5 cabale

The XLink stuff muddies the water, please remove it.

We need to find out where "first", "last", and "payment"
were defined.  Has <http://www.w3.org/TR/relations.html>
a status that can be referenced in a RFC ?

 Frank

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 19 Mar 2008 12:06:48 +1100

> bad enough for a security consideration.

Ack.

> the IANA Webmaster will be annoyed by this idea, and this

Will take a look.

> Maybe deprecate "rev" (?) as proposed by the HTML5 cabale

Yeah, been thinking about that. What do others think? Would anyone  
shed a tear if we didn't support rev? This would effectively make it a  
HTML(<5)-specific link-extension.

> The XLink stuff muddies the water, please remove it.

*shrug* I thought it might come up, but AFAICT XLink *is* dead.

> a status that can be referenced in a RFC ?

I registered the Atom 'first' and 'last'; I'll dig up the e-mail. I  
can chase the definition of 'payment', hopefully.

One substantive question for reviewers: is the registration policy too  
open?

Cheers,