Subject: Re: #131: Connection limits (proposal)

From: Mark Nottingham <[email-masked]>
Date: Mon, 30 Nov 2009 17:27:57 +1100

There hasn't been any discussion since, and in the meantime the editors have incorporated the proposal with the modification below;
  http://trac.tools.ietf.org/wg/httpbis/trac/changeset/715

Unless I hear objection I'll close the issue.

On 20/10/2009, at 9:32 AM, Mark Nottingham wrote:

> 
> Adrien proposed:
> 
>> "Implementors of client applications SHOULD give consideration to effects that a client's use of resources may have on the network (both local and non-local), and design clients to act responsibly within any network they participate in.  Some intermediaries and servers are known to limit the number of concurrent connections, or rate of requests.  An excessive number of connections has also been known to cause issues on congested shared networks.  In the past HTTP has recommended a maximum number of concurrent connections a client should make, however this limit has also caused problems in some applications.  It is also believed that any recommendation on number of concurrent connections made now will not apply properly to all applications, and will become obsolete with advances in technology."
> 
> And William proposed:
> 
>>> """
>>> Clients attempting to establish simultaneous connections SHOULD anticipate
>>> the server to reject excessive attempts to establish additional connections,
>>> and gracefully degrade to passing all requests through the successfully
>>> established connection(s), rather than retrying.
>>> """
> 
> My .02 - both of these proposed requirements are quite vague and can't be tested. I'd put forth that client authors know full well whether they're being abusive, and a few sentences in HTTP isn't going to convince them not to be. At the most, we might add something like
> 
> """
> Note that servers might reject traffic that they deem abusive, including an excessive number of connections from a client.
> ""
> 
> (IMHO)
> 
> --
> Mark Nottingham     http://www.mnot.net/
> 
> 

--
Mark Nottingham     http://www.mnot.net/

---

From: "William A. Rowe Jr." <[email-masked]>
Date: Mon, 30 Nov 2009 20:43:32 -0600

>> Note that servers might reject traffic that they deem abusive, including an excessive number of connections from a client.

+1 to this alternate phrasing.