Subject: Re: issue 85 - range unit extensions

From: Kris Zyp <[email-masked]>
Date: Wed, 25 Nov 2009 09:13:42 -0700

Julian Reschke wrote:
> [snip]
>> We'll also need to determine what the requirements for registration
>> are (standards-track?), and set up the registry.
>
> For now we haven't defined a registry (I think the idea was to wait
> for the first use case to come up and then discuss again).
So if I wanted to submit a request to register "items" as a range unit
extension per the discussion in this thread ([1] for reference), is
there a way I could that?

[1] http://markmail.org/message/re6oo4hq3wvt6qhn

- --
Kris Zyp
SitePen
(503) 806-1841
http://sitepen.com

---

From: Julian Reschke <[email-masked]>
Date: Wed, 25 Nov 2009 17:21:52 +0100

Kris Zyp wrote:
> ...

The short answer I think is: not right now.

But even if HTTPbis *did* have the registry now, using it would block 
publication until HTTPbis is ready as well. Would that be acceptable?

BR, Julian

---

From: Kris Zyp <[email-masked]>
Date: Wed, 25 Nov 2009 09:34:51 -0700

Julian Reschke wrote:
> Kris Zyp wrote:
>> Julian Reschke wrote:
>>> [snip]
>>>> We'll also need to determine what the requirements for
>>>> registration are (standards-track?), and set up the registry.
>>>>
>>> For now we haven't defined a registry (I think the idea was to
>>> wait for the first use case to come up and then discuss again).
>>>
>> So if I wanted to submit a request to register "items" as a range
>> unit extension per the discussion in this thread ([1] for
>> reference), is there a way I could that?
>>
>> [1] http://markmail.org/message/re6oo4hq3wvt6qhn ...
>
> But even if HTTPbis *did* have the registry now, using it would
> block publication until HTTPbis is ready as well. Would that be
> acceptable?
Thats fine, I am in no hurry. We'll just plan on registering it at
some point in the future when everything is ready.
Thanks,

- --
Kris Zyp
SitePen
(503) 806-1841
http://sitepen.com

---

From: Adrien de Croy <[email-masked]>
Date: Thu, 26 Nov 2009 10:24:48 +1300

I thought when this was discussed previously it was concluded that range 
unit extensions were a really bad idea, and that they were to be deprecated.

or was that just wishful thinking on my part?

How on earth is a proxy supposed to deal with extensions to range units?

-- 
Adrien de Croy - WinGate Proxy Server - http://www.wingate.com