Subject: Re: I-D Action:draft-dusseault-http-patch-16.txt

From: Julian Reschke <[email-masked]>
Date: Thu, 26 Nov 2009 09:26:11 +0100

(FYI)

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : PATCH Method for HTTP
> 	Author(s)       : L. Dusseault, J. Snell
> 	Filename        : draft-dusseault-http-patch-16.txt
> 	Pages           : 14
> 	Date            : 2009-11-25
> 
> Several applications extending the Hypertext Transfer Protocol (HTTP)
> require a feature to do partial resource modification.  The existing
> HTTP PUT method only allows a complete replacement of a document.
> This proposal adds a new HTTP method, PATCH, to modify an existing
> HTTP resource.
> 
> Status of this Memo
> 
> This Internet-Draft is submitted to IETF in full conformance with the
> provisions of BCP 78 and BCP 79.
> 
> Internet-Drafts are working documents of the Internet Engineering
> Task Force (IETF), its areas, and its working groups.  Note that
> other groups may also distribute working documents as Internet-
> Drafts.
> 
> Internet-Drafts are draft documents valid for a maximum of six months
> and may be updated, replaced, or obsoleted by other documents at any
> time.  It is inappropriate to use Internet-Drafts as reference
> material or to cite them other than as "work in progress."
> 
> The list of current Internet-Drafts can be accessed at
> http://www.ietf.org/ietf/1id-abstracts.txt.
> 
> The list of Internet-Draft Shadow Directories can be accessed at
> http://www.ietf.org/shadow.html.
> 
> This Internet-Draft will expire on May 29, 2010.
> 
> Copyright Notice
> 
> Copyright (c) 2009 IETF Trust and the persons identified as the
> document authors.  All rights reserved.
> 
> This document is subject to BCP 78 and the IETF Trust's Legal
> Provisions Relating to IETF Documents
> (http://trustee.ietf.org/license-info) in effect on the date of
> publication of this document.  Please review these documents
> carefully, as they describe your rights and restrictions with respect
> to this document.  Code Components extracted from this document must
> include Simplified BSD License text as described in Section 4.e of
> the Trust Legal Provisions and are provided without warranty as
> described in the BSD License.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-dusseault-http-patch-16.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: vishvesh raiter <[email-masked]>
Date: Thu, 26 Nov 2009 14:08:42 +0530

Hi,

Please un-subscribe me from this group. I have changed my project.

Regards,

Vishy
 
> Date: Thu, 26 Nov 2009 09:26:11 +0100
> From: [email-masked]
> To: [email-masked]; [email-masked]
> Subject: Re: I-D Action:draft-dusseault-http-patch-16.txt
> 
> (FYI)
> 
 		 	   		  
_________________________________________________________________
Windows 7: Simplify what you do everyday. Find the right PC for you.
http://windows.microsoft.com/shop

---

From: Julian Reschke <[email-masked]>
Date: Thu, 26 Nov 2009 13:58:19 +0100

Hi,

in response to earlier comments the draft now has the following example 
in <http://tools.ietf.org/html/draft-dusseault-http-patch-16#section-2.1>:

--- old ---
    This example illustrates use of a hypothetical patch document on an
    existing resource.  The 204 response code is used because the
    response does not have a body (a response with the 200 code would
    have a body) but other success codes can be used if appropriate.

    Successful PATCH response to existing text file

    HTTP/1.1 204 No Content
    Content-Location: /file.txt
    ETag: "e0023aa4f"
--- old ---

It's good that Content-Location was added, making this consistent with 
the proposed resolution of 
<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/110>.

However, it would be even better it there was a short explanation, such 
as in:

--- new ---
    This example illustrates use of a hypothetical patch document on an
    existing resource.

    Successful PATCH response to existing text file:

    HTTP/1.1 204 No Content
    Content-Location: /file.txt
    ETag: "e0023aa4f"

    The 204 response code is used because the response does not
    carry a message body (which a response with the 200 code would have).
    Note that other success codes could be used as well.

    Futhermore, the ETag response header field contains the ETag for
    the entity created by applying the PATCH, available at
    http://www.example.com/file.txt, as indicated by the Content-Location
    response header field.
--- new ---

This moves part of the explanation below the response, expands on the 
Content-Location thingy and replaces "body" by "message body" (also adds 
a ":" after the subtitle).

Best regards, Julian